OpenWrt Forum Archive

Topic: wrt54gl v1.0 -mmc

The content of this topic has been archived on 2 Feb 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I am sorry if this question has been asked a million times on this forum but I just can't seem to find a solution
I have a version 1.0 running whiterussion, and a 2 gb sd card installed.
My router (so I have read) uses the gpio2 in the mmc.o
I have downloaded and installed just about every mmc.o file on the interweb and none of them seem to be working.
All of the tutorials I have read are for the version 1.1
Is there a difference in the soldering locations between 1.1 and 1.0?
anyhow...
The error I am getting from dmesg is

mmc Hardware init
mmc Card init
mmc Card init
mmc: error in mmc_card_init (1)
mmc: error in mmc_init (-1)


And this is as far as I can get.
When I insmod the mmc.o my orange ses light comes on and I can cd into my /mnt/mmc directory and see files in there but when I do a df -h I do not see anything for the mmc card.




Filesystem                Size      Used Available Use% Mounted on
/dev/root                 1.0M      1.0M         0 100% /rom
none                      7.0M     32.0k      7.0M   0% /tmp
/dev/mtdblock/4           2.2M    892.0k      1.3M  40% /jffs
/jffs                     1.0M      1.0M         0 100% /
root@OpenWrt:/mnt/mmc#



this is also another error I am getting

root@OpenWrt:~# mount /mnt/mmc/
mount: Mounting /dev/mmc/disc0/part1 on /mnt/mmc failed: No such file or directory
root@OpenWrt:~#


Like I said.
I have been fighting with this for weeks and I still can't find a solution.
Is there a thread someone can point me to or maybe have some advice?
Thanks guys.

Ok.
Now I really did it.
I installed a version of dd-wrt that was supposed to have gpio2 mmc and I clicked on 'enable jffs' .
It did not work either so I went back to openwrt and now when I do df -h I get the following.

root@OpenWrt:~$ df -h           
Filesystem                Size      Used Available Use% Mounted on
none                      7.0M     32.0k      7.0M   0% /tmp
/dev/mtdblock/4           1.3M    324.0k   1020.0k  24% /jffs
/jffs                     1.9M      1.9M         0 100% /

It appears that I screwed it up pretty good.
Is there a way that I can get my file system back to the way that it was before?
Will I need to jtag and erase the file system or can I just issue a command and reinstall the firmware?

I'm having the same problem. I tried to use a no-name 32 MB SD card with the wires soldered directly on it. Tried lots of compiled mmc modules, but none worked. dmesg gives me

mmc Hardware init
mmc Card init
mmc Card init
mmc: error in mmc_card_init (1)
mmc: error in mmc_init (-1)

Also, checked the wires with the gpio utility and a multimeter.

With dd-wrt it seems to work (or at least /dev/mmc/[...] is created).

Tomorrow I think I'll buy a new card.

Do you have any idea where the problem may be when using OpenWRT?

LE: Forgot to mention, my router is V 1.1.

(Last edited by BlackNight on 10 Sep 2007, 00:16)

I just bought another wrt54gl v1.1 but have not tried the mmc mod yet.
I will post my results with that one soon.
Maybe this week.

Resoldered some of the wires today and now it works using the optimized driver and OpenWRT Kamikaze.

Edit: Again not working after I assambled (is this the correct term?) my router. But it seems that the memory card is faulty, because now I see that it is not accessible neither with my card reader.

Edit2: It works ok with the new SD card.

(Last edited by BlackNight on 10 Sep 2007, 20:12)

The discussion might have continued from here.