OpenWrt Forum Archive

Topic: Problem flashing openwrt on WRT54GS

The content of this topic has been archived on 22 Jan 2015. There are no obvious gaps in this topic, but there may still be some posts missing at the end.


I have 2 linksys routers, a WRT54G and a WRT54GS.  I built and flashed the openwrt binary for the WRT54G router and everything worked fine.  Now, I'm trying to flash the other router (GS), and tftp keeps telling me that I have an invalid password:

[sam@localhost build_30062004]$ ls
openwrt-g-code.bin  openwrt-gs-code.bin
[sam@localhost build_30062004]$ tftp
tftp> binary
tftp> trace
Packet tracing on.
tftp> rexmt
(value) 1
tftp> put openwrt-gs-code.bin
sent WRQ <file=openwrt-gs-code.bin, mode=octet>
sent WRQ <file=openwrt-gs-code.bin, mode=octet>
sent WRQ <file=openwrt-gs-code.bin, mode=octet>
sent WRQ <file=openwrt-gs-code.bin, mode=octet>
sent WRQ <file=openwrt-gs-code.bin, mode=octet>
sent WRQ <file=openwrt-gs-code.bin, mode=octet>
sent WRQ <file=openwrt-gs-code.bin, mode=octet>
sent WRQ <file=openwrt-gs-code.bin, mode=octet>
sent WRQ <file=openwrt-gs-code.bin, mode=octet>
sent WRQ <file=openwrt-gs-code.bin, mode=octet>
received ERROR <code=100, msg=Invalid Password !!>
Error code 100: Invalid Password !!

Now everything has been done according to what's written on the FAQ (boot_wait is on, I plug the router in after the put command has been sent) and I did exactly the same with my WRT54G (successfully).  I even went back to firmare v2.06.1 to make sure linksys had not put some kind of password protection.

Note that I changed the IP of that router for

Anybody has another way of flashing openwrt on the GS router?



boot_wait mode is ALWAYS!!!!!

it does not matter what you set the ip to, you tftp to

that's its default, boot_wait is before nvram checks

tftp to, and it'l work

you know, I have flashed 5 wrtgs's now, and I swear each one of them seemed like I had to different stuff to get them seems some sort of combination of unplugging it, and holding on the reset button for 10-15 seconds and, plug the power in(while still holding down on the reset) and hit enter on the tftp xfer. I'v also held the reset button for 20 seconds after its powered up and gotten it to take an image -lol

I think it helped me to have a ping -t open on a seperate dos window. you will see it returning a couple of pings and then time out before resuming after its booted up....those couple of pings are the magic window I think

try the reset thing, after making sure boot_wait=on of course

keep screwing with it, it took me 3 hours to get one of my wrt54gs's flashed, and the next one i did took 5 minutes -lol

First of all, thanks for your hints. 

I finally decided to give a try to the update firmware facility from the original linksys administration web page on my router.  I could'n find any information whether or not this would work, and I figured the only way to find out was to try it. 

I was then surprised to see it worked like a charm on my wrt54gs.  Good thing, I would probably have bricked it had it failed.  I still have no clue though as to know if I would be able to go back to linksys original firmware by sending it with tftp.  I might try it soon.

Thanks, and keep posting if you have any other info useful for wrt54gs users out here...


This worked for me too. After reading your post I tried using the Linksys web interface to upload my new firmware and it worked.


I'm not sure if this is because I have a wrt v2.2 but I'm getting the same thing when I try to flash it via tftp. I also tried to flash it using the linksys default front end. I've tried 3 different tftp clients.

Any clues?

Have you tried the tftp method I described in the forum topic:
WRT54G 2.2, boot_wait = ON

This is a guess, but I believe that some tftp clients will try to use a password, while others don't, and apparently a password isn't necessary, but if the tftp client thinks it needs to specify one, you could have this problem.

The discussion might have continued from here.