OpenWrt Forum Archive

Topic: bridge mode

The content of this topic has been archived on 2 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.


I want to connect my PC lan card  to the linksys and then connect to a remote AP. Can I use the WRT54g with OpenWRT as a bridge/client?

What would i need to change?

Thanks in advance,


This is called client mode.
Not sure about OpenWRT options, but if you copy Linksys WL utility, you can set wl ap 0 (client mode).
And you can use wl join <ssid> <key>.

There are some other options also, like macmode, wl scan, wl scanresults.

There's really two options:

client mode
One access point connects as a client to another access point. The access point in client mode cannot except wireless connections.

wl wet 1
wl ap 0
wl join <ssid>


iwconfig eth2 mode managed essid <ssid>

should also work

WDS Bridge / repeater
Two access points communicate using WDS, both access points can accept wireless connections.

wl wds XX:XX:XX:XX:XX:XX
ifconfig wds0.2 up
brctl addif br0 wds0.2

Where XX:XX:XX:XX:XX:XX is the wireless mac address of the remote access point. Both access points need to be configured on the same channel with the same wireless options. You can use "wl lazywds 1" to specify that all wds connections should be accepted, however you will still need to add the resulting wds interface to the bridge.

To simplify wds connections you can create a /sbin/hotplug which will be called whenever a new wds interface is created:

[ "${INTERFACE%%[0-9]*}" = "wds" ] && { 
ifconfig $INTERFACE up
/usr/sbin/brctl addif br0 $INTERFACE

Now you can just use "wl lazywds 1" on one end and "wl wds xx:xx:xx..." on the other end and the interfaces will automatically be added to the bridge.

I tried the following:

wl wet 1
wl ap 0
wl join <SSID> <PASSWORD>

I am able connect to the internet via the machine connected to the WRT54G, including DNS traffic (IE browsing works).

But, also from another machine on another wireless router that is on the LAN, I am not able to ping that machine connected to the WRT54G router above.     

Are there anything else I should check, change?

The discussion might have continued from here.