OpenWrt Forum Archive

Topic: [SOLVED] Help with routing ovpn-traffic

The content of this topic has been archived on 27 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello,

i try to setup ovpn on my openwrt-router for 3 days. The tunnel works perfect but i cant ping local computers when connected with vpn.

Here is my config:

root@OpenWrt:~# cat /tmp/openvpn.log
cat: can't open '/tmp/openvpn.log': No such file or directory
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd22:4803:25e0::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr '10:0d:7f:52:9c:52'
        option ipaddr '10.0.0.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option macaddr '10:0d:7f:52:9c:53'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 5'

config interface 'vpn0'
        option ifname 'tun0'
        option proto 'none'
        option auto '1'

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config rule
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule 'Allow_OpenVPN_Inbound'
        option target 'ACCEPT'
        option src '*'
        option proto 'udp'
        option dest_port '1194'

config zone 'vpn'
        option name 'vpn'
        option network 'vpn0'
        option input 'ACCEPT'
        option forward 'REJECT'
        option output 'ACCEPT'
        option masq '1'

config forwarding 'vpn_forwarding_lan_in'
        option src 'vpn'
        option dest 'lan'

config forwarding 'vpn_forwarding_lan_out'
        option src 'lan'
        option dest 'vpn'

config forwarding 'vpn_forwarding_wan'
        option src 'vpn'
        option dest 'wan'
config route6
        option interface 'wan'
        option source '10.8.0.0/28'
        option target '10.0.0.0/26'
config rule
    option  target          'ACCEPT'
    option  family          'ipv4'
    option  proto           'tcp udp'
    option  src             '*'
    option  src_ip          '10.8.0.0/28'
    option  dest_ip         '10.0.0.0/26'
    option  name            'Allow VPN0 -> LAN'

root@OpenWrt:~# cat /etc/config/openvpn

I think it's just a "touting problem" but i cant find the answer by myself...

Hopefully someone can help me here?!


Best regards,
Niko

ps.: I'm not a native english speaker; So please go easy on me smile

(Last edited by NixXxon on 22 Mar 2017, 16:21)

Oh, are you unable to ping to local computer from the openwrt device? Or are you having a problem pinging from one computer to another?

Also, could you post the output of "netstat -rn" on the openwrt device? This will help us understand exactly how things are effectively routed. (Not just what a config SAYS it should do, but what it is actually doing.)


I'm not going to lie, I'm super rusty at configuring OpenVPN, but I do think that the questions I asked will help others even if I have some difficulty helping you. lol I'll be sure to try though! (Subjects like this tend to come back to me randomly hours after reading stuff, so yes.. )

Hello,

thank you for the fast answer! Sorry for the short description of my problem. I was short before throwing the router + Laptop out of my windows, yesterday smile

Lets say A is my laptop with installed ovpn-client and B is my router / vpn server.
A is able to connect to B and get an 10.8.0.X adress.
B has the IP 10.0.0.1
I want to reach a share from 10.0.0.44 (wich is a computer in my network). But I'm not even able to ping B or 10.0.0.44 from A.

Here is the output of netstat -rn:

root@OpenWrt:~# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         80.X.X.X     0.0.0.0         UG        0 0          0 eth0.2
10.0.0.0        0.0.0.0         255.255.255.0   U         0 0          0 br-lan
10.8.0.0        10.8.0.2        255.255.255.0   UG        0 0          0 tun0
10.8.0.2        0.0.0.0         255.255.255.255 UH        0 0          0 tun0
80.X.X.X     0.0.0.0         255.255.255.0   U         0 0          0 eth0.2
80.X.X.X     0.0.0.0         255.255.255.255 UH        0 0          0 eth0.2
root@OpenWrt:~#

I "X'ed" out my public IP ;-)

Thank you a lot for helping me!

p.S.: another problem: I dont have WAN Access over VPN. So when i'm connected i cant access the internet. But maybe one Problem after the other?!

To sum up, you have OpenWRT router running OpenVPN-server, and laptop, running OpenVPN-client. Bring its OpenVPN-configs.

It is topic of General Discussion, not Community Documentation.

(Last edited by ulmwind on 19 Mar 2017, 16:13)

Sorry for posting in the wrong section. Wasnt really sure where to post. Cant find the option to move the topic.

Herr is my client.conf:

client
dev tun
proto udp
log openvpn.log
verb 7
ca ca.crt
cert my-client1.crt
key my-client1.key
remote-cert-tls server
remote mydddns.com 1194
comp-lzo
nobind
route 10.0.0.0 255.255.255.0

And my server config:

config openvpn 'myvpn'
    option enabled '1'
    option verb '3'
    option port '1194'
    option proto 'udp'
    option dev 'tun'
    option server '10.8.0.1 255.255.255.0'
    option keepalive '10 120'
    option ca '/etc/openvpn/ca.crt'
    option cert '/etc/openvpn/my-server.crt'
    option key '/etc/openvpn/my-server.key'
    option dh '/etc/openvpn/dh2048.pem'
    list push 'route 10.0.0.0 255.255.255.0'
    option push "redirect-gateway def1 bypass-dhcp"
    local 10.0.0.0

(Last edited by NixXxon on 19 Mar 2017, 17:13)

Does your server have IP 10.0.0.0?
Try to replace
in client config:

#route 10.0.0.0 255.255.255.0

in server config:

#list push 'route 10.0.0.0 255.255.255.0'
option push "redirect-gateway def1"

(Last edited by ulmwind on 19 Mar 2017, 16:56)

My Server has the internal IP 10.0.0.1
I think i messed something up with trying arround.
At the moment i'm not able anymore to connect.

It now looks like this:

Server Conf:

root@OpenWrt:~# cat /etc/config/openvpn
config openvpn 'myvpn'
        option enabled '1'
        option verb '3'
        option port '1194'
        option proto 'udp'
        option dev 'tun'
        option server '10.8.0.1 255.255.255.0'
        option keepalive '10 120'
        option ca '/etc/openvpn/ca.crt'
        option cert '/etc/openvpn/my-server.crt'
        option key '/etc/openvpn/my-server.key'
        option dh '/etc/openvpn/dh2048.pem'
        #list push 'route 10.0.0.0 255.255.255.0'
        option push "redirect-gateway def1"
        local 10.0.0.1root@OpenWrt:~#

Server Log: n/A

Netstat output:

root@OpenWrt:~# netstat -rn
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         X.X.X.1     0.0.0.0         UG        0 0          0 eth0.2
10.0.0.0        0.0.0.0         255.255.255.0   U         0 0          0 br-lan
X.X.X.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0.2
X.X.X.1     0.0.0.0         255.255.255.255 UH        0 0          0 eth0.2

Network:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd22:4803:25e0::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option macaddr '10:0d:7f:52:9c:52'
        option ipaddr '10.0.0.1'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option macaddr '10:0d:7f:52:9c:53'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0t 1 2 3 4'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 5'

config interface 'vpn0'
        option proto 'none'
        option auto '1'
        option type 'bridge'
        option _orig_ifname 'tun0'
        option _orig_bridge 'true'
        option ifname 'eth0.1 tun0'

Firewall:

root@OpenWrt:~# cat /etc/config/firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option src_ip 'fe80::/10'
        option src_port '547'
        option dest_ip 'fe80::/10'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config include
        option path '/etc/firewall.user'

config rule
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

config rule 'Allow_OpenVPN_Inbound'
        option target 'ACCEPT'
        option src '*'
        option proto 'udp'
        option dest_port '1194'

config zone 'vpn'
        option name 'vpn'
        option network 'vpn0'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option masq '1'
        option forward 'ACCEPT'

config forwarding 'vpn_forwarding_lan_in'
        option src 'vpn'
        option dest 'lan'

config forwarding 'vpn_forwarding_lan_out'
        option src 'lan'
        option dest 'vpn'

config forwarding 'vpn_forwarding_wan'
        option src 'vpn'
        option dest 'wan'

config route6
        option interface 'wan'
        option source '10.8.0.0/28'
        option target '10.0.0.0/26'

config rule
        option target 'ACCEPT'
        option family 'ipv4'
        option proto 'tcp udp'
        option src '*'
        option src_ip '10.8.0.0/28'
        option dest_ip '10.0.0.0/26'
        option name 'Allow VPN0 -> LAN'

config redirect
        option target 'DNAT'
        option src 'wan'
        option dest 'lan'
        option proto 'tcp'
        option src_dport '3389'
        option dest_ip '10.0.0.44'
        option dest_port '3389'
        option name 'RDP'

config rule
        option enabled '1'
        option target 'ACCEPT'
        option src 'vpn'
        option dest 'lan'
        option name 'VPN-FORWARD-DEL'

p.s.
Client Log:

Sun Mar 19 17:28:51 2017 us=235234 Current Parameter Settings:
Sun Mar 19 17:28:51 2017 us=236231   config = 'openvpn_bcn.ovpn'
Sun Mar 19 17:28:51 2017 us=236231   mode = 0
Sun Mar 19 17:28:51 2017 us=236231   show_ciphers = DISABLED
Sun Mar 19 17:28:51 2017 us=236231   show_digests = DISABLED
Sun Mar 19 17:28:51 2017 us=236231   show_engines = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   genkey = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   key_pass_file = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   show_tls_ciphers = DISABLED
Sun Mar 19 17:28:51 2017 us=237232 Connection profiles [default]:
Sun Mar 19 17:28:51 2017 us=237232   proto = udp
Sun Mar 19 17:28:51 2017 us=237232   local = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   local_port = 1194
Sun Mar 19 17:28:51 2017 us=237232   remote = 'myddns.com'
Sun Mar 19 17:28:51 2017 us=237232   remote_port = 1194
Sun Mar 19 17:28:51 2017 us=237232   remote_float = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   bind_defined = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   bind_local = ENABLED
Sun Mar 19 17:28:51 2017 us=237232   connect_retry_seconds = 5
Sun Mar 19 17:28:51 2017 us=237232   connect_timeout = 10
Sun Mar 19 17:28:51 2017 us=237232   connect_retry_max = 0
Sun Mar 19 17:28:51 2017 us=237232   socks_proxy_server = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   socks_proxy_port = 0
Sun Mar 19 17:28:51 2017 us=237232   socks_proxy_retry = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   tun_mtu = 1500
Sun Mar 19 17:28:51 2017 us=237232   tun_mtu_defined = ENABLED
Sun Mar 19 17:28:51 2017 us=237232   link_mtu = 1500
Sun Mar 19 17:28:51 2017 us=237232   link_mtu_defined = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   tun_mtu_extra = 0
Sun Mar 19 17:28:51 2017 us=237232   tun_mtu_extra_defined = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   mtu_discover_type = -1
Sun Mar 19 17:28:51 2017 us=237232   fragment = 0
Sun Mar 19 17:28:51 2017 us=237232   mssfix = 1450
Sun Mar 19 17:28:51 2017 us=237232   explicit_exit_notification = 0
Sun Mar 19 17:28:51 2017 us=237232 Connection profiles END
Sun Mar 19 17:28:51 2017 us=237232   remote_random = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   ipchange = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   dev = 'tun'
Sun Mar 19 17:28:51 2017 us=237232   dev_type = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   dev_node = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   lladdr = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   topology = 1
Sun Mar 19 17:28:51 2017 us=237232   tun_ipv6 = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   ifconfig_local = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   ifconfig_remote_netmask = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   ifconfig_noexec = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   ifconfig_nowarn = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   ifconfig_ipv6_local = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   ifconfig_ipv6_netbits = 0
Sun Mar 19 17:28:51 2017 us=237232   ifconfig_ipv6_remote = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   shaper = 0
Sun Mar 19 17:28:51 2017 us=237232   mtu_test = 0
Sun Mar 19 17:28:51 2017 us=237232   mlock = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   keepalive_ping = 0
Sun Mar 19 17:28:51 2017 us=237232   keepalive_timeout = 0
Sun Mar 19 17:28:51 2017 us=237232   inactivity_timeout = 0
Sun Mar 19 17:28:51 2017 us=237232   ping_send_timeout = 0
Sun Mar 19 17:28:51 2017 us=237232   ping_rec_timeout = 0
Sun Mar 19 17:28:51 2017 us=237232   ping_rec_timeout_action = 0
Sun Mar 19 17:28:51 2017 us=237232   ping_timer_remote = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   remap_sigusr1 = 0
Sun Mar 19 17:28:51 2017 us=237232   persist_tun = ENABLED
Sun Mar 19 17:28:51 2017 us=237232   persist_local_ip = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   persist_remote_ip = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   persist_key = ENABLED
Sun Mar 19 17:28:51 2017 us=237232   passtos = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   resolve_retry_seconds = 1000000000
Sun Mar 19 17:28:51 2017 us=237232   username = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   groupname = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   chroot_dir = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   cd_dir = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   writepid = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   up_script = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   down_script = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   down_pre = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   up_restart = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   up_delay = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   daemon = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   inetd = 0
Sun Mar 19 17:28:51 2017 us=237232   log = ENABLED
Sun Mar 19 17:28:51 2017 us=237232   suppress_timestamps = DISABLED
Sun Mar 19 17:28:51 2017 us=237232   nice = 0
Sun Mar 19 17:28:51 2017 us=237232   verbosity = 4
Sun Mar 19 17:28:51 2017 us=237232   mute = 0
Sun Mar 19 17:28:51 2017 us=237232   gremlin = 0
Sun Mar 19 17:28:51 2017 us=237232   status_file = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=237232   status_file_version = 1
Sun Mar 19 17:28:51 2017 us=237232   status_file_update_freq = 60
Sun Mar 19 17:28:51 2017 us=237232   occ = ENABLED
Sun Mar 19 17:28:51 2017 us=237232   rcvbuf = 0
Sun Mar 19 17:28:51 2017 us=237232   sndbuf = 0
Sun Mar 19 17:28:51 2017 us=237232   sockflags = 0
Sun Mar 19 17:28:51 2017 us=237232   fast_io = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   lzo = 7
Sun Mar 19 17:28:51 2017 us=238232   route_script = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   route_default_gateway = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   route_default_metric = 0
Sun Mar 19 17:28:51 2017 us=238232   route_noexec = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   route_delay = 5
Sun Mar 19 17:28:51 2017 us=238232   route_delay_window = 30
Sun Mar 19 17:28:51 2017 us=238232   route_delay_defined = ENABLED
Sun Mar 19 17:28:51 2017 us=238232   route_nopull = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   route_gateway_via_dhcp = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   max_routes = 100
Sun Mar 19 17:28:51 2017 us=238232   allow_pull_fqdn = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   management_addr = '127.0.0.1'
Sun Mar 19 17:28:51 2017 us=238232   management_port = 25342
Sun Mar 19 17:28:51 2017 us=238232   management_user_pass = 'stdin'
Sun Mar 19 17:28:51 2017 us=238232   management_log_history_cache = 250
Sun Mar 19 17:28:51 2017 us=238232   management_echo_buffer_size = 100
Sun Mar 19 17:28:51 2017 us=238232   management_write_peer_info_file = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   management_client_user = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   management_client_group = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   management_flags = 6
Sun Mar 19 17:28:51 2017 us=238232   shared_secret_file = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   key_direction = 0
Sun Mar 19 17:28:51 2017 us=238232   ciphername_defined = ENABLED
Sun Mar 19 17:28:51 2017 us=238232   ciphername = 'BF-CBC'
Sun Mar 19 17:28:51 2017 us=238232   authname_defined = ENABLED
Sun Mar 19 17:28:51 2017 us=238232   authname = 'SHA1'
Sun Mar 19 17:28:51 2017 us=238232   prng_hash = 'SHA1'
Sun Mar 19 17:28:51 2017 us=238232   prng_nonce_secret_len = 16
Sun Mar 19 17:28:51 2017 us=238232   keysize = 0
Sun Mar 19 17:28:51 2017 us=238232   engine = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   replay = ENABLED
Sun Mar 19 17:28:51 2017 us=238232   mute_replay_warnings = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   replay_window = 64
Sun Mar 19 17:28:51 2017 us=238232   replay_time = 15
Sun Mar 19 17:28:51 2017 us=238232   packet_id_file = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   use_iv = ENABLED
Sun Mar 19 17:28:51 2017 us=238232   test_crypto = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   tls_server = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   tls_client = ENABLED
Sun Mar 19 17:28:51 2017 us=238232   key_method = 2
Sun Mar 19 17:28:51 2017 us=238232   ca_file = 'ca.crt'
Sun Mar 19 17:28:51 2017 us=238232   ca_path = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   dh_file = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   cert_file = 'my-client1.crt'
Sun Mar 19 17:28:51 2017 us=238232   extra_certs_file = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   priv_key_file = 'my-client1.key'
Sun Mar 19 17:28:51 2017 us=238232   pkcs12_file = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   cryptoapi_cert = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   cipher_list = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   tls_verify = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   tls_export_cert = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   verify_x509_type = 0
Sun Mar 19 17:28:51 2017 us=238232   verify_x509_name = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   crl_file = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   ns_cert_type = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 160
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 136
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_ku[i] = 0
Sun Mar 19 17:28:51 2017 us=238232   remote_cert_eku = 'TLS Web Server Authentication'
Sun Mar 19 17:28:51 2017 us=238232   ssl_flags = 0
Sun Mar 19 17:28:51 2017 us=238232   tls_timeout = 2
Sun Mar 19 17:28:51 2017 us=238232   renegotiate_bytes = -1
Sun Mar 19 17:28:51 2017 us=238232   renegotiate_packets = 0
Sun Mar 19 17:28:51 2017 us=238232   renegotiate_seconds = 3600
Sun Mar 19 17:28:51 2017 us=238232   handshake_window = 60
Sun Mar 19 17:28:51 2017 us=238232   transition_window = 3600
Sun Mar 19 17:28:51 2017 us=238232   single_session = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   push_peer_info = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   tls_exit = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   tls_auth_file = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=238232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=238232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_private_mode = 00000000
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_cert_private = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_pin_cache_period = -1
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_id = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=239232   pkcs11_id_management = DISABLED
Sun Mar 19 17:28:51 2017 us=239232   server_network = 0.0.0.0
Sun Mar 19 17:28:51 2017 us=239232   server_netmask = 0.0.0.0
Sun Mar 19 17:28:51 2017 us=240233   server_network_ipv6 = ::
Sun Mar 19 17:28:51 2017 us=240233   server_netbits_ipv6 = 0
Sun Mar 19 17:28:51 2017 us=240233   server_bridge_ip = 0.0.0.0
Sun Mar 19 17:28:51 2017 us=240233   server_bridge_netmask = 0.0.0.0
Sun Mar 19 17:28:51 2017 us=241234   server_bridge_pool_start = 0.0.0.0
Sun Mar 19 17:28:51 2017 us=241234   server_bridge_pool_end = 0.0.0.0
Sun Mar 19 17:28:51 2017 us=241234   ifconfig_pool_defined = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   ifconfig_pool_start = 0.0.0.0
Sun Mar 19 17:28:51 2017 us=241234   ifconfig_pool_end = 0.0.0.0
Sun Mar 19 17:28:51 2017 us=241234   ifconfig_pool_netmask = 0.0.0.0
Sun Mar 19 17:28:51 2017 us=241234   ifconfig_pool_persist_filename = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=241234   ifconfig_pool_persist_refresh_freq = 600
Sun Mar 19 17:28:51 2017 us=241234   ifconfig_ipv6_pool_defined = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   ifconfig_ipv6_pool_base = ::
Sun Mar 19 17:28:51 2017 us=241234   ifconfig_ipv6_pool_netbits = 0
Sun Mar 19 17:28:51 2017 us=241234   n_bcast_buf = 256
Sun Mar 19 17:28:51 2017 us=241234   tcp_queue_limit = 64
Sun Mar 19 17:28:51 2017 us=241234   real_hash_size = 256
Sun Mar 19 17:28:51 2017 us=241234   virtual_hash_size = 256
Sun Mar 19 17:28:51 2017 us=241234   client_connect_script = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=241234   learn_address_script = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=241234   client_disconnect_script = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=241234   client_config_dir = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=241234   ccd_exclusive = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   tmp_dir = 'C:\Users\NIKOR_~1\AppData\Local\Temp\'
Sun Mar 19 17:28:51 2017 us=241234   push_ifconfig_defined = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   push_ifconfig_local = 0.0.0.0
Sun Mar 19 17:28:51 2017 us=241234   push_ifconfig_remote_netmask = 0.0.0.0
Sun Mar 19 17:28:51 2017 us=241234   push_ifconfig_ipv6_defined = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   push_ifconfig_ipv6_local = ::/0
Sun Mar 19 17:28:51 2017 us=241234   push_ifconfig_ipv6_remote = ::
Sun Mar 19 17:28:51 2017 us=241234   enable_c2c = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   duplicate_cn = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   cf_max = 0
Sun Mar 19 17:28:51 2017 us=241234   cf_per = 0
Sun Mar 19 17:28:51 2017 us=241234   max_clients = 1024
Sun Mar 19 17:28:51 2017 us=241234   max_routes_per_client = 256
Sun Mar 19 17:28:51 2017 us=241234   auth_user_pass_verify_script = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=241234   auth_user_pass_verify_script_via_file = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   client = ENABLED
Sun Mar 19 17:28:51 2017 us=241234   pull = ENABLED
Sun Mar 19 17:28:51 2017 us=241234   auth_user_pass_file = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=241234   show_net_up = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   route_method = 0
Sun Mar 19 17:28:51 2017 us=241234   block_outside_dns = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   ip_win32_defined = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   ip_win32_type = 3
Sun Mar 19 17:28:51 2017 us=241234   dhcp_masq_offset = 0
Sun Mar 19 17:28:51 2017 us=241234   dhcp_lease_time = 31536000
Sun Mar 19 17:28:51 2017 us=241234   tap_sleep = 0
Sun Mar 19 17:28:51 2017 us=241234   dhcp_options = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   dhcp_renew = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   dhcp_pre_release = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   dhcp_release = DISABLED
Sun Mar 19 17:28:51 2017 us=241234   domain = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=241234   netbios_scope = '[UNDEF]'
Sun Mar 19 17:28:51 2017 us=241234   netbios_node_type = 0
Sun Mar 19 17:28:51 2017 us=241234   disable_nbt = DISABLED
Sun Mar 19 17:28:51 2017 us=241234 OpenVPN 2.3.13 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Nov  3 2016
Sun Mar 19 17:28:51 2017 us=241234 Windows version 6.2 (Windows 8 or greater) 64bit
Sun Mar 19 17:28:51 2017 us=241234 library versions: OpenSSL 1.0.1u  22 Sep 2016, LZO 2.09
Enter Management Password:
Sun Mar 19 17:28:51 2017 us=242235 MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:25342
Sun Mar 19 17:28:51 2017 us=242235 Need hold release from management interface, waiting...
Sun Mar 19 17:28:51 2017 us=707565 MANAGEMENT: Client connected from [AF_INET]127.0.0.1:25342
Sun Mar 19 17:28:51 2017 us=808636 MANAGEMENT: CMD 'state on'
Sun Mar 19 17:28:51 2017 us=808636 MANAGEMENT: CMD 'log all on'
Sun Mar 19 17:28:51 2017 us=990766 MANAGEMENT: CMD 'hold off'
Sun Mar 19 17:28:51 2017 us=993769 MANAGEMENT: CMD 'hold release'
Sun Mar 19 17:28:52 2017 us=137870 LZO compression initialized
Sun Mar 19 17:28:52 2017 us=137870 Control Channel MTU parms [ L:1542 D:1212 EF:38 EB:0 ET:0 EL:3 ]
Sun Mar 19 17:28:52 2017 us=137870 Socket Buffers: R=[65536->65536] S=[65536->65536]
Sun Mar 19 17:28:52 2017 us=137870 MANAGEMENT: >STATE:1489940932,RESOLVE,,,
Sun Mar 19 17:28:52 2017 us=262960 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:143 ET:0 EL:3 AF:3/1 ]
Sun Mar 19 17:28:52 2017 us=262960 Local Options String: 'V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client'
Sun Mar 19 17:28:52 2017 us=262960 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-server'
Sun Mar 19 17:28:52 2017 us=262960 Local Options hash (VER=V4): '41690919'
Sun Mar 19 17:28:52 2017 us=262960 Expected Remote Options hash (VER=V4): '530fdded'
Sun Mar 19 17:28:52 2017 us=262960 UDPv4 link local (bound): [undef]
Sun Mar 19 17:28:52 2017 us=262960 UDPv4 link remote: [AF_INET]X.X.X.X:1194
Sun Mar 19 17:28:52 2017 us=262960 MANAGEMENT: >STATE:1489940932,WAIT,,,
Sun Mar 19 17:29:30 2017 us=275945 MANAGEMENT: CMD 'signal SIGHUP'
Sun Mar 19 17:29:30 2017 us=276947 TCP/UDP: Closing socket
Sun Mar 19 17:29:30 2017 us=276947 SIGHUP[hard,] received, process restarting
Sun Mar 19 17:29:30 2017 us=276947 MANAGEMENT: >STATE:1489940970,RECONNECTING,SIGHUP,,
Sun Mar 19 17:29:30 2017 us=276947 Current Parameter Settings:
Sun Mar 19 17:29:30 2017 us=276947   config = 'openvpn_bcn.ovpn'
Sun Mar 19 17:29:30 2017 us=276947   mode = 0
Sun Mar 19 17:29:30 2017 us=276947   show_ciphers = DISABLED
Sun Mar 19 17:29:30 2017 us=276947   show_digests = DISABLED
Sun Mar 19 17:29:30 2017 us=276947   show_engines = DISABLED
Sun Mar 19 17:29:30 2017 us=277948   genkey = DISABLED
Sun Mar 19 17:29:30 2017 us=277948   key_pass_file = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=277948   show_tls_ciphers = DISABLED
Sun Mar 19 17:29:30 2017 us=277948 Connection profiles [default]:
Sun Mar 19 17:29:30 2017 us=277948   proto = udp
Sun Mar 19 17:29:30 2017 us=277948   local = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=277948   local_port = 1194
Sun Mar 19 17:29:30 2017 us=277948   remote = 'myddns.com'
Sun Mar 19 17:29:30 2017 us=277948   remote_port = 1194
Sun Mar 19 17:29:30 2017 us=277948   remote_float = DISABLED
Sun Mar 19 17:29:30 2017 us=277948   bind_defined = DISABLED
Sun Mar 19 17:29:30 2017 us=277948   bind_local = ENABLED
Sun Mar 19 17:29:30 2017 us=277948   connect_retry_seconds = 5
Sun Mar 19 17:29:30 2017 us=277948   connect_timeout = 10
Sun Mar 19 17:29:30 2017 us=277948   connect_retry_max = 0
Sun Mar 19 17:29:30 2017 us=277948   socks_proxy_server = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=277948   socks_proxy_port = 0
Sun Mar 19 17:29:30 2017 us=277948   socks_proxy_retry = DISABLED
Sun Mar 19 17:29:30 2017 us=277948   tun_mtu = 1500
Sun Mar 19 17:29:30 2017 us=277948   tun_mtu_defined = ENABLED
Sun Mar 19 17:29:30 2017 us=277948   link_mtu = 1500
Sun Mar 19 17:29:30 2017 us=277948   link_mtu_defined = DISABLED
Sun Mar 19 17:29:30 2017 us=277948   tun_mtu_extra = 0
Sun Mar 19 17:29:30 2017 us=277948   tun_mtu_extra_defined = DISABLED
Sun Mar 19 17:29:30 2017 us=277948   mtu_discover_type = -1
Sun Mar 19 17:29:30 2017 us=277948   fragment = 0
Sun Mar 19 17:29:30 2017 us=277948   mssfix = 1450
Sun Mar 19 17:29:30 2017 us=277948   explicit_exit_notification = 0
Sun Mar 19 17:29:30 2017 us=277948 Connection profiles END
Sun Mar 19 17:29:30 2017 us=277948   remote_random = DISABLED
Sun Mar 19 17:29:30 2017 us=278948   ipchange = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=278948   dev = 'tun'
Sun Mar 19 17:29:30 2017 us=278948   dev_type = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=278948   dev_node = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=278948   lladdr = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=278948   topology = 1
Sun Mar 19 17:29:30 2017 us=278948   tun_ipv6 = DISABLED
Sun Mar 19 17:29:30 2017 us=278948   ifconfig_local = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=278948   ifconfig_remote_netmask = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=278948   ifconfig_noexec = DISABLED
Sun Mar 19 17:29:30 2017 us=278948   ifconfig_nowarn = DISABLED
Sun Mar 19 17:29:30 2017 us=278948   ifconfig_ipv6_local = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=278948   ifconfig_ipv6_netbits = 0
Sun Mar 19 17:29:30 2017 us=278948   ifconfig_ipv6_remote = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=278948   shaper = 0
Sun Mar 19 17:29:30 2017 us=278948   mtu_test = 0
Sun Mar 19 17:29:30 2017 us=278948   mlock = DISABLED
Sun Mar 19 17:29:30 2017 us=278948   keepalive_ping = 0
Sun Mar 19 17:29:30 2017 us=278948   keepalive_timeout = 0
Sun Mar 19 17:29:30 2017 us=278948   inactivity_timeout = 0
Sun Mar 19 17:29:30 2017 us=278948   ping_send_timeout = 0
Sun Mar 19 17:29:30 2017 us=278948   ping_rec_timeout = 0
Sun Mar 19 17:29:30 2017 us=278948   ping_rec_timeout_action = 0
Sun Mar 19 17:29:30 2017 us=278948   ping_timer_remote = DISABLED
Sun Mar 19 17:29:30 2017 us=278948   remap_sigusr1 = 0
Sun Mar 19 17:29:30 2017 us=278948   persist_tun = ENABLED
Sun Mar 19 17:29:30 2017 us=278948   persist_local_ip = DISABLED
Sun Mar 19 17:29:30 2017 us=278948   persist_remote_ip = DISABLED
Sun Mar 19 17:29:30 2017 us=278948   persist_key = ENABLED
Sun Mar 19 17:29:30 2017 us=278948   passtos = DISABLED
Sun Mar 19 17:29:30 2017 us=278948   resolve_retry_seconds = 1000000000
Sun Mar 19 17:29:30 2017 us=279949   username = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=279949   groupname = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=279949   chroot_dir = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=279949   cd_dir = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=279949   writepid = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=279949   up_script = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=279949   down_script = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=279949   down_pre = DISABLED
Sun Mar 19 17:29:30 2017 us=279949   up_restart = DISABLED
Sun Mar 19 17:29:30 2017 us=279949   up_delay = DISABLED
Sun Mar 19 17:29:30 2017 us=279949   daemon = DISABLED
Sun Mar 19 17:29:30 2017 us=279949   inetd = 0
Sun Mar 19 17:29:30 2017 us=279949   log = ENABLED
Sun Mar 19 17:29:30 2017 us=279949   suppress_timestamps = DISABLED
Sun Mar 19 17:29:30 2017 us=279949   nice = 0
Sun Mar 19 17:29:30 2017 us=279949   verbosity = 5
Sun Mar 19 17:29:30 2017 us=279949   mute = 0
Sun Mar 19 17:29:30 2017 us=279949   gremlin = 0
Sun Mar 19 17:29:30 2017 us=279949   status_file = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=279949   status_file_version = 1
Sun Mar 19 17:29:30 2017 us=279949   status_file_update_freq = 60
Sun Mar 19 17:29:30 2017 us=279949   occ = ENABLED
Sun Mar 19 17:29:30 2017 us=279949   rcvbuf = 0
Sun Mar 19 17:29:30 2017 us=279949   sndbuf = 0
Sun Mar 19 17:29:30 2017 us=279949   sockflags = 0
Sun Mar 19 17:29:30 2017 us=279949   fast_io = DISABLED
Sun Mar 19 17:29:30 2017 us=279949   lzo = 7
Sun Mar 19 17:29:30 2017 us=279949   route_script = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=279949   route_default_gateway = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=279949   route_default_metric = 0
Sun Mar 19 17:29:30 2017 us=279949   route_noexec = DISABLED
Sun Mar 19 17:29:30 2017 us=279949   route_delay = 5
Sun Mar 19 17:29:30 2017 us=280950   route_delay_window = 30
Sun Mar 19 17:29:30 2017 us=280950   route_delay_defined = ENABLED
Sun Mar 19 17:29:30 2017 us=280950   route_nopull = DISABLED
Sun Mar 19 17:29:30 2017 us=280950   route_gateway_via_dhcp = DISABLED
Sun Mar 19 17:29:30 2017 us=280950   max_routes = 100
Sun Mar 19 17:29:30 2017 us=280950   allow_pull_fqdn = DISABLED
Sun Mar 19 17:29:30 2017 us=280950   management_addr = '127.0.0.1'
Sun Mar 19 17:29:30 2017 us=280950   management_port = 25342
Sun Mar 19 17:29:30 2017 us=280950   management_user_pass = 'stdin'
Sun Mar 19 17:29:30 2017 us=280950   management_log_history_cache = 250
Sun Mar 19 17:29:30 2017 us=280950   management_echo_buffer_size = 100
Sun Mar 19 17:29:30 2017 us=280950   management_write_peer_info_file = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=280950   management_client_user = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=280950   management_client_group = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=280950   management_flags = 6
Sun Mar 19 17:29:30 2017 us=280950   shared_secret_file = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=280950   key_direction = 0
Sun Mar 19 17:29:30 2017 us=280950   ciphername_defined = ENABLED
Sun Mar 19 17:29:30 2017 us=280950   ciphername = 'BF-CBC'
Sun Mar 19 17:29:30 2017 us=280950   authname_defined = ENABLED
Sun Mar 19 17:29:30 2017 us=280950   authname = 'SHA1'
Sun Mar 19 17:29:30 2017 us=280950   prng_hash = 'SHA1'
Sun Mar 19 17:29:30 2017 us=280950   prng_nonce_secret_len = 16
Sun Mar 19 17:29:30 2017 us=280950   keysize = 0
Sun Mar 19 17:29:30 2017 us=280950   engine = DISABLED
Sun Mar 19 17:29:30 2017 us=280950   replay = ENABLED
Sun Mar 19 17:29:30 2017 us=280950   mute_replay_warnings = DISABLED
Sun Mar 19 17:29:30 2017 us=280950   replay_window = 64
Sun Mar 19 17:29:30 2017 us=280950   replay_time = 15
Sun Mar 19 17:29:30 2017 us=280950   packet_id_file = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=281950   use_iv = ENABLED
Sun Mar 19 17:29:30 2017 us=281950   test_crypto = DISABLED
Sun Mar 19 17:29:30 2017 us=281950   tls_server = DISABLED
Sun Mar 19 17:29:30 2017 us=281950   tls_client = ENABLED
Sun Mar 19 17:29:30 2017 us=281950   key_method = 2
Sun Mar 19 17:29:30 2017 us=281950   ca_file = 'ca.crt'
Sun Mar 19 17:29:30 2017 us=281950   ca_path = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=281950   dh_file = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=281950   cert_file = 'my-client1.crt'
Sun Mar 19 17:29:30 2017 us=281950   extra_certs_file = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=281950   priv_key_file = 'my-client1.key'
Sun Mar 19 17:29:30 2017 us=281950   pkcs12_file = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=281950   cryptoapi_cert = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=281950   cipher_list = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=281950   tls_verify = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=281950   tls_export_cert = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=281950   verify_x509_type = 0
Sun Mar 19 17:29:30 2017 us=281950   verify_x509_name = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=281950   crl_file = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=281950   ns_cert_type = 0
Sun Mar 19 17:29:30 2017 us=281950   remote_cert_ku[i] = 160
Sun Mar 19 17:29:30 2017 us=281950   remote_cert_ku[i] = 136
Sun Mar 19 17:29:30 2017 us=281950   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=281950   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=281950   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=281950   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=282951   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=282951   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=282951   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=282951   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=282951   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=282951   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=282951   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=282951   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=282951   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=282951   remote_cert_ku[i] = 0
Sun Mar 19 17:29:30 2017 us=282951   remote_cert_eku = 'TLS Web Server Authentication'
Sun Mar 19 17:29:30 2017 us=282951   ssl_flags = 0
Sun Mar 19 17:29:30 2017 us=282951   tls_timeout = 2
Sun Mar 19 17:29:30 2017 us=282951   renegotiate_bytes = -1
Sun Mar 19 17:29:30 2017 us=282951   renegotiate_packets = 0
Sun Mar 19 17:29:30 2017 us=282951   renegotiate_seconds = 3600
Sun Mar 19 17:29:30 2017 us=282951   handshake_window = 60
Sun Mar 19 17:29:30 2017 us=282951   transition_window = 3600
Sun Mar 19 17:29:30 2017 us=282951   single_session = DISABLED
Sun Mar 19 17:29:30 2017 us=282951   push_peer_info = DISABLED
Sun Mar 19 17:29:30 2017 us=282951   tls_exit = DISABLED
Sun Mar 19 17:29:30 2017 us=282951   tls_auth_file = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=282951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=282951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=282951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=282951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=282951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=282951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=283951   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_pin_cache_period = -1
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_id = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=284952   pkcs11_id_management = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   server_network = 0.0.0.0
Sun Mar 19 17:29:30 2017 us=284952   server_netmask = 0.0.0.0
Sun Mar 19 17:29:30 2017 us=284952   server_network_ipv6 = ::
Sun Mar 19 17:29:30 2017 us=284952   server_netbits_ipv6 = 0
Sun Mar 19 17:29:30 2017 us=284952   server_bridge_ip = 0.0.0.0
Sun Mar 19 17:29:30 2017 us=284952   server_bridge_netmask = 0.0.0.0
Sun Mar 19 17:29:30 2017 us=284952   server_bridge_pool_start = 0.0.0.0
Sun Mar 19 17:29:30 2017 us=284952   server_bridge_pool_end = 0.0.0.0
Sun Mar 19 17:29:30 2017 us=284952   ifconfig_pool_defined = DISABLED
Sun Mar 19 17:29:30 2017 us=284952   ifconfig_pool_start = 0.0.0.0
Sun Mar 19 17:29:30 2017 us=284952   ifconfig_pool_end = 0.0.0.0
Sun Mar 19 17:29:30 2017 us=285953   ifconfig_pool_netmask = 0.0.0.0
Sun Mar 19 17:29:30 2017 us=285953   ifconfig_pool_persist_filename = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=285953   ifconfig_pool_persist_refresh_freq = 600
Sun Mar 19 17:29:30 2017 us=285953   ifconfig_ipv6_pool_defined = DISABLED
Sun Mar 19 17:29:30 2017 us=285953   ifconfig_ipv6_pool_base = ::
Sun Mar 19 17:29:30 2017 us=285953   ifconfig_ipv6_pool_netbits = 0
Sun Mar 19 17:29:30 2017 us=285953   n_bcast_buf = 256
Sun Mar 19 17:29:30 2017 us=285953   tcp_queue_limit = 64
Sun Mar 19 17:29:30 2017 us=285953   real_hash_size = 256
Sun Mar 19 17:29:30 2017 us=285953   virtual_hash_size = 256
Sun Mar 19 17:29:30 2017 us=285953   client_connect_script = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=285953   learn_address_script = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=285953   client_disconnect_script = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=285953   client_config_dir = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=285953   ccd_exclusive = DISABLED
Sun Mar 19 17:29:30 2017 us=285953   tmp_dir = 'C:\Users\NIKOR_~1\AppData\Local\Temp\'
Sun Mar 19 17:29:30 2017 us=285953   push_ifconfig_defined = DISABLED
Sun Mar 19 17:29:30 2017 us=285953   push_ifconfig_local = 0.0.0.0
Sun Mar 19 17:29:30 2017 us=285953   push_ifconfig_remote_netmask = 0.0.0.0
Sun Mar 19 17:29:30 2017 us=285953   push_ifconfig_ipv6_defined = DISABLED
Sun Mar 19 17:29:30 2017 us=285953   push_ifconfig_ipv6_local = ::/0
Sun Mar 19 17:29:30 2017 us=285953   push_ifconfig_ipv6_remote = ::
Sun Mar 19 17:29:30 2017 us=285953   enable_c2c = DISABLED
Sun Mar 19 17:29:30 2017 us=285953   duplicate_cn = DISABLED
Sun Mar 19 17:29:30 2017 us=285953   cf_max = 0
Sun Mar 19 17:29:30 2017 us=285953   cf_per = 0
Sun Mar 19 17:29:30 2017 us=286954   max_clients = 1024
Sun Mar 19 17:29:30 2017 us=286954   max_routes_per_client = 256
Sun Mar 19 17:29:30 2017 us=286954   auth_user_pass_verify_script = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=286954   auth_user_pass_verify_script_via_file = DISABLED
Sun Mar 19 17:29:30 2017 us=286954   client = ENABLED
Sun Mar 19 17:29:30 2017 us=286954   pull = ENABLED
Sun Mar 19 17:29:30 2017 us=286954   auth_user_pass_file = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=286954   show_net_up = DISABLED
Sun Mar 19 17:29:30 2017 us=286954   route_method = 0
Sun Mar 19 17:29:30 2017 us=286954   block_outside_dns = DISABLED
Sun Mar 19 17:29:30 2017 us=286954   ip_win32_defined = DISABLED
Sun Mar 19 17:29:30 2017 us=286954   ip_win32_type = 3
Sun Mar 19 17:29:30 2017 us=286954   dhcp_masq_offset = 0
Sun Mar 19 17:29:30 2017 us=286954   dhcp_lease_time = 31536000
Sun Mar 19 17:29:30 2017 us=286954   tap_sleep = 0
Sun Mar 19 17:29:30 2017 us=286954   dhcp_options = DISABLED
Sun Mar 19 17:29:30 2017 us=286954   dhcp_renew = DISABLED
Sun Mar 19 17:29:30 2017 us=286954   dhcp_pre_release = DISABLED
Sun Mar 19 17:29:30 2017 us=286954   dhcp_release = DISABLED
Sun Mar 19 17:29:30 2017 us=286954   domain = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=286954   netbios_scope = '[UNDEF]'
Sun Mar 19 17:29:30 2017 us=286954   netbios_node_type = 0
Sun Mar 19 17:29:30 2017 us=286954   disable_nbt = DISABLED
Sun Mar 19 17:29:30 2017 us=286954 OpenVPN 2.3.13 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Nov  3 2016
Sun Mar 19 17:29:30 2017 us=286954 Windows version 6.2 (Windows 8 or greater) 64bit
Sun Mar 19 17:29:30 2017 us=286954 library versions: OpenSSL 1.0.1u  22 Sep 2016, LZO 2.09
Sun Mar 19 17:29:30 2017 us=286954 Restart pause, 2 second(s)
Sun Mar 19 17:29:32 2017 us=290376 LZO compression initialized
Sun Mar 19 17:29:32 2017 us=290376 Control Channel MTU parms [ L:1542 D:1212 EF:38 EB:0 ET:0 EL:3 ]
Sun Mar 19 17:29:32 2017 us=290376 Socket Buffers: R=[65536->65536] S=[65536->65536]
Sun Mar 19 17:29:32 2017 us=290376 MANAGEMENT: >STATE:1489940972,RESOLVE,,,
Sun Mar 19 17:29:32 2017 us=290376 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:143 ET:0 EL:3 AF:3/1 ]
Sun Mar 19 17:29:32 2017 us=290376 Local Options String: 'V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client'
Sun Mar 19 17:29:32 2017 us=290376 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-server'
Sun Mar 19 17:29:32 2017 us=290376 Local Options hash (VER=V4): '41690919'
Sun Mar 19 17:29:32 2017 us=290376 Expected Remote Options hash (VER=V4): '530fdded'
Sun Mar 19 17:29:32 2017 us=291377 UDPv4 link local (bound): [undef]
Sun Mar 19 17:29:32 2017 us=291377 UDPv4 link remote: [AF_INET]X.X.X.X:1194
Sun Mar 19 17:29:32 2017 us=291377 MANAGEMENT: >STATE:1489940972,WAIT,,,
Sun Mar 19 17:29:47 2017 us=880444 MANAGEMENT: CMD 'signal SIGHUP'
Sun Mar 19 17:29:47 2017 us=880444 TCP/UDP: Closing socket
Sun Mar 19 17:29:47 2017 us=881445 SIGHUP[hard,] received, process restarting
Sun Mar 19 17:29:47 2017 us=881445 MANAGEMENT: >STATE:1489940987,RECONNECTING,SIGHUP,,
Sun Mar 19 17:29:47 2017 us=881445 Current Parameter Settings:
Sun Mar 19 17:29:47 2017 us=881445   config = 'openvpn_bcn.ovpn'
Sun Mar 19 17:29:47 2017 us=881445   mode = 0
Sun Mar 19 17:29:47 2017 us=881445   show_ciphers = DISABLED
Sun Mar 19 17:29:47 2017 us=881445   show_digests = DISABLED
Sun Mar 19 17:29:47 2017 us=881445   show_engines = DISABLED
Sun Mar 19 17:29:47 2017 us=881445   genkey = DISABLED
Sun Mar 19 17:29:47 2017 us=881445   key_pass_file = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=881445   show_tls_ciphers = DISABLED
Sun Mar 19 17:29:47 2017 us=881445 Connection profiles [default]:
Sun Mar 19 17:29:47 2017 us=881445   proto = udp
Sun Mar 19 17:29:47 2017 us=881445   local = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=881445   local_port = 1194
Sun Mar 19 17:29:47 2017 us=881445   remote = 'myddns.com'
Sun Mar 19 17:29:47 2017 us=881445   remote_port = 1194
Sun Mar 19 17:29:47 2017 us=881445   remote_float = DISABLED
Sun Mar 19 17:29:47 2017 us=882445   bind_defined = DISABLED
Sun Mar 19 17:29:47 2017 us=882445   bind_local = ENABLED
Sun Mar 19 17:29:47 2017 us=882445   connect_retry_seconds = 5
Sun Mar 19 17:29:47 2017 us=882445   connect_timeout = 10
Sun Mar 19 17:29:47 2017 us=882445   connect_retry_max = 0
Sun Mar 19 17:29:47 2017 us=882445   socks_proxy_server = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=882445   socks_proxy_port = 0
Sun Mar 19 17:29:47 2017 us=882445   socks_proxy_retry = DISABLED
Sun Mar 19 17:29:47 2017 us=882445   tun_mtu = 1500
Sun Mar 19 17:29:47 2017 us=882445   tun_mtu_defined = ENABLED
Sun Mar 19 17:29:47 2017 us=882445   link_mtu = 1500
Sun Mar 19 17:29:47 2017 us=882445   link_mtu_defined = DISABLED
Sun Mar 19 17:29:47 2017 us=882445   tun_mtu_extra = 0
Sun Mar 19 17:29:47 2017 us=882445   tun_mtu_extra_defined = DISABLED
Sun Mar 19 17:29:47 2017 us=882445   mtu_discover_type = -1
Sun Mar 19 17:29:47 2017 us=882445   fragment = 0
Sun Mar 19 17:29:47 2017 us=882445   mssfix = 1450
Sun Mar 19 17:29:47 2017 us=882445   explicit_exit_notification = 0
Sun Mar 19 17:29:47 2017 us=882445 Connection profiles END
Sun Mar 19 17:29:47 2017 us=882445   remote_random = DISABLED
Sun Mar 19 17:29:47 2017 us=882445   ipchange = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=882445   dev = 'tun'
Sun Mar 19 17:29:47 2017 us=882445   dev_type = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=882445   dev_node = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=882445   lladdr = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=882445   topology = 1
Sun Mar 19 17:29:47 2017 us=882445   tun_ipv6 = DISABLED
Sun Mar 19 17:29:47 2017 us=882445   ifconfig_local = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=882445   ifconfig_remote_netmask = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=882445   ifconfig_noexec = DISABLED
Sun Mar 19 17:29:47 2017 us=882445   ifconfig_nowarn = DISABLED
Sun Mar 19 17:29:47 2017 us=882445   ifconfig_ipv6_local = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=882445   ifconfig_ipv6_netbits = 0
Sun Mar 19 17:29:47 2017 us=883446   ifconfig_ipv6_remote = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=883446   shaper = 0
Sun Mar 19 17:29:47 2017 us=883446   mtu_test = 0
Sun Mar 19 17:29:47 2017 us=883446   mlock = DISABLED
Sun Mar 19 17:29:47 2017 us=883446   keepalive_ping = 0
Sun Mar 19 17:29:47 2017 us=883446   keepalive_timeout = 0
Sun Mar 19 17:29:47 2017 us=883446   inactivity_timeout = 0
Sun Mar 19 17:29:47 2017 us=883446   ping_send_timeout = 0
Sun Mar 19 17:29:47 2017 us=883446   ping_rec_timeout = 0
Sun Mar 19 17:29:47 2017 us=883446   ping_rec_timeout_action = 0
Sun Mar 19 17:29:47 2017 us=883446   ping_timer_remote = DISABLED
Sun Mar 19 17:29:47 2017 us=883446   remap_sigusr1 = 0
Sun Mar 19 17:29:47 2017 us=883446   persist_tun = ENABLED
Sun Mar 19 17:29:47 2017 us=883446   persist_local_ip = DISABLED
Sun Mar 19 17:29:47 2017 us=883446   persist_remote_ip = DISABLED
Sun Mar 19 17:29:47 2017 us=883446   persist_key = ENABLED
Sun Mar 19 17:29:47 2017 us=883446   passtos = DISABLED
Sun Mar 19 17:29:47 2017 us=883446   resolve_retry_seconds = 1000000000
Sun Mar 19 17:29:47 2017 us=883446   username = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=883446   groupname = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=883446   chroot_dir = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=883446   cd_dir = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=883446   writepid = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=883446   up_script = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=883446   down_script = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=883446   down_pre = DISABLED
Sun Mar 19 17:29:47 2017 us=883446   up_restart = DISABLED
Sun Mar 19 17:29:47 2017 us=883446   up_delay = DISABLED
Sun Mar 19 17:29:47 2017 us=883446   daemon = DISABLED
Sun Mar 19 17:29:47 2017 us=883446   inetd = 0
Sun Mar 19 17:29:47 2017 us=883446   log = ENABLED
Sun Mar 19 17:29:47 2017 us=883446   suppress_timestamps = DISABLED
Sun Mar 19 17:29:47 2017 us=884447   nice = 0
Sun Mar 19 17:29:47 2017 us=884447   verbosity = 6
Sun Mar 19 17:29:47 2017 us=884447   mute = 0
Sun Mar 19 17:29:47 2017 us=884447   gremlin = 0
Sun Mar 19 17:29:47 2017 us=884447   status_file = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=884447   status_file_version = 1
Sun Mar 19 17:29:47 2017 us=884447   status_file_update_freq = 60
Sun Mar 19 17:29:47 2017 us=884447   occ = ENABLED
Sun Mar 19 17:29:47 2017 us=884447   rcvbuf = 0
Sun Mar 19 17:29:47 2017 us=884447   sndbuf = 0
Sun Mar 19 17:29:47 2017 us=884447   sockflags = 0
Sun Mar 19 17:29:47 2017 us=884447   fast_io = DISABLED
Sun Mar 19 17:29:47 2017 us=884447   lzo = 7
Sun Mar 19 17:29:47 2017 us=884447   route_script = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=884447   route_default_gateway = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=884447   route_default_metric = 0
Sun Mar 19 17:29:47 2017 us=884447   route_noexec = DISABLED
Sun Mar 19 17:29:47 2017 us=884447   route_delay = 5
Sun Mar 19 17:29:47 2017 us=884447   route_delay_window = 30
Sun Mar 19 17:29:47 2017 us=884447   route_delay_defined = ENABLED
Sun Mar 19 17:29:47 2017 us=884447   route_nopull = DISABLED
Sun Mar 19 17:29:47 2017 us=884447   route_gateway_via_dhcp = DISABLED
Sun Mar 19 17:29:47 2017 us=884447   max_routes = 100
Sun Mar 19 17:29:47 2017 us=884447   allow_pull_fqdn = DISABLED
Sun Mar 19 17:29:47 2017 us=884447   management_addr = '127.0.0.1'
Sun Mar 19 17:29:47 2017 us=884447   management_port = 25342
Sun Mar 19 17:29:47 2017 us=884447   management_user_pass = 'stdin'
Sun Mar 19 17:29:47 2017 us=884447   management_log_history_cache = 250
Sun Mar 19 17:29:47 2017 us=884447   management_echo_buffer_size = 100
Sun Mar 19 17:29:47 2017 us=884447   management_write_peer_info_file = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=884447   management_client_user = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=884447   management_client_group = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=884447   management_flags = 6
Sun Mar 19 17:29:47 2017 us=885447   shared_secret_file = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=885447   key_direction = 0
Sun Mar 19 17:29:47 2017 us=885447   ciphername_defined = ENABLED
Sun Mar 19 17:29:47 2017 us=885447   ciphername = 'BF-CBC'
Sun Mar 19 17:29:47 2017 us=885447   authname_defined = ENABLED
Sun Mar 19 17:29:47 2017 us=885447   authname = 'SHA1'
Sun Mar 19 17:29:47 2017 us=885447   prng_hash = 'SHA1'
Sun Mar 19 17:29:47 2017 us=885447   prng_nonce_secret_len = 16
Sun Mar 19 17:29:47 2017 us=885447   keysize = 0
Sun Mar 19 17:29:47 2017 us=885447   engine = DISABLED
Sun Mar 19 17:29:47 2017 us=885447   replay = ENABLED
Sun Mar 19 17:29:47 2017 us=885447   mute_replay_warnings = DISABLED
Sun Mar 19 17:29:47 2017 us=885447   replay_window = 64
Sun Mar 19 17:29:47 2017 us=885447   replay_time = 15
Sun Mar 19 17:29:47 2017 us=885447   packet_id_file = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=885447   use_iv = ENABLED
Sun Mar 19 17:29:47 2017 us=885447   test_crypto = DISABLED
Sun Mar 19 17:29:47 2017 us=885447   tls_server = DISABLED
Sun Mar 19 17:29:47 2017 us=885447   tls_client = ENABLED
Sun Mar 19 17:29:47 2017 us=885447   key_method = 2
Sun Mar 19 17:29:47 2017 us=885447   ca_file = 'ca.crt'
Sun Mar 19 17:29:47 2017 us=885447   ca_path = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=885447   dh_file = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=885447   cert_file = 'my-client1.crt'
Sun Mar 19 17:29:47 2017 us=885447   extra_certs_file = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=885447   priv_key_file = 'my-client1.key'
Sun Mar 19 17:29:47 2017 us=885447   pkcs12_file = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=885447   cryptoapi_cert = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=885447   cipher_list = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=885447   tls_verify = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=885447   tls_export_cert = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=885447   verify_x509_type = 0
Sun Mar 19 17:29:47 2017 us=886448   verify_x509_name = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=886448   crl_file = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=886448   ns_cert_type = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 160
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 136
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_ku[i] = 0
Sun Mar 19 17:29:47 2017 us=886448   remote_cert_eku = 'TLS Web Server Authentication'
Sun Mar 19 17:29:47 2017 us=886448   ssl_flags = 0
Sun Mar 19 17:29:47 2017 us=886448   tls_timeout = 2
Sun Mar 19 17:29:47 2017 us=886448   renegotiate_bytes = -1
Sun Mar 19 17:29:47 2017 us=886448   renegotiate_packets = 0
Sun Mar 19 17:29:47 2017 us=886448   renegotiate_seconds = 3600
Sun Mar 19 17:29:47 2017 us=886448   handshake_window = 60
Sun Mar 19 17:29:47 2017 us=886448   transition_window = 3600
Sun Mar 19 17:29:47 2017 us=886448   single_session = DISABLED
Sun Mar 19 17:29:47 2017 us=886448   push_peer_info = DISABLED
Sun Mar 19 17:29:47 2017 us=886448   tls_exit = DISABLED
Sun Mar 19 17:29:47 2017 us=886448   tls_auth_file = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=886448   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=886448   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_protected_authentication = DISABLED
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_private_mode = 00000000
Sun Mar 19 17:29:47 2017 us=887449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_cert_private = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_pin_cache_period = -1
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_id = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=888449   pkcs11_id_management = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   server_network = 0.0.0.0
Sun Mar 19 17:29:47 2017 us=888449   server_netmask = 0.0.0.0
Sun Mar 19 17:29:47 2017 us=888449   server_network_ipv6 = ::
Sun Mar 19 17:29:47 2017 us=888449   server_netbits_ipv6 = 0
Sun Mar 19 17:29:47 2017 us=888449   server_bridge_ip = 0.0.0.0
Sun Mar 19 17:29:47 2017 us=888449   server_bridge_netmask = 0.0.0.0
Sun Mar 19 17:29:47 2017 us=888449   server_bridge_pool_start = 0.0.0.0
Sun Mar 19 17:29:47 2017 us=888449   server_bridge_pool_end = 0.0.0.0
Sun Mar 19 17:29:47 2017 us=888449   ifconfig_pool_defined = DISABLED
Sun Mar 19 17:29:47 2017 us=888449   ifconfig_pool_start = 0.0.0.0
Sun Mar 19 17:29:47 2017 us=888449   ifconfig_pool_end = 0.0.0.0
Sun Mar 19 17:29:47 2017 us=888449   ifconfig_pool_netmask = 0.0.0.0
Sun Mar 19 17:29:47 2017 us=888449   ifconfig_pool_persist_filename = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=888449   ifconfig_pool_persist_refresh_freq = 600
Sun Mar 19 17:29:47 2017 us=889450   ifconfig_ipv6_pool_defined = DISABLED
Sun Mar 19 17:29:47 2017 us=889450   ifconfig_ipv6_pool_base = ::
Sun Mar 19 17:29:47 2017 us=889450   ifconfig_ipv6_pool_netbits = 0
Sun Mar 19 17:29:47 2017 us=889450   n_bcast_buf = 256
Sun Mar 19 17:29:47 2017 us=889450   tcp_queue_limit = 64
Sun Mar 19 17:29:47 2017 us=889450   real_hash_size = 256
Sun Mar 19 17:29:47 2017 us=889450   virtual_hash_size = 256
Sun Mar 19 17:29:47 2017 us=889450   client_connect_script = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=889450   learn_address_script = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=889450   client_disconnect_script = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=889450   client_config_dir = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=889450   ccd_exclusive = DISABLED
Sun Mar 19 17:29:47 2017 us=889450   tmp_dir = 'C:\Users\NIKOR_~1\AppData\Local\Temp\'
Sun Mar 19 17:29:47 2017 us=889450   push_ifconfig_defined = DISABLED
Sun Mar 19 17:29:47 2017 us=889450   push_ifconfig_local = 0.0.0.0
Sun Mar 19 17:29:47 2017 us=889450   push_ifconfig_remote_netmask = 0.0.0.0
Sun Mar 19 17:29:47 2017 us=889450   push_ifconfig_ipv6_defined = DISABLED
Sun Mar 19 17:29:47 2017 us=889450   push_ifconfig_ipv6_local = ::/0
Sun Mar 19 17:29:47 2017 us=889450   push_ifconfig_ipv6_remote = ::
Sun Mar 19 17:29:47 2017 us=889450   enable_c2c = DISABLED
Sun Mar 19 17:29:47 2017 us=889450   duplicate_cn = DISABLED
Sun Mar 19 17:29:47 2017 us=889450   cf_max = 0
Sun Mar 19 17:29:47 2017 us=889450   cf_per = 0
Sun Mar 19 17:29:47 2017 us=889450   max_clients = 1024
Sun Mar 19 17:29:47 2017 us=889450   max_routes_per_client = 256
Sun Mar 19 17:29:47 2017 us=889450   auth_user_pass_verify_script = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=889450   auth_user_pass_verify_script_via_file = DISABLED
Sun Mar 19 17:29:47 2017 us=889450   client = ENABLED
Sun Mar 19 17:29:47 2017 us=889450   pull = ENABLED
Sun Mar 19 17:29:47 2017 us=889450   auth_user_pass_file = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=889450   show_net_up = DISABLED
Sun Mar 19 17:29:47 2017 us=889450   route_method = 0
Sun Mar 19 17:29:47 2017 us=890451   block_outside_dns = DISABLED
Sun Mar 19 17:29:47 2017 us=890451   ip_win32_defined = DISABLED
Sun Mar 19 17:29:47 2017 us=890451   ip_win32_type = 3
Sun Mar 19 17:29:47 2017 us=890451   dhcp_masq_offset = 0
Sun Mar 19 17:29:47 2017 us=890451   dhcp_lease_time = 31536000
Sun Mar 19 17:29:47 2017 us=890451   tap_sleep = 0
Sun Mar 19 17:29:47 2017 us=890451   dhcp_options = DISABLED
Sun Mar 19 17:29:47 2017 us=890451   dhcp_renew = DISABLED
Sun Mar 19 17:29:47 2017 us=890451   dhcp_pre_release = DISABLED
Sun Mar 19 17:29:47 2017 us=890451   dhcp_release = DISABLED
Sun Mar 19 17:29:47 2017 us=890451   domain = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=890451   netbios_scope = '[UNDEF]'
Sun Mar 19 17:29:47 2017 us=890451   netbios_node_type = 0
Sun Mar 19 17:29:47 2017 us=890451   disable_nbt = DISABLED
Sun Mar 19 17:29:47 2017 us=890451 OpenVPN 2.3.13 x86_64-w64-mingw32 [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Nov  3 2016
Sun Mar 19 17:29:47 2017 us=890451 Windows version 6.2 (Windows 8 or greater) 64bit
Sun Mar 19 17:29:47 2017 us=890451 library versions: OpenSSL 1.0.1u  22 Sep 2016, LZO 2.09
Sun Mar 19 17:29:47 2017 us=890451 Restart pause, 2 second(s)
Sun Mar 19 17:29:49 2017 us=894874 LZO compression initialized
Sun Mar 19 17:29:49 2017 us=894874 Control Channel MTU parms [ L:1542 D:1212 EF:38 EB:0 ET:0 EL:3 ]
Sun Mar 19 17:29:49 2017 us=894874 Socket Buffers: R=[65536->65536] S=[65536->65536]
Sun Mar 19 17:29:49 2017 us=894874 MANAGEMENT: >STATE:1489940989,RESOLVE,,,
Sun Mar 19 17:29:49 2017 us=895874 Data Channel MTU parms [ L:1542 D:1450 EF:42 EB:143 ET:0 EL:3 AF:3/1 ]
Sun Mar 19 17:29:49 2017 us=895874 Local Options String: 'V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-client'
Sun Mar 19 17:29:49 2017 us=895874 Expected Remote Options String: 'V4,dev-type tun,link-mtu 1542,tun-mtu 1500,proto UDPv4,comp-lzo,cipher BF-CBC,auth SHA1,keysize 128,key-method 2,tls-server'
Sun Mar 19 17:29:49 2017 us=895874 Local Options hash (VER=V4): '41690919'
Sun Mar 19 17:29:49 2017 us=895874 Expected Remote Options hash (VER=V4): '530fdded'
Sun Mar 19 17:29:49 2017 us=895874 UDPv4 link local (bound): [undef]
Sun Mar 19 17:29:49 2017 us=895874 UDPv4 link remote: [AF_INET]X.X.X.X:1194
Sun Mar 19 17:29:49 2017 us=895874 MANAGEMENT: >STATE:1489940989,WAIT,,,
Sun Mar 19 17:29:49 2017 us=895874 UDPv4 WRITE [14] to [AF_INET]X.X.X.X:1194: P_CONTROL_HARD_RESET_CLIENT_V2 kid=0 [ ] pid=0 DATA len=0
Sun Mar 19 17:29:51 2017 us=925315 UDPv4 WRITE [14] to [AF_INET]X.X.X.X:1194: P_CONTROL_HARD_RESET_CLIENT_V2 kid=0 [ ] pid=0 DATA len=0
Sun Mar 19 17:29:55 2017 us=984198 UDPv4 WRITE [14] to [AF_INET]X.X.X.X:1194: P_CONTROL_HARD_RESET_CLIENT_V2 kid=0 [ ] pid=0 DATA len=0
WWWW

OK - i managed to get it working again BUT i still cant access any computer in my network when im connected to VPN:

Here is my "working" config:

Server-Conf:

config openvpn 'myvpn'
    option enabled '1'
    option verb '3'
    option port '1194'
    option proto 'udp'
    option dev 'tun'
    option server '10.8.0.0 255.255.255.0'
    option keepalive '10 120'
    option ca '/etc/openvpn/ca.crt'
    option cert '/etc/openvpn/my-server.crt'
    option key '/etc/openvpn/my-server.key'
    option dh '/etc/openvpn/dh2048.pem'

Client-Conf:

dev tun
proto udp

log openvpn.log
verb 7

ca ca.crt
cert my-client1.crt
key my-client1.key

client
remote-cert-tls server
remote myddns.com 1194

persist-key
persist-tun

Output of netstat:

Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
0.0.0.0         X.X.X.1     0.0.0.0         UG        0 0          0 eth0.2
10.0.0.0        0.0.0.0         255.255.255.0   U         0 0          0 br-lan
10.8.0.0        10.8.0.2        255.255.255.0   UG        0 0          0 tun0
10.8.0.2        0.0.0.0         255.255.255.255 UH        0 0          0 tun0
X.X.X.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0.2
X.X.X.1     0.0.0.0         255.255.255.255 UH        0 0          0 eth0.2

p.S.: And sorry for answering so much to my own post.

(Last edited by NixXxon on 19 Mar 2017, 19:39)

As far as I've understood, tun ip of router is 10.8.0.1, lan ip is 10.0.0.1, you want to connect to computers in lan. Can you ping 10.0.0.1 from laptop running OpenVPN-client?

Yes.
Tun-IP of my router is 10.8.0.1
Lan-IP of my router is 10.0.0.1

And yes i want to connect to computers in the lan (acutally only to one specific computer 10.0.0.44).

No, i cant ping 10.0.0.1 when connected with OVPN but of course i can ping 10.8.0.1.

(Last edited by NixXxon on 19 Mar 2017, 22:05)

In manual https://wiki.openwrt.org/doc/howto/vpn. … wrt_router I see strange thing:

uci set firewall.vpn=zone
uci set firewall.vpn.name=vpn
uci set firewall.vpn.network=vpn0
uci set firewall.vpn.input=ACCEPT
uci set firewall.vpn.forward=REJECT
uci set firewall.vpn.output=ACCEPT
uci set firewall.vpn.masq=1

I don't understand, why for server masq=1. Try to remove option

uci set firewall.vpn.masq=1

However, it doesn't matter in ping from vpn to lan. Try to remove following sections from firewall config:

config rule
        option target 'ACCEPT'
        option family 'ipv4'
        option proto 'tcp udp'
        option src '*'
        option src_ip '10.8.0.0/28'
        option dest_ip '10.0.0.0/26'
        option name 'Allow VPN0 -> LAN'
config rule
        option enabled '1'
        option target 'ACCEPT'
        option src 'vpn'
        option dest 'lan'
        option name 'VPN-FORWARD-DEL'

(Last edited by ulmwind on 19 Mar 2017, 22:36)

I removed the mentioned lines and reloaded the firewall but I still cant ping any host in my network. Any other ideas?

I'm really not a network-pro but isn't it possible that i "just" need a working route from vlan 10.8.0.0 255.255.255.0 to 10.0.0.0 255.255.255.0?

Btw. i already tried to disabled the firewall completely - after doing that i wasnt able to connect at all. (maybe that helps)?

HAH ... i got it! I changed the following:

Client-Conf:

# VPN default settings
client
port 1194
remote myddns.com
dev tun
proto udp

# Certificate files for OpenWrt access
ca ca.crt
cert my-client1.crt
key my-client1.key

# default redirect through VPN
# Enable when you want to route all traffic through VPN
redirect-gateway def1
dhcp-option DNS 8.8.8.8
route 10.8.0.0 255.255.250.0

# network configuration
comp-lzo
nobind
auth-nocache
script-security 2
persist-key
persist-tun

Server-Conf 1:

package openvpn

config openvpn myvpn
        # Set to 1 to enable this instance:
        option enable 1

        # Include OpenVPN configuration
        option config /etc/openvpn/server.ovpn

Server-Conf 2:

port 1194

proto udp

dev tun

ca ca.crt
cert my-server.crt
key my-server.key  # This file should be kept secret
dh dh2048.pem

server 10.8.0.0 255.255.255.0

ifconfig-pool-persist ipp.txt

keepalive 10 120
comp-lzo
persist-key
persist-tun
verb 3

Thank you really a lot for your time and help! hopefully my topic will someday help someone else with the same problem!

Well after a bit of testing it came up that it's not completly done.

The connection works more or less fine but it's not really stable. When i access ressources from 10.0.0.44 or any other client in my network i get a lot of these warnings:

Authenticate/Decrypt packet error: bad packet ID

I read about switching to tcp instead of udp; but can this really be the only solution? And if so; Am i right that i "only" have to change "udp" to "tcp" in the firewall rules, network-conf and the ovpn-config (client & server)?

Good, the issue was in routing on client (earlier you've posted routes on server). It would be next debugging stage.

Concerning current issue try to play with MTU options:

tun-mtu
tun-mtu-extra
mssfix

Begin with

tun-mtu 1500

You can also add option

mtu-test

and run client. It will test connection and print determined MTU.

Thank you for your help and patience. I ended up using tcp instead of udp. Changing the mtu-time didnt solve the problem and it's not sooo important for me.

The discussion might have continued from here.