My old AP has broken and I want to replace it with a 'Fonera'. Im tying to get the same behabiour as a I used to have with my old AP so I successfully installed OpenWrt Kamikaze on my Fonera, but I'm having problems configuring the WAN-LAN bridge.
First I will describe what I want to get:
All my wired-LAN computers have the same config
IP: 192.168.0.x
MASK: 255.255.255.0
GW: 192.168.0.1
DNS: 192.168.0.2
There is no DHCP server on the LAN. I want all my wireless-LAN computers have the same config as above. Once a wireless-LAN computers successfully authenticates using WPA-PSK, it should become part of the 192.168.0.x wired LAN and comunication between Wireless-LAN<>Wired-Lan should be possible.
I think the 'wired' configuration part is clear to me (correct me if I'm worng or misunderstand something):
root@OpenWrt:~# cat /etc/config/network
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option proto static
option ipaddr 192.168.0.6
option netmask 255.255.255.0
option gateway 192.168.0.1
option dns 192.168.0.2
but the lack of documentation (Wiki seems down at the moment) about Kamikaze makes hard to me to configure wireless part of the bridge. A far as I can undertand, it may be similar to this (again, correct me if I'm worng or misunderstand something)
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device wifi0
option type atheros
option channel 5
option diversity 0
option txantenna 1
option rxantenna 1
config wifi-iface
option device wifi0
option network lan
option mode ap
option ssid Fonera
option hidden 0
option encryption psk
option key topsecret
but obviosuly I missed something to create the bridge.
Is it possible to get what I want (that is: use my Fonera as standar AP)?
Can someone help me to configure the bridge?
Tanks in advance.
--Stolz
Note: wpa-supplicant and hostapd have been succesfully installed with ipkg