Hi.
I want to show a strange behaviour of Openwrt.
This is my configuration:
config wifi-device wl0
option type broadcom
option channel 1
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid aaaaaaa
option hidden 1
option encryption psk
option key bbbbbbbbbbbbbb
config wifi-iface
option device wl0
option network wan
option mode sta
option ssid "Other Network"
root@OpenWrt:~# cat /etc/config/network
#### VLAN configuration
config switch eth0
option vlan0 "0 1 2 3 5*"
option vlan1 "4 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option gateway ''
option dns ''
#### WAN configuration
config interface wan
option type bridge
option ifname "eth0.1"
option proto static
option ipaddr 192.168.0.7
option netmask 255.255.255.0
option gateway 192.168.0.1
option dns 192.168.0.1
The "Other Network" is a wpa-psk network and i did a S99nas script in /etc/init.d to set up it correctly:
nas -P /var/run/nas.wl0.pid -l br-wan -i wl0 -S -m 4 -k "afjndhlfhelhfdfdf" -s "Other Network" -w 4 &
All works fine if i don't run this last script. If i run it, some computers (not ALL) can't associate to my network in ap mode.
This is a strange behaviour: why some computers can associate and other don't? The problem is the same also with WEP or NO ENCRYPTION (so it seems an error handling the bssid)