I'm trying to set up my fonera in client mode so that the PHP-server on it can wget a website.
But I have some problems, I have to wait very long before the wifi is connected, and when it's connected it cannot access any site. (no route to host)
Gateway and DNS-server are correct, they point to my router.
Here are my config files:
/etc/config/network:
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname 'eth0'
option proto 'static'
option ipaddr '192.168.123.3'
option netmask '255.255.255.0'
option gateway '192.168.123.1'
option dns '192.168.123.1'
/etc/config/wireless:
config wifi-device wifi0
option type atheros
option distance '200'
option diversity '0'
option txantenna '0'
option rxantenna '0'
config wifi-iface
option device wifi0
option ssid 'HomeWifi'
option mode 'sta'
option encryption 'psk'
option txpower '18'
option bgscan '1'
option key 'jsdhbfsqdghfh'
option key1 ''
option key2 ''
option key3 ''
option key4 ''
option network 'lan'
option server ''
option port ''
The routing table:
root@OpenWrt:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.123.0 * 255.255.255.0 U 0 0 0 eth0
192.168.123.0 * 255.255.255.0 U 0 0 0 ath0
default 192.168.123.1 0.0.0.0 UG 0 0 0 eth0
Wget a google page:
root@OpenWrt:~# wget http://www.google.com
Connecting to www.google.com [64.233.183.147:80]
wget: cannot connect to remote host (64.233.183.147): No route to host
Can somebody help me to fix those problems, please?
(Last edited by lospiratos on 12 May 2007, 13:44)