Hello,
I've configured my fonera to connect to my wireless wpa network, and it works fine. Now I'd like to add another (virtual) interface and to use it as an ap, but I don't understand how to do that. Is it possible to do that or am I dreaming?
My working configuration is:
----------------
root@OpenWrt:~# cat /etc/config/network
# Copyright (C) 2006 OpenWrt.org
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface waifai
option ifname ath0
option type bridge
option proto static
option ipaddr '192.168.0.10'
option netmask 255.255.255.0
option gateway '192.168.0.1'
option dns '192.168.0.20'
----------------
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device wifi0
option type atheros
option channel ''
option disabled '0'
option diversity '0'
option txantenna '0'
option rxantenna '0'
config wifi-iface
option device wifi0
option network waifai
option mode 'sta'
option ssid 'my_ssid'
option hidden 0
option encryption 'psk'
option isolate '0'
option txpower '16'
option bgscan '0'
option key 'my_key'
----------------
I've tried to add at the end of /etc/config/wireless this:
----------------
config "wifi-iface" ""
option device 'wifi0'
option mode 'ap'
option ssid 'another_ssid'
option hidden '0'
option encryption 'psk'
option network 'waifai'
option isolate '0'
option txpower '16'
option bgscan '0'
option key 'another_key'
----------------
but it doesn't work and break my config so I've to move to old config.
Any hint?
Thank you and bye
InSa
Ps: kamikaze revision 7355
(Last edited by insa_hc on 1 Jun 2007, 00:34)