as newcomer to Kamikaze I am struggling to understand the current way of defining the wan/lan/wlan properties of a system. It doesn't appear intuitive and terminolgy 'iface' 'device' 'network' in the way used now may cause unnecessary confusion. A suggestion for another organization of the settings:
network:
config switches # only needed if more than one switch present, default to eth0
option sifs "eth0" # list of the names of the switches
config switch eth0 # each entry in 'config switches' has a 'config switch' entry
option vlan0 "0 1 2 3 5*"
option vlan1 "4 5"
config radios # only needed if more than one radio present, default to wl0
option rifs "wl0" # list of the names of real radio interfaces
config rif wl0 # each entry in radios has a 'config rif' entry if virtual radios are used
option vrifs "wl0.0 wl0.1" # list the names of virtual interfaces per radio hardware
# without virtual radios this section can be omitted (defaults to name of radio)
## now assign network properties to all these interfaces, real or virtual alike; e.g. in a non-bridged set up
config interface lan
option ifname vlan0
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
config interface wan
option ifname vlan1 # no need to keep using eth0 based names but use switch definitions
option proto static
option ipaddr 192.168.2.1
option netmask 255.255.255.0
option gateway 192.168.1.254
option dns 192.168.1.254
config interface wifi0 # give each real or virtual radio a friendly name, to be used in 'wireless'
option ifname wl0.0
option proto static
option ipaddr 192.168.3.1
option netmask 255.255.255.0
config interface wifi1
option ifname wl0.1
option proto static
option ipaddr 192.168.4.1
option netmask 255.255.255.0
(in case of use of a bridge introduce a section like
config interface br0
option ifnames "vlan0 wl0.0 wl0.1"
option proto static
option ipaddr 192.168.4.1
option netmask 255.255.255.0
and remove wifi sections if wifi part of bridge, and ip settings of bridged interfaces)
wireless:
config radio wl0 # radio characteristics comon to all virtual interfaces; repeat per radio in 'network'
option type broadcom
option channel 5
option country JP
option distance 5000
config interface wifi0 # only friendly interface name needed here; rest already defined in 'network'
option mode "ap"
option ssid "WIFI_0"
option hidden "0"
option encryption "psk"
option key "some key"
option hidden 0
option isolate 0
option maxassoc 10 # this should be characteristic oof a virtual radio, not a real one
config interface wifi1
option mode "ap"
option ssid "WIFI_1"
option hidden "0"
option encryption "psk"
option key "yet another key"
option hidden 0
option isolate 0
option maxassoc 10 # this should be characteristic oof a virtual radio, not a real one
(Last edited by doddel on 14 Jun 2007, 15:10)