OpenWrt Forum Archive

Topic: Writing to usb harddrive freezes Asus wl-500gP

The content of this topic has been archived between 10 Feb 2018 and 27 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

My Asus wl-500 gP runs flawlessly, except when I write/read to the the external usb harddisk it sometimes freezes. It does that under the following conditions:

1. When copying a large file (500mb or larger) to it.
2. Many smaller files (5-10mb) in a row under an extended period of time.
3. When reading from it under a longer period of time, like when watching a move.

The only way to unfreeze it is to remove the power cable and put it back in.
The harddrive needs to be restarted too. The led indicating write/read from the usb disk sometimes gets stuck lighted up when this happens. Once restarted everything is back to normal.

It happens at least 70% of the time I try to copy a large file/many smaller to it and more seldom when reading from it. Usually it freezes when I've been writing to it for 10 or more minutes, sometimes all goes well for half an hour (which is what puzzles me the most).

The disk is 500gb, less than a month old and running ext3. The same problem occurs both when writing files via vsftpd and reading/writing via samba. There is plenty of ram available.

I am using Kamikaze 7.06 (broadcom2.4), but I've had the same problems with whiterussian and previous kamikaze builds as well. The usb drivers and disk are configured as per the wiki.

Any help/ideas would be greatly appreciated, I use this disk for all my storage so you can imagine how annoying it gets! Let me know if you need additional info.

Thanks,
nesse

UPDATE:

I connected the disk to my computer running windows xp via ext2fsd and got a "disk full" error after a couple of minutes when copying a large file to it. So I reckon it's probably a filesystem error(?). Did an e2fsck, but still received the same error afterwards.

Any ideas guys?

I have exactly the same problem;
However, I do not think it is related to the disk being full.

I've had this problem a number of times, even if the disk isn't even near to being full.

It only happens when the disk is under heavy load; (copying large file or multiple small files).

And, the router itself doesn't crash/hang; Only accessing the disk blocks. In my case, I cannot login any longer, but
everything else still works (dns, nat, ...)

I've tried attaching the disk directly or through an USB-1 hub; Made no difference.

I'm hoping that kernel 2.6 will fix this issue...

Problem solved!

I don't understand how, but it turns out the partition table had gotten screwed up. Partition table doctor (windows) found the errors automatically and corrected them, I then reconnected it to the router and did a e2fsck, after that all has been fine!

Hope this helps you dries!

Doh, turns out it was a false alarm. Was working nicely for a couple of days, now its back to its regular crashing self..

I am also experiencing similar things, though probably closer to netddos' problem from March 2006: http://forum.openwrt.org/viewtopic.php?pid=22160#p22160.

I have the WL-500GP, an external USB 2.0 hdd enclosure (with a SATA-II drive inside). The filesystem is xfs, and is accessible to my WinXP via samba. When I run azureus, the file gets downloaded directly to the router's external hdd. Like netddos, after awhile, the transfer stops and I get write errors and WinXP can no longer access the drive.

However, I can *still* login to the router, umount the drive, and when I remount it, everything works again. I can drag-and-drop 2 GB files directly to the drive in WinXP. I can stream large videos off of it with no dropped frames or errors. No problems.

But the errors come back as soon as I do bittorrent/azureus.



UPDATE: Actually, the more I experiment with controlling various factors in attempting to consistently reproduce the errors, the more I'm beginning to suspect that my problem, at least, has to do with the speed to which data is being written to the disk (which may have to do with load/stress also, as dries intimated).

If my torrents are downloaded at about 100 KB/s (that's kiloBYTES) or less (and uploading at 32KB/s), there are NO problems. If the total download speed is 300 KB/s or more, I get the write errors and "freeze" that the OP (nesse) describes.

It doesn't make sense as my network is 100 Mb/s (that's megaBITS) and USB 2.0 is theoretically 480 Mb/s. Even assuming less-than-theoretical, I'm nowhere near these numbers. But I can pretty consistently reproduce this now.

I don't think it's bittorrent-specific like I originally thought. I think it just boils down to the write speed. It's just that bittorrent allows me to control that variable (d/l speed) in order to more clearly bring the problem into focus.

But no, I have not yet found the "optimal" speed at which I can d/l without errors. I just know it's somewhere between 100 KB/s and 300 KB/s.

(Last edited by bluerussian on 27 Jun 2007, 07:24)

Hello!

I have ASUS wl-500gp with kamikaze too, and x-wrt webif. USB devices (pendrive and multi card reader) appears on webif status/usb menu, but can't mounted it. I found an error report:

https://dev.openwrt.org/ticket/1819

dmesg creates same error for me.

How do you install kmod-fs-vfat package, because it depends kmod-nls-base, which is not in brcm2.x packages? I tried to install with -nodeps option, and it's installed, but maybe this caused my problem?

Under white-russian everything works well.

I have the exact same problem since WhiteRussian I dunno why no one is fixing it.

If you run - cat /etc/meminfo, you will find that the cache (inactive) takes about > 10Mb and the router started chocked up and freeze...

I read from other thread that remounting the drive can solve the problem then obviously something is wrong at the USB or the disk driver module. May be you can try to run a cron to remount the drive regularly.

But some one in the DEV team has to look at the problem and fix this.

has anyone with this problem checked dmesg for errors?

The problem is that when the router got choked up you can't even telnet into it... the router will not respond at all not even ping
Is there anyway you can get the dmesg printed somehow?

(Last edited by mib on 30 Jun 2007, 16:45)

I have an wl-500gp, with kamikaze, 2.4 kernel (svn version).
I'm using the EHCI-usb drivers.

I also freezes, but only when i copy a lot of files over samba, or very
large ones (>2GB).

copying via ncftp (running on kamikaze) is faster and is stable up to now.

I just assumed it was a bug in samba, but maybe i'm wrong

tuigje, did you check your /proc/meminfo and see if there're large amount of Inactive Cache? or the free memory?

I think somehow when any programs access the drive via some way (probably thru driver API calls) will trigger the problem. I tried vsftp, samba, ctorrent... and found the problem was in common that when the disk access reaches certain level (certain written size or certain time of continous run), the cache for inactive connections pumps up and not going away... and then after a while the router got chocked and eventually completely stop. A hard-reset is needed.

That's why I think the issue is on the USB or the disk driver layer. Using EHCI driver may help... I'll give a try later.

(Last edited by mib on 3 Jul 2007, 11:29)

These seem like very similar problems that I'm having with my WL-700ge. My router crashes on large file transfers or lots of small files. Can anybody confirm that they only have these problems when transferring files over a wireless connection?

EDIT: I have posted my problem here - http://forum.openwrt.org/viewtopic.php?id=12103
and here - https://dev.openwrt.org/ticket/2221

(Last edited by splendid on 17 Aug 2007, 00:39)

The problem exists not only when wireless is used. I'm using the ethernet port only but it has the same problem.
Did you check the meminfo and see if the Inactive Cache keep pumping up when you access your drive and eventually the router choked?

My /proc/meminfo seems to remain fairly stable. And I note from http://forum.openwrt.org/viewtopic.php?id=11317 nesse seems to have fixed the problem with a new external USB drive. Doesn't seem like the problems are related.

(Last edited by splendid on 18 Aug 2007, 11:39)

Try remove kmod-usb2. Sometimes helps.

Any solutions yet for this problem?
I also have it with Kamikaze 7.06, Asus WL500gP and a Samsung 500GB hd over usb...


Best regards,
max

none so far.....

Is there any solution for this problem? or any workaround? i would like to use a 500gb hdd as the base of a ftp server but it freeze whenever i try to heavily read/write it.:/
I think it has nothing to do with the connection of network, i read somebody wrote that this is because of the wireless but it freeze with wired connection too....

i removed kmod-usb2, but now the tranfer speed continually jumping from 0 to 2.5mb/s(and the vsftpd's load is changing in the same rhythm from 1 to 75%) but the router doesn't freeze yet...

Ya, I think now you are only using USB1.1, thus having less transfer speed = less cpu load = less chance to overload system/driver/whatever causes the problem = less crashes.
If usb2 is really the full reason, crashes should have vanished completely, if usb1.1 is only using less load, crashes are only less frequent.
Did you test that? How many dvd isos did you copy? tongue
Would be interesting...

Cheers,
max

UPDATE: I just checked, also with removing kmod-usb2, and after that, my speed went down from ca. 2.6 to 0.7.
Also the crashes came only after 1.2 GB, instead of 600 MB earlier.
=> still no solution for our problem! sad

[OpenWRT 7.09, Asus WL-500gP]

(Last edited by max2k5 on 10 Dec 2007, 21:50)

yeah, crash came after a few hour...:( i read about running debian in theese routers, after my exams i'll try it.. i hope there will be some workaround.

i have the problem,too. It dont'works with samba, but it works fine with pure-ftpd

Is there a way to install a pure Debian/MIPS? I was also looking in that direction, and they always use the openwrt kernel to boot the system, and just use debian sysv, libs etc, but not debian kernel...

memento wrote:

yeah, crash came after a few hour...:( i read about running debian in theese routers, after my exams i'll try it.. i hope there will be some workaround.