Configure WDS with WPA2 (Atheros WiFi)
This guide describe how to configure WDS with WPA2 between two routers with Kamikaze installed. Also both routers must have a Atheros WiFi card.
Hardware used in this howto:
WDS AP: Soekris net4801 (Wistron CM9)
WDS STA: La Fonera
Note: The MAC address used in 'option bssid' comes from 'ifconfig ath0'. 192.168.178.1 is my main router/gateway (AVM FRITZ!Box Fon WLAN 7170) which is doing DSL, DNS and DHCP).
WDS AP
For WPA2 encryption you have to install the hostapd package (dependencies: libopenssl, zlib).
ipkg install hostapd
/etc/config/network
# Copyright (C) 2006 OpenWrt.org
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname 'eth0 eth1 eth2'
option type bridge
option proto static
option ipaddr '192.168.178.3'
option netmask 255.255.255.0
option gateway '192.168.178.1'
option dns '192.168.178.1'
/etc/config/wireless
config wifi-device wifi0
option type atheros
option channel 5
config wifi-iface
option device wifi0
option network lan
option mode 'ap'
option ssid OpenWrt
option encryption 'psk2'
option bssid '00:18:84:14:39:95'
option wds '1'
option key '<password>'
WDS STA
For WPA2 encryption you have to install the wpa-supplicant package (dependencies: libopenssl, zlib).
ipkg install wpa-supplicant
/etc/config/network
# Copyright (C) 2006 OpenWrt.org
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr '192.168.178.4'
option netmask 255.255.255.0
option gateway '192.168.178.1'
option dns '192.168.178.1'
/etc/config/wireless
config wifi-device wifi0
option type atheros
option channel 5
option disabled '0'
config wifi-iface
option device wifi0
option network lan
option mode 'sta'
option ssid OpenWrt
option encryption 'psk2'
option bssid '00:18:84:14:39:95'
option wds '1'
option key '<password>'
(Last edited by forum2006 on 29 Jul 2007, 10:40)