OpenWrt Forum Archive

Topic: Kamikaze 7.06 on RB532A

The content of this topic has been archived on 1 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi,
I am wondering can I burn kamikaze image on routerboard RB532A.
Here is why I am asking. Routerboard povides patches only for
2.4.30 and 2.4.31 kernel, and the latest version of kamikaze uses
2.6 kernel. So, are there patches available for latest kernel, or
I miss something.

thanks,

Just take a look at openwrt site
you can download allready compiled for rb532 image

http://downloads.openwrt.org/kamikaze/7.07/rb532-2.6/

You can compile image by yourself with partition size and type
you need for your additional packages.

Just take a closer look at it smile

Take CompactFlash and dd choosen image to it...

It works like a charm ..

Sincerely

Thank you for the link.
I took a closer look but I could not figure what those files are for.
There is no readme....could you plse give me a quick step-by-step
guidenace to compile my own image. Or, are there any docs available
for that....thanks

I quickly cleaned up the RB532 wiki page, which provides basic installation instructions.  As I do not own a RB532 I cannot confirm that the directions work.  They direct you to write OpenWrt to a CF card so it won't touch any existing OS you have installed in onboard flash.

hello nathan_vanan,

I also have a rb532a whith openwrt kamikaze 7.07 installed. To buil your own firmware it's really easy (thanks to the nice OpenWrt developpers work):

1) create a working directory, for instance :

$ mkdir /home/your-user-name/openwrt
$ cd /home/your-user-name/openwrt

2) Check out the 7.07 sources

$ wget http://downloads.openwrt.org/kamikaze/7 … 07.tar.bz2 && tar jxvf kamikaze_7.07.tar.bz2

3) Optional: if you want X-Wrt extension

$ cd kamikaze_7.07/package
$ svn checkout http://svn.berlios.de/svnroot/repos/xwr … kage/webif
$ svn checkout http://svn.berlios.de/svnroot/repos/xwr … bif-batman
$ svn checkout http://svn.berlios.de/svnroot/repos/xwr … webif-mesh
$ svn checkout http://svn.berlios.de/svnroot/repos/xwr … -netsukuku
$ svn checkout http://svn.berlios.de/svnroot/repos/xwr … webif-olsr

4) Customize the sources

$ cd kamikaze_7.07
$ make menuconfig
(make sure you save changes when exiting)
$ make package/symlinks (this enables all packages)
$ make menuconfig

--> it will open a configuration menu as a traditional linux kernel. In this menu you can for instance tweak busybox (the Swiss Army Knife of Embedded Linux), add or remoe specific kernel modules (filesystem, wireless drivers, ...), add or remove some applications (freeradius, chillispot, openvpn, ...). You will see, you have the possibility to really customize your firmware. In my case, I always build a firmware whith a 128 MB parition size (the size of the NAND memory of our rb532a). One time your configuration finished, quit and save the menuconfig.

5) Run the compilation

$ make V=99

and be patient ... the firmware is under the bin directory and the packages are under the bin/package directory (from the kamikaze_7.07 directory)

6) Install the firmware on a compact flash (suppose your CF is detected under /dev/sdc)

$ dd if=bin/openwrt-rb532-2.6-jffs2-128k.bin of=/dev/sdc

7) Put CF into the rb532's slot

8) Start the board and see throught a serial cable the startup.

Note: by default the wan interface is firewalled, you can edit /etc/firewall.user in oder to autorize the ssh traffic. I hope for anything to have forgotten.

Good luck !

(Last edited by toboz on 17 Aug 2007, 12:53)

Thanks for the great help.
I tried both, the pre-built image, and my own image.
I use CF 512M. For both images kernel booted OK, but it failed
to mount the root file system after a tons of "MAgic bitmask" errors.
It unabled to mount root-fs on unknown-block(1,0)...
I did search on google, and this forum, not much help...

thanks again.

You like having a configuration problem. If you want I can send you my .config file which really works fine on my rb532. Do you still use the ext2 filesystem as you said in this topic ? http://forum.openwrt.org/viewtopic.php?id=9008&p=2

t.

Hi toboz,
plse do provide your .config file......I will try that too...
thanks,

nathan_vanan wrote:

Hi toboz,
plse do provide your .config file......I will try that too...
thanks,

No, I am not using ext2 file system, using jffs2.

Hello nathan_vanan,

You can download my .config file here: http://mypics.fr/openwrt-firmware/.config

I advise you to use the 7.07 sources as I described you in my previous post. As you will see, I build some packages directly into my firmware (like freeradius, vsftpd, ...), of course you are free to disable them. Don't forget to make make menuconfig one time (don't need to save), make package/symlinks, and finally make menuconfig (this will enable the extra packages).

If the compilations fails (it's strange, since it works fine for me), you can send me your .config file that I will compile for you if you want.

Best regards.

Hi toboz,
Thanks for your time.
This what I did:
- I replaced the .config file with yours
- I compiled (7.07) the source code - OK
- I cd to /bin
- Then I issued this, dd if=openwrt-rb532-2.6-jffs2-128k.bin of=/dev/sdb - sdb is my 512CF
- I booted to CF
- SAME ERROR - unable to mount rootfs on unknown-block 31,0

Am I missing steps between, do i need to copy rootfs or anything.

After the "dd" command my CF look like this,
Disk /dev/sdb: 512 MB, 512999424 bytes
16 heads, 32 sectors/track, 1956 cylinders
Units = cylinders of 512 * 512 = 262144 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *           1          17        4336   27  Unknown
/dev/sdb2              18        2066      524528   83  Linux


I am stuck,
Merci

it's really strange, can you try my built firmware version in order to know if it does the same issue ...

you can find it there: http://mypics.fr/openwrt-firmware/7.07/ … 2-128k.bin

and try to run the "sync" command after the "dd" command. strange ...

tu ne crains pas ne t'en fais pas :-)  Avec plaisir !

Hi toboz,
Encore une fois, merci pour votre temps, apprentissage du français smile
Yes, I am getting exactly the same error message....could be my hardware...
any ideas....
thanks.

I can't  see what I could be else than your hardware. try an other CF, an other rb532 ... The firmware which I gave you the link work perfectly for me and my rb532. What else could I say ? Sorry for you and bonne chance pour ton apprentissage du français smile

Sincérement,

t.

Hi toboz,
Thanks again.
I got kamikaze working on my board but with different config.
What I did was I used ramdisk option insted of fs. Works fine so far...

But, I could not get "Bridged client mode" working on the board.
Like, if i connect a laptop to one of the LAN ports of the board,
I want the laptop to receive a valid IP from the AP...I have
this board woking on sta mode....

any help would be appreciated....

thanks

Can you please show me your configuration file:

- /etc/config/network
- /etc/config/wireless
- /etc/config/dhcp

Thanks.

Hi,
The setup I had is working now after I enable wds option
on both AP and STA side, "option wds 1". Could you plse
tell me this is the only way to get that mode working or I am
doing weired thing. If I use an on-the-shelf router, I can not
enable that option in the AP site, is that correct ?

toboz, I believe you're using the RB532A board as a wireless
router. How can I setup this board as a on-the-shelf router.
I mean wan port, local network with the internet....etc.

thanks,
nathan.

nathan wrote:

toboz, I believe you're using the RB532A board as a wireless
router. How can I setup this board as a on-the-shelf router.
I mean wan port, local network with the internet....etc.

Could you be more precise? Each ethernet port are separated, so the board is already a router. If you want you can bridge them or not, the same with the wireless interface. In my case, I use eth0 as a the wan port, and eth1, eth2, ath0 are bridged togethter. Those three interfaces represent my local network. Show me your configuration file, I will better unterstand what you want to do.

Good luck smile

t.

toboz wrote:

In my case, I use eth0 as a the wan port, and eth1, eth2, ath0 are bridged togethter. Those three interfaces represent my local network. Show me your configuration file, I will better unterstand what you want to do.

toboz,
It is exactly what I am trying to do. I want eth0 to be my wan port, with static IP settings. And, eth1, eth2, and ath0 to be in
a local network with DHCP server running behind. So, the DHCP server will assign IP address to wireless or wired computer
and from the computers can access internet.

This is an exact configuration of a off-the-shelf router, isn't it ?

/etc/config/wireless

config wifi-device  wifi0
    option type     atheros
    option channel  9

config wifi-iface
    option device    wifi0
    option network    lan
    option mode    ap
    option ssid    milton
    option encryption none
    option wds    1


/etc/config/network

# Copyright (C) 2006 OpenWrt.org

config interface loopback
    option ifname    lo
    option proto    static
    option ipaddr    127.0.0.1
    option netmask    255.0.0.0

config interface wan
    option    ifname    "eth0.1"
    option    proto    static
    option     ipaddr     x.x.x.x
    option     netmask x.x.x.x
    option     gateway    x.x.x.x
    option    dns    x.x.x.x

config interface lan
    option    type    bridge
    option    ifname    "eth0.0 ath0"
    option    proto    dhcp


/etc/dnsmasq.conf (partial)

dhcp-range=ath0,192.168.1.10,192.168.1.20,255.255.255.255,10h

I know something is not right....plse take a look at my config

thanks.
nathan

Why do you create two virtual interfaces ? You don't need interfaces like "eth0.1" "eth0.0 ath0". Here my configuration:

/etc/config/wireless 

config wifi-device  wifi0
        option type     atheros
        option channel  5
        option disable  0

config wifi-iface
        option device   wifi0
        option network  lan
        option mode     ap
        option ssid     My-SSID
        option encryption none
        option hidden   0
/etc/config/network 

config interface loopback
        option ifname   lo
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0

config interface wan
        option ifname   eth0
        option proto    dhcp

config interface lan
        option ifname   "eth1 eth2"
        option type     bridge
        option proto    static
        option ipaddr  192.168.2.254
        option netmask 255.255.255.0
        option dns      '192.168.0.1'
        option gateway  '192.168.0.1'
/etc/config/dhcp

config dhcp
        option interface        lan
        option start    2
        option limit    150
        option leasetime        12h

config dhcp
        option interface        wan
        option ignore   1

While hoping to be useful for you.

Hi toboz,
It worked. Thanks for your time and help ....

nathan.

The discussion might have continued from here.