I must be missing something.
Can you use WDS between different devices? I have a 500g (atlwap1) and a wrt54g (atlwap2).
I see entries in the logs where they start up wds and complain about being on the same interface:
Jan 1 00:00:14 atlwap1 user.info kernel: device wds0.1 entered promiscuous mode
Jan 1 00:00:14 atlwap1 user.info kernel: wds0.1: attempt to add interface with same source address.
Jan 1 00:00:14 atlwap1 user.info kernel: br-lan: port 3(wds0.1) entering learning state
Jan 1 00:00:14 atlwap1 user.info kernel: br-lan: port 3(wds0.1) entering forwarding state
DHCP is off on atlwap2 (supposed to be, right)
I cannot get DHCP addr when the second one (atlwap2) is on. As soon as I shut it off, I get dhcp. It's like they're not talking.
I am posting my configs to be thorough. Any help would be great. Thanks in advance!
Atlwap1
/etc/config/network
#### VLAN configuration
config switch eth0
option vlan0 "1 2 3 4 5*"
option vlan1 "0 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.100.1
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto dhcp
/etc/config/wireless
config wifi-device wl0
option type broadcom
option channel 5
option disabled 0
# REMOVE THIS LINE TO ENABLE WIFI:
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid myssid
option encryption psk1
option key password
option isolate 1
config wifi-iface
option device wl0
option network lan
option mode wds
option ssid wdslink
option bssid 00:0C:41:75:FB:35
option encryption psk1
option key wdspassword
br-lan Link encap:Ethernet HWaddr 00:1E:8C:3D:FF:8D
inet addr:192.168.100.1 Bcast:192.168.100.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:638 errors:0 dropped:0 overruns:0 frame:0
TX packets:430 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:59595 (58.1 KiB) TX bytes:86676 (84.6 KiB)
eth0 Link encap:Ethernet HWaddr 00:1E:8C:3D:FF:8D
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3336 errors:0 dropped:0 overruns:0 frame:0
TX packets:357 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:272646 (266.2 KiB) TX bytes:47081 (45.9 KiB)
Interrupt:4
eth0.0 Link encap:Ethernet HWaddr 00:1E:8C:3D:FF:8D
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:81 errors:0 dropped:0 overruns:0 frame:0
TX packets:172 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7195 (7.0 KiB) TX bytes:17392 (16.9 KiB)
eth0.1 Link encap:Ethernet HWaddr 00:1E:8C:3D:FF:8D
inet addr:98.192.35.68 Bcast:255.255.255.255 Mask:255.255.248.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3255 errors:0 dropped:0 overruns:0 frame:0
TX packets:185 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:205403 (200.5 KiB) TX bytes:27561 (26.9 KiB)
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1 errors:0 dropped:0 overruns:0 frame:0
TX packets:1 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:88 (88.0 B) TX bytes:88 (88.0 B)
wds0.1 Link encap:Ethernet HWaddr 00:1E:8C:3D:FF:8D
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
wl0 Link encap:Ethernet HWaddr 00:1E:8C:3D:FF:8D
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:539 errors:0 dropped:0 overruns:0 frame:31011
TX packets:486 errors:5 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:58607 (57.2 KiB) TX bytes:102510 (100.1 KiB)
Interrupt:2 Base address:0x2000
atlwap2
/etc/config/network
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.100.2
option netmask 255.255.255.0
#### WAN configuration
#config interface wan
# option ifname "eth0.1"
# option proto dhcp
/etc/config/wireless
config wifi-device wl0
option type broadcom
option channel 5
option disabled 0
# REMOVE THIS LINE TO ENABLE WIFI:
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid myssid
option encryption psk1
option key password
option isolate 1
config wifi-iface
option device wl0
option network lan
option mode wds
option ssid wdslink
option bssid 00:1E:8C:3D:FF:8D
option encryption psk1
option key wdspassword
/etc/init.d/dnsmasq disable
br-lan Link encap:Ethernet HWaddr 00:0C:41:75:FB:33
inet addr:192.168.100.2 Bcast:192.168.100.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:382 errors:0 dropped:0 overruns:0 frame:0
TX packets:139 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:37019 (36.1 KiB) TX bytes:17501 (17.0 KiB)
eth0 Link encap:Ethernet HWaddr 00:0C:41:75:FB:33
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:266 errors:0 dropped:0 overruns:0 frame:0
TX packets:140 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:28159 (27.4 KiB) TX bytes:19471 (19.0 KiB)
Interrupt:3
eth0.0 Link encap:Ethernet HWaddr 00:0C:41:75:FB:33
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:269 errors:0 dropped:0 overruns:0 frame:0
TX packets:143 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:23613 (23.0 KiB) TX bytes:19119 (18.6 KiB)
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2 errors:0 dropped:0 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:204 (204.0 B) TX bytes:204 (204.0 B)
wds0.1 Link encap:Ethernet HWaddr 00:0C:41:75:FB:35
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
wl0 Link encap:Ethernet HWaddr 00:0C:41:75:FB:35
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:55 errors:0 dropped:0 overruns:0 frame:19582
TX packets:70 errors:1 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6834 (6.6 KiB) TX bytes:9436 (9.2 KiB)
Interrupt:6 Base address:0x2000