Hi:
I've been running WR for about a year now successfully and decided to upgrade to 7.07 kamikaze. I tftpd the bin image for wrt54gs (2.4 version) onto the unit and went through the normal setup stuff.
The unit booted up fine in access point (ap) mode, and all appeared well. However, I need to run the unit in routed client mode.
When I reboot, the router comes up and if I do an iwconfig wl0, it shows the mode as "Repeater" (not Managed), and the tx power is "off", and it basically looks like the wireless radio hasn't been turned on, and the mode hasn't been properly set.
Not sure what it means, but if I do a:
wlc infra, it returns "1"
wlc wet, it returns "1"
wlc ap, it returns "0"
wlc apsta, it returns "0",
and if I try to set ap to 1 (wlc ap 1), then the card comes to life and turns on and shows "Master" on iwconfig. If I try to set infra to 0 (wlc infra 0), then I get a "can't set card option error -1" or something.
What's interesting is that if I set the config/wireless file to bring the interface up as "mode adhoc", the wireless card turns on and I can scan for APs normally (iwlist wl0 scanning), and see a bunch.
For the past couple days I was able to boot into adhoc mode and then issue:
iwconfig wl0 mode Managed
iwconfig wl0 essid TargetEssid
and the card would go to the proper mode and be 'on', it would pick up an IP, and so on.
Since then, i installed the "wl" package to be able to use the aircrack-ng package, and ran airodump successfully a few times. Since then, my trick of bringing the card up in adhoc mode and then using iwconfig to switch to client doesn't work. The card will switch to "Managed" mode, but it appears that the radio is off "tx power: off"
So, not sure where to go from here.
Could I be dealing with some hangover nvram settings somewhere that are not allowing kamikaze proper control of the wifi card? If so, how can I do a clean wipe?
Are there any known issues about switching to client mode on a wrt54gs 2.0 AP, with 2.4 kamikaze 7.07? I've searched the board a bit and found some config files that are apparently working for some folks. But those files aren't working for me.
What's the trick for client mode?
I appreciate your help and can provide more diagnostic info as required.
Thanks!
John.
So, per the documentation I adjusted /etc/config/network and /etc/config/wireless
****************************
/etc/config/network
config switch eth0
option vlan0 "0 1 2 3 4 5u"
config interface lan
option ifname eth0
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
config interface wan
option ifname wl0
option proto dhcp
************************
***********************
/etc/config/wireless
config wifi-device wl0
option type broadcom
option disabled 0
config wifi-iface
option device wl0
option mode sta
option ssid MYSSID
*************************