OpenWrt Forum Archive

Topic: vdsl(t-home) - vlan tagging problem

The content of this topic has been archived on 28 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hello there,

i ran into a problem when i tried to set my linksys wrt45gs (kamikaze 7.07) for t-home (german isp).
For whatever reasons the wan port needs to be tagged with id7 as described here (german).

So i edited /etc/config/network to look like this:

config switch eth0
        option vlan0    "1 2 3 4 5*"
        option vlan7    "0 5"

config interface        wan
        option ifname   "eth0.7"


nvram:

vlan0ports=1 2 3 4 5*
vlan7ports=0 5
vlan0hwname=et0
vlan7hwname=et0
wan_device=vlan7


But I only get theese error messages when plugging on the modem:

Jan  1 01:03:26 (none) daemon.warn pppd[518]: Timeout waiting for PADO packets
Jan  1 01:03:26 (none) daemon.err pppd[518]: Unable to complete PPPoE Discovery

It works fine the W700V Router provided by t-com so there has to be something wrong with my config but i have no clue what sad

Any ideas?

T-Home VDSL needs a VLAN7 ID and must be tagged. The tag is added with the 't'.

uci del network.eth0.vlan1
uci set network.eth0.vlan7="0t 5"
uci set network.wan.ifname=eth0.7
uci set network.wan.proto=pppoe
uci set network.wan.username=<pppoe_psername>
uci set network.wan.password=<pppoe_password>
uci commit network
ifdown wan && ifup wan

Connect the VDSL modem to the WAN port. Can you report if it works?

The final /etc/config/network configuration file:

#### VLAN configuration
config switch eth0
        option vlan0    "1 2 3 4 5*"
        option vlan7    "0t 5"


#### Loopback configuration
config interface loopback
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0


#### LAN configuration
config interface lan
        option type     bridge
        option ifname   "eth0.0"
        option proto    static
        option ipaddr   '192.168.1.1'
        option netmask  255.255.255.0


#### WAN configuration
config interface        wan
        option ifname   "eth0.7"
        option proto    'pppoe'
        option username '<pppoe_username>'
        option password '<pppoe_password>'

(Last edited by forum2006 on 18 Nov 2007, 21:01)

Works great with Asus WL-500g Deluxe after reboot of modem (Speedport300HS) and router.

hi
i´ve read somewere that not all hardware is able to tag on wan interface - and all WRT54 where not able to tag.
can somebody confirm that WRT54GL with kamikaze is able to Tag VLAN7 vor VDSL?
regards
Thorsten

The discussion might have continued from here.