OpenWrt Forum Archive

Topic: ether-wake for brcm-2.4

The content of this topic has been archived on 28 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Where can I find ether-wake package for brcm-2.4 ?
It seems the whiterussian version doesn't work on kamikaze.
I can wake up pc only with ether-wake, I havn't
problem, so if anyone have an ether-wake for kamikaze, come on !

Recompile busybox to include ether-wake ;-)

Or use the wol package. WOL can be configured using UCI.

Install WOL package:

ipkg install wol

Configure WOL:

uci set wol.cfg1.mac=11:22:33:44:55:66
uci set wol.cfg1.enabled=1
uci commit wol

Add a second computer to wakeup via WOL

uci set wol.cfg2=wol-target
uci set wol.cfg2.mac=aa:bb:cc:dd:ee:ff
uci set wol.cfg2.enabled=1
uci commit wol

Show the WOL configuration:

uci show wol

wol.cfg1=wol-target
wol.cfg1.mac=11:22:33:44:55:66
wol.cfg1.enabled=1
wol.cfg2=wol-target
wol.cfg2.mac=aa:bb:cc:dd:ee:ff
wol.cfg2.enabled=1

Delete the second configuration

uci del wol.cfg2
uci commit wol

Test wol (tested with my Notebook running Feisty Fawn):

sleep 60 && /etc/init.d/wol start &

Have fun smile

(Last edited by forum2006 on 1 Oct 2007, 20:12)

Can someone provide a Kamikaze package of ether-wake?

This would help several people who needs it to switch from WR to Kamikaze.

Regards
Maddes

I have added the ticket 2460.
Maybe forum2006 could equip it with his nice UCI config and scripts. :-)

@maddes.b: Use

wol -p 65535 -h 192.168.x.255 x:x:x:x:x:x

instead ether-wake for the moment ...

Sonic wrote:

@maddes.b: Use

wol -p 65535 -h 192.168.x.255 x:x:x:x:x:x

instead ether-wake for the moment ...

This can be done with UCI. Looking into the /etc/init.d/wol init script tells you that these parameters can be configured in /etc/config/wol using UCI and are used by the init script.

So, do:

uci set wol.cfg1.mac=x:x:x:x:x:x
uci set wol.cfg1.broadcast=192.168.x.255
uci set wol.cfg1.port=65535
uci set wol.cfg1.enabled=1
uci commit wol

(Last edited by forum2006 on 2 Oct 2007, 00:02)

#1 ether-wake
I need ether-wake because one router is giving me headaches when using wol with IP packages. Hence I still use WR 0.9 on the hardware.

#2 wol via uci
As of now I couldn't get Kamikaze to run in a VM, so I have no experience with it yet.
In my case I wake-up the server only when I need it, and not when the router reboots.
Therefore some questions:
a) As an init script it is executed on the router's startup, how can I disable it for the router's startup? Runlevels?
b) How can I use the uci config while the router is running? Is there an invoke-rc.d? Or can I use "wol --cfg=<cfg name/number>"?

Thanks for all your info
Maddes

The discussion might have continued from here.