OpenWrt Forum Archive

Topic: Asus 500gp and tv tuner

The content of this topic has been archived on 4 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

How I can run MSI VOX USB 2 tv tuner on my Asus wl-500g Premium ? Tv Tuner chip is Empia Em2880

if i remember correctly, that one is supported by the
video4linux drivers.
you should be able to
1. grab the source from svn
2. cd to the kamikaze dir, and type 'make kernel_menuconfig'
a tool like mplayer should be able to connect to the tuner, and dump
the contents to a file.

my wl-500gP is connected to a pinnacle usb tuner, but it needs
custom software to work. So the router is capable
of recording to harddisk, but i do not know the standard software.

It requires a bit of fiddling, but can be done.

Do you think it's possible to plug in a DVB USB card and record TVshows? Maybe the wl-500gp cant handle the dataspeed over usb? Would be a cool app though.

Yes, it is possible to record using a usb-tv tuner.

I have a pinnacle pc-tv deluxe. i downloaded and compiled drivers from:
http://www.paranoyaxc.de/dune/dune.html

it works flawlessly, even in combination with the harddisk-spin-down scripts.
I use 'at' from http://www.nslu2-linux.org/wiki/Optware/Packages to make timed
recordings.

It do not have a graphical/ web-based user interface though.

the wl-500gp is a bit picky about it's usb connections. The tv-tuner only works
if it is connected directly to the router, without a hub in between.

(Last edited by tuigje on 7 Oct 2007, 21:06)

That's very interesting. More info please! Do you need v4l kernel support? Does the sound work also?

Hi,

i managed to compile i2c, the last dvb-modules and dvb-utils/apps.

I can load all modules without probs. i tried, two adapters

Afatech AF9005
and
AVerMedia AVerTV DVB-T Volar

the first prob. was that i the device-nodes where none standard.

so i put the following script
mkdir -p /dev/dvb/adapter0
ln -sf /dev/dvb0.frontend0 /dev/dvb/adapter0/frontend0
ln -sf /dev/dvb0.net0 /dev/dvb/adapter0/net0
ln -sf /dev/dvb0.demux0 /dev/dvb/adapter0/demux0
ln -sf /dev/dvb0.dvr0 /dev/dvb/adapter0/dvr0

when i use
./scan de-Muenchen
... i get no channel, but when i use
./tzap zdf -c channels.conf -r # with a channels.conf from my laptop
i get a lock, so i think something works....

when i try now
cat /dev/dvb/adapter0/dvr0
i get nothing...

I assume a problem with i2c, usb, or udev (device-nodes).

using dvbstream, wasnt successful neither:

./dvbstream -f 578000 -a 337 -v 338 -o > tt2.mpg
dvbstream v0.7 - (C) Dave Chapman 2001-2004
Released under the GPL.
Latest version available from http://www.linuxstb.org/
Tuning to 578000 Hz
MT2060: successfully identified (IF1 = 1216)
Using DVB card "AF9005 USB DVB-T", freq=578000
tuning DVB-T (in United Kingdom) to 578000000 Hz, Bandwidth: 8
Getting frontend status
Event:  Frequency: 578000000
Bit error rate: 0
Signal strength: 40320
UNC: 0
FE_STATUS: FE_HAS_SIGNAL FE_HAS_LOCK FE_HAS_VITERBI FE_HAS_SYNC
dvbstream will stop after -1 seconds (71582788 minutes)
dvb_demux_feed_del: feed not in list (type=0 state=0 pid=ffff)
Failed setting filter for pid 337: DMX SET PES FILTER: Invalid argument
Output to stdout
Streaming 3 streams


tt2.mpg is "empty" ... on my laptop, with the same usb-card, antenna and at the same location, everything works?

maybe somebody can help, ....

Hi there!
I am about to try the same thing...
Could you please tell me how to cross-compile the linuxtv-dvb-modules for my router?
Thanks an advance!

Hello

Perhaps this could help you

I played to make MuMuDVB (http://mumudvb.braice.net) working under openWRT

MuMuDVB is a DVB streaming software so I wrote some script to add the support for some USB DVB-T under openwrt. This script is intended to make the options for DVB available under the standard make menuconfig of openWRT

Now the script is working pretty well (at least for my hardware) but I think there is still a lot of space for improvments

You can find the script and the explanation of what I did on the following page

http://mumudvb.braice.net/mumudvbwiki/i … B_Embedded

I hope it will be useful

Regards

(Last edited by braice on 9 Oct 2009, 23:02)

Wow never heared of Mumudvb, but it was exactly what i was looking for, so i tried to compile an image for my WL 500-GP, with the build scripts you provided. But I ran into some problems

In the compiling process it seems to ask for a reconfiguration.
I dont really know where to go on from their.

Trying to include support for a "TerraTec Cinergy T USB XE" so I enabled this package: "dvb-usb-af9015"

this is the axact error message:

.config:523:warning: symbol value 'm' invalid for DVB_CAPTURE_DRIVERS
*
* Restart config...
*
*
* Multimedia devices
*
*
* Multimedia core support
*
Video For Linux (VIDEO_DEV) [N/m/y/?] n
DVB for Linux (DVB_CORE) [M/n/y/?] m
*
* Multimedia drivers
*
Load and attach frontend and tuner driver modules as needed (MEDIA_ATTACH) [N/y/?] n
Dynamic DVB minor allocation (DVB_DYNAMIC_MINORS) [N/y/?] (NEW)

(Last edited by tcjew on 11 Oct 2009, 19:55)

Hello,

There is one problem you got which is corrected in the new dvb.mk I uploaded tonight (it's because I didn't tested with a fresh kamikaze download hmm )

The second problem is that the kernel encounter configurations options for which he doesn't know what to do. Normally answering
no to all of them is fine.
The other option is to complete the file
target/linux/generic-2.6/config-2.6.30 (or 2.6.28 depending on the kernel you use)
with all these symbols

Now it should work with a fresh download

Edit : to make the task easier, I wrotted a script (which can be improverd ...) to generate the dvb.mk from the linux sources
It will find all the dvb-usb devices, the dependancies, the files generated and the firmware name.

You can find it here http://gitweb.braice.net/gitweb?p=mumud … hb=openwrt

(Last edited by braice on 16 Oct 2009, 00:15)

Hi,
thanks a lot for your work its really great
i'm having some trouble trying to make it work with an nslu2
i have installed the latest openwrt (from svn) and have made the package for mumudvb

But i cant find how to make your script work. In my case i have a TerraTec Cinergy T USB XS so I tryed to enabled this package: "dvb-usb-af9015" but it dont work
the script search a file name af9015.c but cant find it.
I have find this file on the net in order to complete my image file for flashing my nslu2 but it dont work.  (I really think it wasnt a thing to do but i have no idea ...)

Here is what i have when i try the insmod :
  root@OpenWrt:~# insmod dvb-core
  insmod: cannot insert '/lib/modules/2.6.26.8/dvb-core.ko': File exists (-1): File exists
  root@OpenWrt:~# insmod dvb-usb force_pid_filter_usage=1
  insmod: cannot insert '/lib/modules/2.6.26.8/dvb-usb.ko': File exists (-1): File exists
  root@OpenWrt:~# insmod dvb-pll
  insmod: Loading module failed: No such file or directory
  root@OpenWrt:~# insmod mxl5005s
  insmod: Loading module failed: No such file or directory
  root@OpenWrt:~# insmod tda18271
  insmod: Loading module failed: No such file or directory
  root@OpenWrt:~# insmod qt1010
  insmod: Loading module failed: No such file or directory
  root@OpenWrt:~# insmod mt2060
  insmod: Loading module failed: No such file or directory
  root@OpenWrt:~# insmod af9013
  insmod: Loading module failed: No such file or directory
  root@OpenWrt:~# insmod dvb-usb-af9015
  insmod: Loading module failed: No such file or directory
  root@OpenWrt:~#

And when i plug the dvd stick, here is my dmesg:
  usb 3-2: new high speed USB device using ehci_hcd and address 4
  usb 3-2: configuration #1 chosen from 1 choice

If you can help me?
thanks in advance

(Last edited by giejo on 21 Oct 2009, 22:59)

Hello

The response is here

http://www.kernel.org/pub/linux/kernel/ … Log-2.6.28

commit : 80619de8117701cad1fb5526be6fcfe6fc2a6cc2

Which means that the support of your card was included in the 2.6.28 and according to your log you are using a 2.6.26

I don't know why your openWrt selects a 2.6.26 because in my case it used a 2.6.28.10

For my script, edit the beginning and put the path to your kernel sources (the version which will be used by openwrt)
then run it with "python generatedvbmk.py"
and say yes all the time
then you should find a dvb.mk in the /tmp directory

Regards

(Last edited by braice on 21 Oct 2009, 23:15)

Thanks for the reply.
How do you have the 2.6.28 kernel ?
i used the svn and it is a 2.6.26

Thanks again

Hi,
i've succeed to update the kernel of openwrt.
Now the insmod works but when i launch mumudvb i have :

  root@OpenWrt:/tmp# mumudvb -v -d -c mumu.conf
  MuMuDVB Version 1.6.1-openwrt
  Latest version available from http://mumudvb.braice.net/

  You decided not to send the SDT pid. This is a VLC workaround.
  WARNING : Can't create /var/run/mumudvb/chaines_diffusees_carte0: No such file or directory
  WARNING : Can't create /var/run/mumudvb/chaines_non_diffusees_carte0: No such file or directory
  Streaming. Freq 842000
  FRONTEND DEVICE: /dev/dvb/adapter0/frontend0 : No such file or directory
  FE_GET_INFO: Bad file descriptor
  Tunning issue, card 0

  closing cleanly. Error 7

And in the dmesg there is nothing special for the dvb stick :
  usb 1-1: new high speed USB device using ehci_hcd and address 5
  usb 1-1: configuration #1 chosen from 1 choice

Is it normal ? or have i forgot something ?
thanks in advance

Yes, You forgot to do some symlinks ...
mkdir /dev/dvb
mkdir /dev/dvb/adapter0
ln -s /dev/dvb0.demux0 /dev/dvb/adapter0/demux0
ln -s /dev/dvb0.dvr0 /dev/dvb/adapter0/dvr0   
ln -s /dev/dvb0.frontend0 /dev/dvb/adapter0/frontend0

thanks for your response

no all symlinks and mkdir were made
dont know why it dont work ...

here is my lsusb :
root@OpenWrt:~# lsusb
Bus 003 Device 001: ID 1d6b:0001
Bus 002 Device 001: ID 1d6b:0001
Bus 001 Device 006: ID 0ccd:0043 TerraTec Electronic GmbH
Bus 001 Device 001: ID 1d6b:0002

The message looks pretty clear

FRONTEND DEVICE: /dev/dvb/adapter0/frontend0 : No such file or directory

are you sure you didn't made a typo/the module is properly loaded/you don't have a firmware problem ?

Hi,
do i need i2c support in openwrt ?
sorry but i'm totaly new for this
thanks

Hi, i think my problem is with the em28xx driver
i think it isnt in my openwrt image
do you have any idea ? how can i add this ?
thanks a lot for your help

Hello

It's a bit tricky, you have to adjust the dvb.mk to add your device
Since this device is not classified as a DVB USB device, the generated dvb.mk does not include it

one simple thing you can do is after doing a first make of openwrt, type
make kernel_menuconfig

You will access to the menuconfig of the kernel that openwrt will build. There you select your device (as a module)

you type make again, openwrt is compiled

and then you have to copy the proper files from
build_dir/linux-"platform"/linux-"version"/drivers/media/*/*.ko

to your device /lib/modules/"version"/

You also have to copy the firmware to your device


And then you should be able to modprobe your modules (if it worked you will see it in the dmesg)

Hope this will help

Hello to you all,

I´m trying to get a dvb device (af9015) to work with my wl500gp.
Had a look at:
http://mumudvb.braice.net/mumudvbwiki/i … B_Embedded (thanks braice)

It seems everything is compiled ok, but trying to load the module dvb-usb-af9015.ko makes insmod segfault.
First I thought this error was due to memory shortage, so I activated so swap space. But still got the same error.
Here is a dump of dmesg:
----
dvb-usb: found a 'Afatech AF9015 DVB-T USB2.0 stick' in cold state, will try to load a firmware
usb 1-1: firmware: requesting dvb-usb-af9015.fw
dvb-usb: downloading firmware from file 'dvb-usb-af9015.fw'
dvb-usb: found a 'Afatech AF9015 DVB-T USB2.0 stick' in warm state.
dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
dvb-usb: pid filter enabled by module option.
DVB: registering new adapter (Afatech AF9015 DVB-T USB2.0 stick)
CPU 0 Unable to handle kernel paging request at virtual address 00000000, epc == 81eac5a4, ra == 81510198
Oops[#1]:
Cpu 0
$ 0   : 00000000 1000d800 00000000 8155db7c
$ 4   : 81e84600 8155db80 00000002 00000038
$ 8   : 00000001 81eaaa98 8d1d0082 09010006
$12   : 0000000f 802207f0 ffffffff 00480000
$16   : 81e84600 8155dbb8 81eaa800 8155dbec
$20   : 8155dc4c 00000100 8155dc38 8156a010
$24   : 00000000 00000000
$28   : 8155c000 8155db40 8156a008 81510198
Hi    : 0000018a
Lo    : 8aee7d00
epc   : 81eac5a4 0x81eac5a4
    Tainted: P
ra    : 81510198 0x81510198
Status: 1000d803    KERNEL EXL IE
Cause : 00800008
BadVA : 00000000
PrId  : 00029006 (Broadcom BCM3302)
Modules linked in: dvb_usb_af9015(+) mc44s803 af9013 mt2060 qt1010 tda18271 mxl5005s dvb_pll dvb_usb i2c_core dvb_core uhci_hcd ath_pci ath_hal(P) nf_nat_tftp nf_conntrack_tftp nf_nat_irc nf_conntrack_irc nf_nat_ftp nf_conntrack_ftp ipt_MASQUERADE iptable_nat nf_nat xt_NOTRACK iptable_raw xt_state nf_conntrack_ipv4 nf_defrag_ipv4 nf_conntrack ehci_hcd ipt_REJECT xt_TCPMSS ipt_LOG xt_multiport xt_mac xt_limit iptable_mangle iptable_filter ip_tables xt_tcpudp x_tables usbcore switch_robo switch_core diag [last unloaded: dvb_usb]
Process insmod (pid: 1103, threadinfo=8155c000, task=81e09148, tls=00000000)
Stack : 0000000d 00000021 00000002 00000010 ffffffff 0000d733 8155dbb8 81eaa800
        8155dbec 81510198 8155dc10 81f6f400 8155db94 81568264 00000000 800033d7
        00000038 81e20003 8155db7c 00010038 00000001 8155db78 010100ff 00000004
        00000004 815104b4 00000000 81eae694 81f6f460 81eaf4f0 00000001 81e84600
        8156b100 81e84600 8156b100 81512500 8155dbf8 81eaf4f0 8155db88 8155db87
        ...
----

Does the "paging request at virtual address 00000000" indicate a null-pointer?

I'm left with only 3 device nodes in /dev:
---
crw-r--r--    1 root     root     212,   4 Jan  1 00:48 dvb0.demux0
crw-r--r--    1 root     root     212,   5 Jan  1 00:48 dvb0.dvr0
crw-r--r--    1 root     root     212,   7 Jan  1 00:48 dvb0.net0
---

If I try to load the module without any firmware being available, it do not give a segfault, but that only shows the problem happens after the module start to load the firmware, I guess.

I'm using openwrt r18328 with kernel 2.6.30.9, and my asus router is a v1 with a atheros wifi card.

Any ideas?

Thanks in advance.

Hello, it seems similar to

http://patchwork.kernel.org/patch/29106/

This patch is included in the 2.6.31, if you can use this kernel you dont have to apply the patch by hand

(Last edited by braice on 12 Nov 2009, 21:51)

I am having a problem making dvb packages under OpenWRT
While compiling I have the fallowing warnings and this is probably the reason why dvb modules are not created
Can any one help me to solve this problem?
(I used script provided by Braice on his page to generate dvb.mk against 2.6.31.6 kernel)

 make[3] -C toolchain/kernel-headers compile
 make[3] -C toolchain/kernel-headers install
 make[3] -C toolchain/uClibc prepare
 make[3] -C toolchain/gcc compile
 make[3] -C toolchain/uClibc compile
 make[3] -C toolchain/gcc install
 make[3] -C toolchain/uClibc install
 make[2] target/compile
 make[3] -C target/linux compile
WARNING: can't parse line: DVB_FE_CUSTOMISE=y
WARNING: can't parse line: MEDIA_TUNER_CUSTOMIZE=y
make[5]: Entering directory `/home/wiktor/Devel/wrt/kamikaze/build_dir/linux-brcm47xx/linux-2.6.31.6'
scripts/kconfig/conf -o arch/mips/Kconfig
^Cmake[7]: *** [oldconfig] Interrupt
make[6]: *** [oldconfig] Interrupt
make[5]: *** [oldconfig] Interrupt
make[3]: *** [compile] Interrupt
make[2]: *** [target/linux/compile] Interrupt
make[1]: *** [/home/wiktor/Devel/wrt/kamikaze/staging_dir/target-mipsel_uClibc-0.9.30.1/stamp/.target_compile] Interrupt
make: *** [world] Interrupt

(Of course I interrupted the compilation)

EDIT: I manage to compile modules finally. Don't know what was the problem. Probably distclean helped

(Last edited by t4ndeta on 20 Nov 2009, 23:48)

Finally got mumudvb working, after i left this project alone for several month.
Mumudvb runs right now on my wl500gp using a Hauppauge NOVA-TD stick, with latest backfire branch.
Can stream 2 pictures perfectly, amazing.
Only one transpoder doesnt want to get autoconfigured, will try manual config the other day.


THX braice for your work and support

I have a skybox S9? ,
it has all function for Linux Operative System ; HD CPU;Available tuners: DVB-S2;
and support on screen menu in multilingual languages, and it can be used in a large area.

(Last edited by Alohe3 on 13 Jan 2011, 11:12)

The discussion might have continued from here.