When trying to set my WRT54GL in client mode, I seem to be having DNS problems. My gateway is set to 192.168.1.1 and my client 192.168.1.116.
# ping -c 3 192.168.1.1
PING 192.168.1.1 (192.168.1.1): 56 data bytes
64 bytes from 192.168.1.1: icmp_seq=0 ttl=64 time=2.0 ms
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=1.5 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=1.7 ms
--- 192.168.1.1 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 1.5/1.7/2.0 ms
# ping openwrt.org
ping: openwrt.org: Unknown host
# ifconfig wl0
wl0 Link encap:Ethernet HWaddr 00:1C:10:13:8F:AD
inet addr:192.168.1.116 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:373 errors:0 dropped:0 overruns:0 frame:88303
TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:48416 (47.2 KiB) TX bytes:3949 (3.8 KiB)
Interrupt:2 Base address:0x5000
# iwconfig wl0
wl0 IEEE 802.11-DS ESSID:"my-ssid"
Mode:Repeater Frequency:2.437 GHz Access Point: 00:1C:10:0B:4B:54
Tx-Power:19 dBm
RTS thr:2347 B Fragment thr:2346 B
Encryption key:<too big>
Link Signal level:-82 dBm Noise level:-93 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:1 Invalid misc:0 Missed beacon:0
# </etc/config/network
#### VLAN configuration
config switch eth0
option vlan0 "0 1 2 3 5*"
option vlan1 "4 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.0.1
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto dhcp
# </etc/config/wireless
config wifi-device wl0
option type broadcom
#option channel 5
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0
config wifi-iface
option device wl0
# option network lan
option mode sta
option ssid my-ssif
option hidden 0
option encryption wep
option key mywepkey