Hi all, I'm configuring my fonera in client mode and I want to use WPA-PSK. Really I have done that, but not in the way that i'd like. First I'll show mi network and wireless files, and after I'm going to tell what I want.
network
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option proto static
option ipaddr 192.168.0.5
option netmask 255.255.255.0
option gateway 192.168.0.1
option dns 192.168.0.1
config interface vlan1
option ifname ath0
option proto dhcp
wireless
config wifi-device wifi0
option type atheros
# option channel 5
# option diversity 1
# option txantenna 0
# option rxantenna 0
# option distance 2000
# disable radio to prevent an open ap after reflashing:
option disabled 0
config wifi-iface
option device wifi0
option network vlan1
option mode sta
option ssid essid
option hidden 0
# option txpower 15
# option bgscan enable
option encryption psk
option key testtest
But I want to use the hex key instead of the password in plain text. I've tried this line but doesn't work:
option key 3e82b064063a7be548adb2db3faf272f0621f1b88843480077c198b2ac2fd2a9
Someone know how can I use that type of password?
(Last edited by neobius on 13 Sep 2007, 18:08)