I have an Asus WL-500W running Kamikaze. I am about to purchase an additional IP (making two) from my ISP to help alleviate some connectivity issues with a particular game when both my roomate and I try to play together (it likes to have particular ports open...and if we're both playing one of us can have a hard time connecting to others). The ISP has recommended connecting a switch to the cable modem, then the computers to the switch. Should work...but is there a way to do this from within my router, to provide some additional security in the form of not automatically making all of the computers ports directly open to the internet....
I really don't know where to begin since I've never dealt with a connection that has more than one IP assigned to it.
Edit: Ok so I've spent the last 3 hours trying to figure it out on my own...
having never had a reason to do this, I discovered that in a traditional linux distro it's possible to create a sub interface, which will allow a single interface to be assigned multiple IP's. From there it appears that it would be a simple (kinda) matter of iptables to forward the correct ports to the correct computer.
Problem is I can't seem to figure out how to handle a subinterface in openwrt...let alone be able to start beating away at the correct iptables.
This is my current network config file...not sure if that's where I set up the sub interfaces.
config switch eth0
option vlan0 "0 1 2 3 4 5u"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0 wl0"
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option ifname "eth1"
option proto dhcp
(Last edited by Druidjaidan on 18 Sep 2007, 20:45)