I can't seem to get my network config to function properly, here's a diagram explaning what I need to accomplish
openwrt
|----------------------|
DHCP Server --> |WAN--Bridge--LAN | --- Other Machines
| | |
| ___WLAN | --- Other machines
|---------------------|
As you can see the "Other machines" should be getting their ip's from the DHCP server on the WAN side, I think that this configuration is commonly refered to as a simple Access Point (not to be confused with AP mode of the wireless driver)
While this should be a relatively easy configuration, I can't get machines on the LAN or WLAN to aquire ip addresses.
here is some relevant config info:
#############################/etc/config/network
#### VLAN configuration
config switch eth0
option vlan0 "1 2 3 4 5*"
option vlan1 "0 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0 wl0"
option macaddr "00:18:F3:2B:17:FA"
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option type bridge
option ifname "eth0.1"
option macaddr "00:18:DE:1F:C0:0A"
option proto dhcp
################################# /etc/config/wireless
config wifi-device wl0
option type broadcom
option channel 5
config wifi-iface
option device wl0
option mode ap
option network lan
option ssid OpenWrt
option hidden 0
option encryption none
#################################ifconfig
ifconfig
br-lan Link encap:Ethernet HWaddr 00:18:F3:2B:17:FA
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:502 errors:0 dropped:0 overruns:0 frame:0
TX packets:311 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:46388 (45.3 KiB) TX bytes:44615 (43.5 KiB)
br-wan Link encap:Ethernet HWaddr 00:18:F3:2B:17:FA
inet addr:130.71.101.89 Bcast:130.71.101.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4013 errors:0 dropped:0 overruns:0 frame:0
TX packets:61 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:714702 (697.9 KiB) TX bytes:9569 (9.3 KiB)
eth0 Link encap:Ethernet HWaddr 00:18:F3:2B:17:FA
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4474 errors:0 dropped:0 overruns:0 frame:0
TX packets:411 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:853943 (833.9 KiB) TX bytes:69342 (67.7 KiB)
Interrupt:4
eth0.0 Link encap:Ethernet HWaddr 00:18:F3:2B:17:FA
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:466 errors:0 dropped:0 overruns:0 frame:0
TX packets:347 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:42207 (41.2 KiB) TX bytes:52552 (51.3 KiB)
eth0.1 Link encap:Ethernet HWaddr 00:18:F3:2B:17:FA
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4015 errors:0 dropped:0 overruns:0 frame:0
TX packets:61 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:731733 (714.5 KiB) TX bytes:9813 (9.5 KiB)
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
wl0 Link encap:Ethernet HWaddr 00:18:F3:2B:17:FA
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:34 errors:0 dropped:0 overruns:0 frame:17004
TX packets:92 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:6509 (6.3 KiB) TX bytes:20076 (19.6 KiB)
Interrupt:2 Base address:0x2000