Here's what I wanted to do. I have a solution if this is what you want to do.....
+---------------+ +---------------+ +---------------+ +---------------+
| | | | | | | |
| laptop |-wireless-| Kamikaze |-wireless-| Backhaul AP |-Ethernet--| Internet |
+--------------+ +---------------+ +---------------+ +---------------+
The same configuration should be able to be used when the Kamikaze LAN port is directly connected to the internet. The WAN port is only used to access the Kamikaze to make changes to the configuration.
This will work without DHCP forwarding.
Here's the configuration:
/etc/config/network:
#### VLAN configuration
config switch eth0
option vlan0 "1 2 3 4 5*"
option vlan1 "0 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 10.0.0.1
option netmask 255.255.255.0
option gateway ''
option dns ''
#### WAN configuration
config interface wan
option type bridge
option ifname "wl0"
option proto dhcp
/etc/config/wireless:
config wifi-device wl0
option type broadcom
option channel 91
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid HarleyNet
option hidden 0
option encryption none
config wifi-iface
option device wl0
option network lan
option mode sta
option ssid Wavion
option hidden 0
option encryption none