You don't need to install the nozomi drivers for your card. It should work fine without them.
This is the installscript I use for my WRT54G3G. From first boot (after telnet:passwd) till finish. I use a local webserver for wgetting my files as I don't have another internet connection but my 3G. If you have a working gateway I suggest though that you download the packages directly on the box. In this case you have a reference on which packages you need.
It works fine with Kamikaze 7.07 and 7.09. I have exactly the same card as you.
ipkg install libncurses_5.6-1_mipsel.ipk
ipkg install nano_1.3.8-1_mipsel.ipk
cd /etc/config
rm wireless
wget wireless
cd /etc/config
rm network
wget network
cd /etc/config
rm dhcp
wget dhcp
ipkg install pcmcia-cs_3.2.8-1_mipsel.ipk
ipkg install kmod-pcmcia-core_2.4.34-brcm-1_mipsel.ipk
cardctl status
ipkg install kmod-usb-core_2.4.34-brcm-1_mipsel.ipk
ipkg install kmod-usb-serial_2.4.34-brcm-1_mipsel.ipk
ipkg install kmod-usb-ohci_2.4.34-brcm-1_mipsel.ipk
ipkg install chat_2.4.3-8_mipsel.ipk
ipkg install comgt_0.32-1_mipsel.ipk
cd /etc/ppp
rm chap-secrets
wget chap-secrets
ifup ppp0
logread
reboot
FILE: 3g.chat
ABORT BUSY
ABORT 'NO CARRIER'
ABORT ERROR
REPORT CONNECT
TIMEOUT 10
"" "AT&F"
OK "ATE1"
OK 'AT+CGDCONT=1,"IP","$USE_APN"'
SAY "Calling UMTS/GPRS"
TIMEOUT 30
OK "ATD*99***1#"
CONNECT ' '
FILE: network
#### VLAN configuration
config switch eth0
option vlan0 "1 2 3 4 5*"
option vlan1 "0 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.1.254
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto dhcp
config interface ppp0
option ifname "ppp0"
option proto 3g
option device /dev/usb/tts/0
option apn www.xlgprs.net
option username xlgprs
option password proxl
FILE: wireless
config wifi-device wl0
option type broadcom
option channel 5
option macfilter '2'
option maclist '00:16:36:6B:91:AB 00:13:02:85:68:DA'
# REMOVE THIS LINE TO ENABLE WIFI:
#
# option disabled 1
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid MAS3G
option encryption none
FILE: 3g.connect
#!/bin/sh
. /lib/network/3g.sh
set_3g_led 1 1 1
/usr/sbin/chat -V -E -f /etc/chatscripts/3g.chat
FILE: chap-secrets
#USERNAME PROVIDER PASSWORD IPADDRESS
xlgprs * proxl
FILE: dhcp
config dhcp
option interface lan
option start 10
option limit 10
option leasetime 24h
config dhcp
option interface wan
option ignore 1
for put up your internet connection:
root@OpenWRT:~# ifup ppp0
ifconfig: SIOCGIFFLAGS: No such device
SIM ready
PIN set successfully
Trying to set mode
root@OpenWRT:~#
to see what's happening with the connection
root@OpenWRT:~# logread
root@OpenWRT:~# logread -f
I hope this helps!
(Last edited by kajje on 23 Oct 2007, 09:20)