I have scoured the net trying to find an answer to this question:
What do I need to change to get chillispot to authenticate wireless and wired ports at the same time?
I have tried many many suggestions that I found on the net, but none seem to work for my setup. I don't know if I am missing a vlan or a firewall rule or what??
I am running on kamikaze 2.4 7.06 on a buffalo WRT-HP-G54. Running openwrt, chillispot, freeradius (flatfile users for now), microperl, mini-httpd=openssl and everything is working great over the wireless connections, but I need to add the wired ports (at least one of them) so I can incorporate an access point which is wired to the existing router.
I have tried bridging wl0 and eth0.0 but that didn't seem to do the trick (I probably did it wrong...)
I have tried using the 'option network lan' setting in the chilli.conf file but that just broke everything it seemed
I've tried changing the dhcpif variable in chilli.conf to a number of values
Here are some specifics:
my dnsmasq has been removed
------------------------------------
/etc/config/wireless:
------------------------
config wifi-device wl0
option type broadcom
option channel 5
config wifi-iface
option device wl0
# option network lan
option mode ap
option ssid OpenWrt
option hidden 0
option encryption none
/etc/config/network:
-----------------------
#### VLAN configuration
config switch eth0
option vlan0 "1 2 3 4 5*"
option vlan1 "0 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto dhcp
/etc/firewall.user: (added this line to the end)
----------------------------------------------------
...
iptables -A forwarding_rule -i tun0 -j ACCEPT
/etc/chilli.conf
----------------
radiusserver1 127.0.0.1
radiusserver2 127.0.0.1
radiussecret testing123
dhcpif wl0
dns1 216.221.100.74
dns2 192.168.182.2
uamanydns
uamsecret testing123
uamserver https://192.168.182.1/cgi-bin/hotspotlogin.cgi
domain hwatech.net
Any help would be greatly appreciated!!!
Larry