OpenWrt Forum Archive

Topic: PulseAudio?

The content of this topic has been archived between 14 Mar 2016 and 5 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

might be something to do with libudev, trying with --disable-udev...

Hello

Indeed it was to do with missing udev on the wgt634u; no libudev

open("/lib/libudev.so.0", O_RDONLY)     = -1 ENOENT (No such file or directory)
open("/usr/lib/libudev.so.0", O_RDONLY) = -1 ENOENT (No such file or directory)

I rebuilt pulseaudio without udev (added the line --disable-udev in the openwrt Makefile pulseaudio config) and its working now - I can sink audio from the network to my alsa USB sound card!

A couple of things - I also had to make the sound devices read-write for user pulse : chmod a+w /dev/snd/*

I had to make the pulse config files readable by user pulse: chmod a+r /etc/pulse/*

I also used the /etc/pulse/daemon.conf settings from http://wiki.openwrt.org/doc/howto/pulseaudio for a 'low-resource system' - in particular I think the resample-method=trivial is important, it avoids attempts to use libspeex for resampling - perhaps could compile pulseaudio without libspeexdsp...[TODO]

I also made a very trivial /etc/pulse/system.pa with just:
load-module module-alsa-sink
load-module module-native-protocol-tcp auth-anonymous=1

One thing - running pulseaudio with -vvv I can see a lot of memblock.c warnings: Memory block too large for pool : 10200 > 4096

Doesnt stop it playing (some minor stutters but probably due to playing machine connected to network by wifi)

Thanks for the support!

John

(Last edited by johncass on 29 Nov 2011, 08:26)

Hi - quick supplementary question;
pulseaudio working well on the WGT634u now, it plays happily from the network BUT does not play locally;
paplay /file.wav give the following error:

Connection failure: Connection refused
pa_context_connect() failed: Connection refused

This might be to do with permissions - Im running as root, I added root to group pulse in /etc/group but no change.
If I export PULSE_SERVER=localhost
then I can paplay /file.wav
so it will accept connections from the network, just not locally.
Also mpd fails with the same error with pulse as its output...
Any ideas on what could be done?
John

I read the thread twice now, was there any conclusion/solution to what Gert reported in #25 here?:
D: [alsa-sink] protocol-native.c: Underrun on 'C-Media USB Headphone Set Analog Stereo for user@v3750-mm', 0 bytes in queue.

I have the same problem here, very dissorted sound, though using current versions (PA 1.1, trunk 29906) on a MR3020 (which is pretty similar to the 1043ND)
Using the settings from this thread and the wiki; But Playing sound locally on the WRT with i.e. madplay is perfectly fine here, so I guess, Alsa and soundcard is ok..

Then I tried using Multicast-RTP instead of TCP - worked *MUCH* better initially, but only for some minutes, then the same stuff popped up..

Any hints appreciated where to start further debugging or what else to try (or if anybody got this really working at all..)

Makki

P.S.: Client is not loaded, Ubuntu 11.10, i7, 100M eth-connection

I've got the same problem with pulseaudio and udev. I'm using the latest packages from the snapshot repository. So I guess I have to build the pulse audio package again. But how do I do that?

I think I have the same problem as the others too.
When I tried to start PulseAudio (OpenWRT Trunk r30919 on a WNDR3700v2) I got the same error message, so I modified the /etc/init.d/pulseaudio to:

#!/bin/sh /etc/rc.common
# Copyright (C) 2011 OpenWrt.org

START=65

SERVICE_USE_PID=1
SERVICE_PID_FILE=/var/run/pulse/pid

start() {
    user_exists pulse 51 || user_add pulse 51
    group_exists pulse 51 || group_add pulse 51
    [ -d /var/run/pulse ] || {
        mkdir -m 0755 -p /var/run/pulse
        chmod 0750 /var/run/pulse
        chown pulse:pulse /var/run/pulse
    }
    [ -d /var/lib/pulse ] || {
        mkdir -m 0755 -p /var/lib/pulse
        chmod 0750 /var/lib/pulse
        chown pulse:pulse /var/lib/pulse
    }
    service_start /usr/bin/pulseaudio --system --disallow-exit --disallow-module-loading --disable-shm --exit-idle-time=-1 --log-level=4 --log-target=stderr
}

stop() {
    service_stop /usr/bin/pulseaudio
}

When I run `/etc/init.d/pulseaudio start` the following was outputed:

D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: setpriority() worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: Found user 'pulse' (UID 51) and group 'pulse' (GID 51).
I: [pulseaudio] main.c: Successfully dropped root privileges.
I: [pulseaudio] main.c: This is PulseAudio 1.1
D: [pulseaudio] main.c: Compilation host: mips-openwrt-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -I/home/openwrt/slave/ar71xx/build/staging_dir/target-mips_r2_uClibc-0.9.33/usr/lib/libiconv-stub/include -I/home/openwrt/slave/ar71xx/build/staging_dir/target-mips_r2_uClibc-0.9.33/usr/lib/libintl-stub/include -std=gnu99  -Wall -W -Wextra -Wno-long-long -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: [pulseaudio] main.c: Running on host: Linux mips 3.2.9 #1 Tue Mar 13 20:33:19 MST 2012
D: [pulseaudio] main.c: Found 1 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: All asserts enabled.
I: [pulseaudio] main.c: Machine ID is NetgearWRT.
I: [pulseaudio] main.c: Using runtime directory /var/run/pulse.
I: [pulseaudio] main.c: Using state directory /var/lib/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-1.1/modules.
I: [pulseaudio] main.c: Running in system mode: yes
W: [pulseaudio] main.c: OK, so you are running PA in system mode. Please note that you most likely shouldn't be doing that.
W: [pulseaudio] main.c: If you do it nonetheless then it's your own fault if things don't work as expected.
W: [pulseaudio] main.c: Please read http://pulseaudio.org/wiki/WhatIsWrongWithSystemMode for an explanation why system mode is usually a bad idea.
I: [pulseaudio] main.c: Fresh high-resolution timers available! Bon appetit!
D: [pulseaudio] memblock.c: Using private memory pool with 1024 slots of size 4.0 KiB each, total size is 4.0 MiB, maximum usable slot size is 4056
D: [pulseaudio] cli-command.c: Checking for existence of '/usr/lib/pulse-1.1/modules/module-udev-detect.so': success
W: [pulseaudio] core-error.c: Unable to convert error string to locale, filtering.
E: [pulseaudio] module-udev-detect.c: inotify_init1() failed: Invalid argument
E: [pulseaudio] module.c: Failed to load module "module-udev-detect" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.
I: [pulseaudio] main.c: Daemon terminated.

(Last edited by fabiei on 17 Mar 2012, 20:32)

Hey, im having exactly the same error!


W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
W: [pulseaudio] core-error.c: Unable to convert error string to locale, filtering.
E: [pulseaudio] module-udev-detect.c: inotify_init1() failed: Invalid argument
E: [pulseaudio] module.c: Failed to load module "module-udev-detect" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.



Any Idea what i can do there?!

Thanks,

Pcace

No Idea what we can do there?


This is the Output on my system:

root@Keksschachtel:/etc/pulse# pulseaudio -vvv
W: [pulseaudio] main.c: This program is not intended to be run as root (unless --system is specified).
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: setpriority() worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: This is PulseAudio 1.1
D: [pulseaudio] main.c: Compilation host: mips-openwrt-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -I/home/openwrt/slave/ar71xx/build/staging_dir/target-mips_r2_uClibc-0.9.33/usr/lib/libiconv-stub/include -I/home/openwrt/slave/ar71xx/build/staging_dir/target-mips_r2_uClibc-0.9.33/usr/lib/libintl-stub/include -std=gnu99  -Wall -W -Wextra -Wno-long-long -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: [pulseaudio] main.c: Running on host: Linux mips 3.2.13 #1 Sat Apr 7 18:14:25 PDT 2012
D: [pulseaudio] main.c: Found 1 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: All asserts enabled.
I: [pulseaudio] main.c: Machine ID is Keksschachtel.
I: [pulseaudio] main.c: Using runtime directory /root/.pulse/Keksschachtel-runtime.
I: [pulseaudio] main.c: Using state directory /root/.pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-1.1/modules.
I: [pulseaudio] main.c: Running in system mode: no
I: [pulseaudio] main.c: Fresh high-resolution timers available! Bon appetit!
D: [pulseaudio] memblock.c: Using shared memory pool with 1024 slots of size 4.0 KiB each, total size is 4.0 MiB, maximum usable slot size is 4056
I: [pulseaudio] module-device-restore.c: Successfully opened database file '/root/.pulse/Keksschachtel-device-volumes'.
I: [pulseaudio] module.c: Loaded "module-device-restore" (index: #0; argument: "").
I: [pulseaudio] module-stream-restore.c: Successfully opened database file '/root/.pulse/Keksschachtel-stream-volumes'.
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1 added for object /org/pulseaudio/stream_restore1
I: [pulseaudio] module.c: Loaded "module-stream-restore" (index: #1; argument: "").
I: [pulseaudio] module-card-restore.c: Successfully opened database file '/root/.pulse/Keksschachtel-card-database'.
I: [pulseaudio] module.c: Loaded "module-card-restore" (index: #2; argument: "").
I: [pulseaudio] module.c: Loaded "module-augment-properties" (index: #3; argument: "").
D: [pulseaudio] cli-command.c: Checking for existence of '/usr/lib/pulse-1.1/modules/module-udev-detect.so': success
W: [pulseaudio] core-error.c: Unable to convert error string to locale, filtering.
E: [pulseaudio] module-udev-detect.c: inotify_init1() failed: Invalid argument
E: [pulseaudio] module.c: Failed to load module "module-udev-detect" (argument: ""): initialization failed.
E: [pulseaudio] main.c: Module load failed.
E: [pulseaudio] main.c: Failed to initialize daemon.
I: [pulseaudio] module.c: Unloading "module-device-restore" (index: #0).
I: [pulseaudio] module.c: Unloaded "module-device-restore" (index: #0).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] module.c: Unloading "module-stream-restore" (index: #1).
D: [pulseaudio] protocol-dbus.c: Interface org.PulseAudio.Ext.StreamRestore1 removed from object /org/pulseaudio/stream_restore1
I: [pulseaudio] module.c: Unloaded "module-stream-restore" (index: #1).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] module.c: Unloading "module-card-restore" (index: #2).
I: [pulseaudio] module.c: Unloaded "module-card-restore" (index: #2).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] module.c: Unloading "module-augment-properties" (index: #3).
I: [pulseaudio] module.c: Unloaded "module-augment-properties" (index: #3).
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to remove event.
I: [pulseaudio] main.c: Daemon terminated.
root@Keksschachtel:/etc/pulse#


Pcace

(Last edited by pcace on 21 Apr 2012, 14:57)

I've got it working on my TL-WR1043ND using a snapshot release. When I try to stream audio from my Ubuntu 12.04 box over wifi using:
paplay -s 192.168.0.44 debaser.wav
I get  perfect playback, but when I configure my client to stream all audio though the zeroconf detected sound device I get jittery audio.
What could be the cause of this ?

I also have cracks and noise when playing via mpd in trunk.

If I toggle pause/play, sound becomes clear, and rests so until the next track is played.
Then the sound may be clear, or it may be with noise. It seems that it's random. But it always stays clear till the end of the track if the track started to play clear or if it was made clear with pause/play.

Backfire with the analogous setup produces perfect sound.

EDIT:
Solved - add

device          "hw:0,0"

to "audio_output" section of mpd.conf

(Last edited by usv on 19 Jul 2012, 16:35)

pulseaudio-2.1 is now available in openwrt

Hello loswillios,
I compiled r32786 and installed pulseaudio-daemon successfully. I can see via wireshark that client is sending data and server is receiving it. But there's no sound. The only thing that I changed was adding to system.pa the following lines (as said in the official howto):

load-module module-esound-protocol-tcp auth-anonymous=1
load-module module-native-protocol-tcp auth-anonymous=1

Why it's not working?
Here is my setup:

./scripts/feeds install pulseaudio-daemon
CONFIG_PACKAGE_kmod-usb-audio=m
CONFIG_PACKAGE_pulseaudio-daemon=m

Tell what further diagnostic info you need.
Regards

Try unmuting the device with alsamixer or thelike. Also, get local sound working first.

Hello loswillios,
First of all, thank you for the reply.
Pulseaudio is a lot of fun and I'd like to play with it.

Local sound is working. I run mpd on the same device, which is working fine.

Following is the verbose log of pulseaudio-daemon. It's split into 2 parts. (I started pulseaudio with the same arguments as in init.d script.)

1. Pulseaudio is started on openwrt and waiting for requests.

root@OpenWrt:/# pulseaudio --system --disallow-exit --disallow-module-loading -vvv
N: [pulseaudio] main.c: Running in system mode, forcibly disabling SHM mode!
N: [pulseaudio] main.c: Running in system mode, forcibly disabling exit idle time!
D: [pulseaudio] core-rtclock.c: Timer slack is set to 50 us.
D: [pulseaudio] core-util.c: setpriority() worked.
I: [pulseaudio] core-util.c: Successfully gained nice level -11.
I: [pulseaudio] main.c: Found user 'pulse' (UID 51) and group 'pulse' (GID 51).
I: [pulseaudio] main.c: Successfully dropped root privileges.
I: [pulseaudio] main.c: This is PulseAudio 2.1
D: [pulseaudio] main.c: Compilation host: mips-openwrt-linux-gnu
D: [pulseaudio] main.c: Compilation CFLAGS: -Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -I/home/user/openwrt/kernel-trunk-dir825-ramfs/staging_dir/target-mips_r2_uClibc-0.9.33.2/usr/lib/libiconv-stub/include -I/home/user/openwrt/kernel-trunk-dir825-ramfs/staging_dir/target-mips_r2_uClibc-0.9.33.2/usr/lib/libintl-stub/include -std=gnu99  -Wall -W -Wextra -Wno-long-long -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option
D: [pulseaudio] main.c: Running on host: Linux mips 3.3.8 #1 Sat Jul 21 14:17:44 KRAT 2012
D: [pulseaudio] main.c: Found 1 CPUs.
I: [pulseaudio] main.c: Page size is 4096 bytes
D: [pulseaudio] main.c: Compiled with Valgrind support: no
D: [pulseaudio] main.c: Running in valgrind mode: no
D: [pulseaudio] main.c: Running in VM: no
D: [pulseaudio] main.c: Optimized build: yes
D: [pulseaudio] main.c: FASTPATH defined, only fast path asserts disabled.
I: [pulseaudio] main.c: Machine ID is 5de465b93240b0f33b5d132b00000025.
I: [pulseaudio] main.c: Using runtime directory /var/run/pulse.
I: [pulseaudio] main.c: Using state directory /var/lib/pulse.
I: [pulseaudio] main.c: Using modules directory /usr/lib/pulse-2.1/modules.
I: [pulseaudio] main.c: Running in system mode: yes
W: [pulseaudio] main.c: OK, so you are running PA in system mode. Please note that you most likely shouldn't be doing that.
W: [pulseaudio] main.c: If you do it nonetheless then it's your own fault if things don't work as expected.
W: [pulseaudio] main.c: Please read http://pulseaudio.org/wiki/WhatIsWrongWithSystemMode for an explanation why system mode is usually a bad idea.
I: [pulseaudio] main.c: Fresh high-resolution timers available! Bon appetit!
D: [pulseaudio] memblock.c: Using private memory pool with 1024 slots of size 4.0 KiB each, total size is 4.0 MiB, maximum usable slot size is 4056
D: [pulseaudio] cli-command.c: Checking for existence of '/usr/lib/pulse-2.1/modules/module-udev-detect.so': success
I: [pulseaudio] module-udev-detect.c: Found 0 cards.
I: [pulseaudio] module.c: Loaded "module-udev-detect" (index: #0; argument: "").
D: [pulseaudio] cli-command.c: Checking for existence of '/usr/lib/pulse-2.1/modules/module-esound-protocol-unix.so': success
I: [pulseaudio] module.c: Loaded "module-esound-protocol-unix" (index: #1; argument: "").
I: [pulseaudio] module.c: Loaded "module-native-protocol-unix" (index: #2; argument: "").
I: [pulseaudio] module-stream-restore.c: Successfully opened database file '/tmp/lib/pulse/5de465b93240b0f33b5d132b00000025-stream-volumes'.
I: [pulseaudio] module.c: Loaded "module-stream-restore" (index: #3; argument: "").
I: [pulseaudio] module-device-restore.c: Successfully opened database file '/tmp/lib/pulse/5de465b93240b0f33b5d132b00000025-device-volumes'.
I: [pulseaudio] module.c: Loaded "module-device-restore" (index: #4; argument: "").
I: [pulseaudio] module-default-device-restore.c: Saved default sink 'auto_null' not existent, not restoring default sink setting.
I: [pulseaudio] module-default-device-restore.c: Saved default source 'auto_null.monitor' not existent, not restoring default source setting.
I: [pulseaudio] module.c: Loaded "module-default-device-restore" (index: #5; argument: "").
D: [pulseaudio] cli-command.c: Checking for existence of '/usr/lib/pulse-2.1/modules/module-dbus-protocol.so': failure
I: [pulseaudio] module.c: Loaded "module-rescue-streams" (index: #6; argument: "").
D: [pulseaudio] module-always-sink.c: Autoloading null-sink as no other sinks detected.
I: [pulseaudio] sink.c: Created sink 0 "auto_null" with sample spec s16be 2ch 44100Hz and channel map front-left,front-right
I: [pulseaudio] sink.c:     device.description = "Dummy Output"
I: [pulseaudio] sink.c:     device.class = "abstract"
I: [pulseaudio] sink.c:     device.icon_name = "audio-card"
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to change event.
I: [pulseaudio] source.c: Created source 0 "auto_null.monitor" with sample spec s16be 2ch 44100Hz and channel map front-left,front-right
I: [pulseaudio] source.c:     device.description = "Monitor of Dummy Output"
I: [pulseaudio] source.c:     device.class = "monitor"
I: [pulseaudio] source.c:     device.icon_name = "audio-input-microphone"
D: [null-sink] module-null-sink.c: Thread starting up
D: [pulseaudio] module-device-restore.c: Could not set format on sink auto_null
I: [pulseaudio] module.c: Loaded "module-null-sink" (index: #7; argument: "sink_name=auto_null sink_properties='device.description="Dummy Output"'").
I: [pulseaudio] module.c: Loaded "module-always-sink" (index: #8; argument: "").
D: [pulseaudio] module-suspend-on-idle.c: Sink auto_null becomes idle, timeout in 5 seconds.
I: [pulseaudio] module.c: Loaded "module-suspend-on-idle" (index: #9; argument: "").
I: [pulseaudio] module.c: Loaded "module-position-event-sounds" (index: #10; argument: "").
W: [pulseaudio] core-error.c: Unable to convert error string to locale, filtering.
E: [pulseaudio] socket-server.c: socket(PF_INET6): Address family not supported by protocol
I: [pulseaudio] module.c: Loaded "module-esound-protocol-tcp" (index: #11; argument: "auth-anonymous=1").
W: [pulseaudio] core-error.c: Unable to convert error string to locale, filtering.
E: [pulseaudio] socket-server.c: socket(PF_INET6): Address family not supported by protocol
I: [pulseaudio] module.c: Loaded "module-native-protocol-tcp" (index: #12; argument: "auth-anonymous=1").
I: [pulseaudio] main.c: Daemon startup complete.
I: [pulseaudio] module-suspend-on-idle.c: Sink auto_null idle for too long, suspending ...
D: [pulseaudio] sink.c: Suspend cause of sink auto_null is 0x0004, suspending
D: [pulseaudio] core.c: Hmm, no streams around, trying to vacuum.

2. I start vlc-pulseaudio on my PC and wait until it dies.

I: [pulseaudio] client.c: Created 0 "Native client (TCP/IP client from 192.168.1.125:36405)"
I: [pulseaudio] protocol-native.c: Client authenticated anonymously.
D: [pulseaudio] protocol-native.c: Protocol version: remote 16, local 26
D: [pulseaudio] protocol-native.c: SHM possible: no
D: [pulseaudio] protocol-native.c: Negotiated SHM: no
I: [pulseaudio] sink-input.c: Trying to change sample rate
I: [pulseaudio] sink-input.c: Resampling enabled to 44100 Hz
D: [pulseaudio] sink.c: Suspend cause of sink auto_null is 0x0000, resuming
D: [pulseaudio] module-suspend-on-idle.c: Sink auto_null becomes idle, timeout in 5 seconds.
D: [pulseaudio] module-suspend-on-idle.c: Sink auto_null becomes busy.
I: [pulseaudio] resampler.c: Using resampler 'speex-float-3'
I: [pulseaudio] resampler.c: Using float32be as working format.
I: [pulseaudio] resampler.c: Choosing speex quality setting 3.
D: [pulseaudio] memblockq.c: memblockq requested: maxlength=33554432, tlength=0, base=4, prebuf=0, minreq=1 maxrewind=0
D: [pulseaudio] memblockq.c: memblockq sanitized: maxlength=33554432, tlength=33554432, base=4, prebuf=0, minreq=4 maxrewind=0
I: [pulseaudio] sink-input.c: Created input 0 "audio stream" on auto_null with sample spec float32le 2ch 48000Hz and channel map front-left,front-right
I: [pulseaudio] sink-input.c:     media.name = "audio stream"
I: [pulseaudio] sink-input.c:     application.name = "Lecteur multimédia VLC"
I: [pulseaudio] sink-input.c:     native-protocol.peer = "TCP/IP client from 192.168.1.125:36405"
I: [pulseaudio] sink-input.c:     native-protocol.version = "16"
I: [pulseaudio] sink-input.c:     application.process.id = "2568"
I: [pulseaudio] sink-input.c:     application.process.user = "user"
I: [pulseaudio] sink-input.c:     application.process.host = "debian"
I: [pulseaudio] sink-input.c:     application.process.binary = "vlc"
I: [pulseaudio] sink-input.c:     application.language = "fr_FR.utf8"
I: [pulseaudio] sink-input.c:     window.x11.display = ":0.0"
I: [pulseaudio] sink-input.c:     application.process.machine_id = "06083d4df29307cb70c6399600000009"
I: [pulseaudio] sink-input.c:     application.process.session_id = "06083d4df29307cb70c6399600000009-1342959413.735830-212153586"
I: [pulseaudio] sink-input.c:     module-stream-restore.id = "sink-input-by-application-name:Lecteur multimédia VLC"
I: [pulseaudio] protocol-native.c: Requested tlength=200.00 ms, minreq=20.00 ms
D: [pulseaudio] protocol-native.c: Adjust latency mode enabled, configuring sink latency to half of overall latency.
D: [pulseaudio] protocol-native.c: Requested latency=80.00 ms, Received latency=80.00 ms
D: [pulseaudio] memblockq.c: memblockq requested: maxlength=153600, tlength=46080, base=8, prebuf=38400, minreq=7680 maxrewind=0
D: [pulseaudio] memblockq.c: memblockq sanitized: maxlength=153600, tlength=46080, base=8, prebuf=38400, minreq=7680 maxrewind=0
I: [pulseaudio] protocol-native.c: Final latency 200.00 ms = 80.00 ms + 2*20.00 ms + 80.00 ms
D: [pulseaudio] core-subscribe.c: Dropped redundant event due to change event.
I: [pulseaudio] module-stream-restore.c: Storing volume/mute/device for stream sink-input-by-application-name:Lecteur multimédia VLC.
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [null-sink] protocol-native.c: Requesting rewind due to end of underrun.
D: [null-sink] module-null-sink.c: Requested to rewind 14112 bytes.
D: [null-sink] sink.c: Processing rewind...
D: [null-sink] sink-input.c: Have to rewind 9012 bytes on render memblockq.
D: [null-sink] source.c: Processing rewind...
D: [null-sink] module-null-sink.c: Rewound 9012 bytes.
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [null-sink] protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [null-sink] protocol-native.c: Requesting rewind due to end of underrun.
D: [null-sink] module-null-sink.c: Requested to rewind 1396 bytes.
D: [null-sink] sink.c: Processing rewind...
D: [null-sink] sink-input.c: Have to rewind 1396 bytes on render memblockq.
D: [null-sink] source.c: Processing rewind...
D: [null-sink] module-null-sink.c: Rewound 1396 bytes.
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [null-sink] protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
D: [null-sink] protocol-native.c: Requesting rewind due to end of underrun.
D: [null-sink] module-null-sink.c: Requested to rewind 1396 bytes.
D: [null-sink] sink.c: Processing rewind...
D: [null-sink] sink-input.c: Have to rewind 1396 bytes on render memblockq.
D: [null-sink] source.c: Processing rewind...
D: [null-sink] module-null-sink.c: Rewound 1396 bytes.
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [pulseaudio] memblock.c: Memory block too large for pool: 7680 > 4096
D: [null-sink] protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
D: [null-sink] protocol-native.c: Requesting rewind due to end of underrun.
D: [null-sink] module-null-sink.c: Requested to rewind 1396 bytes.
D: [null-sink] sink.c: Processing rewind...
D: [null-sink] sink-input.c: Have to rewind 1396 bytes on render memblockq.
D: [null-sink] source.c: Processing rewind...
D: [null-sink] module-null-sink.c: Rewound 1396 bytes.
D: [null-sink] protocol-native.c: Underrun on 'audio stream', 0 bytes in queue.
I: [pulseaudio] module-stream-restore.c: Synced.
D: [null-sink] module-null-sink.c: Requested to rewind 352800 bytes.
D: [null-sink] sink.c: Processing rewind...
D: [null-sink] source.c: Processing rewind...
D: [null-sink] module-null-sink.c: Rewound 1248 bytes.
D: [pulseaudio] module-suspend-on-idle.c: Sink auto_null becomes idle, timeout in 5 seconds.
D: [pulseaudio] module-suspend-on-idle.c: Sink auto_null becomes idle, timeout in 5 seconds.
D: [pulseaudio] core.c: Hmm, no streams around, trying to vacuum.
I: [pulseaudio] sink-input.c: Freeing input 0 "audio stream"
I: [pulseaudio] client.c: Freed 0 "Lecteur multimédia VLC"
I: [pulseaudio] protocol-native.c: Connection died.
I: [pulseaudio] module-suspend-on-idle.c: Sink auto_null idle for too long, suspending ...
D: [pulseaudio] sink.c: Suspend cause of sink auto_null is 0x0004, suspending
D: [pulseaudio] core.c: Hmm, no streams around, trying to vacuum.

Especially, I think this may shed some light on the problem:

I: [pulseaudio] module-udev-detect.c: Found 0 cards.

I think this may also be of some use:

root@OpenWrt:/# opkg list-installed
alsa-lib - 1.0.24.1-1
base-files - 111-r32786
bemusedlinuxserver - r062-4
blkid - 2.21.2-1
block-mount - 0.2.0-8
bluez-libs - 3.36-3
bluez-utils - 3.36-12
busybox - 1.19.4-2
dbus - 1.4.14-2
dnsmasq - 2.62-1
dropbear - 2011.54-2
e2fsprogs - 1.42.4-1
firewall - 2-53
glib1 - 1.2.10-1
glib2 - 2.26.1-2
hotplug2 - 1.0-beta-4
iptables - 1.4.10-4
iw - 3.3-1
jshn - 2012-07-08-cca2ed6c8cdb3555fea43ff63ba1c9905dd7a164
kernel - 3.3.8-1-7f3df76c2cb4f59ad8550761b1a40f47
kmod-ath - 3.3.8+2012-07-16-1
kmod-ath9k - 3.3.8+2012-07-16-1
kmod-ath9k-common - 3.3.8+2012-07-16-1
kmod-bluetooth - 3.3.8-1
kmod-cfg80211 - 3.3.8+2012-07-16-1
kmod-crypto-aes - 3.3.8-1
kmod-crypto-arc4 - 3.3.8-1
kmod-crypto-core - 3.3.8-1
kmod-fs-ext4 - 3.3.8-1
kmod-gpio-button-hotplug - 3.3.8-1
kmod-hid - 3.3.8-1
kmod-input-core - 3.3.8-1
kmod-input-evdev - 3.3.8-1
kmod-ipt-conntrack - 3.3.8-1
kmod-ipt-core - 3.3.8-1
kmod-ipt-nat - 3.3.8-1
kmod-ipt-nathelper - 3.3.8-1
kmod-leds-gpio - 3.3.8-1
kmod-ledtrig-default-on - 3.3.8-1
kmod-ledtrig-netdev - 3.3.8-1
kmod-ledtrig-timer - 3.3.8-1
kmod-ledtrig-usbdev - 3.3.8-1
kmod-lib-crc-ccitt - 3.3.8-1
kmod-lib-crc16 - 3.3.8-1
kmod-mac80211 - 3.3.8+2012-07-16-1
kmod-nls-base - 3.3.8-1
kmod-ppp - 3.3.8-1
kmod-pppoe - 3.3.8-1
kmod-pppox - 3.3.8-1
kmod-rfkill - 3.3.8-1
kmod-scsi-core - 3.3.8-1
kmod-sound-core - 3.3.8-1
kmod-usb-audio - 3.3.8-1
kmod-usb-core - 3.3.8-1
kmod-usb-ohci - 3.3.8-1
kmod-usb-storage - 3.3.8-1
kmod-usb2 - 3.3.8-1
kmod-wdt-ath79 - 3.3.8-1
libaudiofile - 0.2.7-1
libblkid - 2.21.2-1
libblobmsg-json - 2012-07-08-cca2ed6c8cdb3555fea43ff63ba1c9905dd7a164
libbz2 - 1.0.6-1
libc - 0.9.33.2-1
libcom_err - 1.42.4-1
libcurl - 7.23.1-1
libdbus - 1.4.14-2
libevent2 - 2.0.19-1
libexpat - 2.0.1-1
libext2fs - 1.42.4-1
libfaad2 - 2.7-1
libffmpeg-full - 0.8.7-1
libflac - 1.2.1-1
libgcc - 4.6-linaro-1
libid3tag - 0.15.1b-3
libip4tc - 1.4.10-4
libjson - 0.9-2
libltdl - 2.4-1
libmad - 0.15.1b-3
libminiupnpc - 1.6-1
libmms - 0.6-1
libmpdclient - 2.4-1
libncurses - 5.7-5
libnl-tiny - 0.1-3
libogg - 1.1.4-2
libopenssl - 1.0.1c-1
libpthread - 0.9.33.2-1
librt - 0.9.33.2-1
libshout - 2.2.2-2
libsndfile - 1.0.25-2
libspeex - 1.2rc1-1
libspeexdsp - 1.2rc1-1
libstdcpp - 4.6-linaro-1
libtheora - 1.0-3
libubox - 2012-07-08-cca2ed6c8cdb3555fea43ff63ba1c9905dd7a164
libubus - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
libuci - 2012-03-28.1-1
libuuid - 2.21.2-1
libvorbis - 1.2.3-1
libvorbisidec - 1.0.2+svn14261-1
libxtables - 1.4.10-4
mpc - 0.20-1
mpd-full - 0.16.5-2
mtd - 17
nano - 2.2.6-1
netifd - 2012-07-12-857874b2d4f92b800ecc12a5e52adeaf3855b101
opkg - 618-2
ppp - 2.4.5-6
ppp-mod-pppoe - 2.4.5-6
pulseaudio-daemon - 2.1-1
swap-utils - 2.21.2-1
swconfig - 10
terminfo - 5.7-5
transmission-daemon - 2.60-1
uboot-envtools - 2012.04.01-1
ubus - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
ubusd - 2012-06-01-a62e2f8c15a65efb1a82404d8f31e3bfc1cbe7d9
uci - 2012-03-28.1-1
udev - 173-1
wireless-tools - 29-5
wpad-mini - 20120428-1
zlib - 1.2.7-1

(Last edited by usv on 22 Jul 2012, 15:56)

Make sure pulseaudio finds your soundcard. Are udev and dbus running? Why does /usr/lib/pulse-2.1/modules/module-dbus-protocol.so not exist?

root@OpenWrt:/# ps|grep udev
  733 root       884 S    /sbin/hotplug2 --override --persistent --set-rules-file /etc/hotplug2.rules --set-coldplug-cmd /sbin/udevtrigger --max-children 1
root@OpenWrt:/# ps|grep dbus
1473 root      1696 S    /usr/sbin/dbus-daemon --system
root@OpenWrt:/# opkg files pulseaudio-daemon|grep dbus
(empty output)
I didn't change anything myself. Built everything as is. All the indications are that pulseaudio is built without dbus. It seems like there's a bug somewhere.
(and "udev" is installed automatically as a dependency of pulseaudio-daemon.)

Just in case, here is what is in pusleaudio-daemon package:

root@OpenWrt:/# opkg files pulseaudio-daemon
Package pulseaudio-daemon (2.1-1) is installed on root and has the following files:
/usr/lib/libpulsecore-2.1.so
/usr/lib/libpulse-simple.so.0.0.3
/etc/init.d/pulseaudio
/usr/lib/libpulse.so.0
/usr/lib/pulse-2.1/modules/module-rescue-streams.so
/usr/lib/pulse-2.1/modules/module-always-sink.so
/usr/lib/pulse-2.1/modules/module-rtp-recv.so
/usr/lib/pulse-2.1/modules/module-default-device-restore.so
/usr/lib/pulse-2.1/modules/module-combine.so
/usr/lib/pulse-2.1/modules/module-esound-compat-spawnfd.so
/usr/lib/libpulse-simple.so.0
/etc/pulse/daemon.conf
/usr/lib/libcli.so
/usr/lib/pulseaudio/libpulsecommon-2.1.la
/usr/lib/libraop.so
/usr/lib/librtp.so
/usr/lib/pulse-2.1/modules/module-intended-roles.so
/etc/pulse/default.pa
/usr/bin/pulseaudio
/usr/lib/pulse-2.1/modules/module-remap-sink.so
/usr/lib/pulse-2.1/modules/module-simple-protocol-unix.so
/usr/lib/libprotocol-http.so
/usr/lib/pulse-2.1/modules/module-virtual-source.so
/usr/lib/pulse-2.1/modules/module-tunnel-source.so
/usr/lib/pulse-2.1/modules/module-oss.so
/usr/lib/pulse-2.1/modules/module-null-source.so
/usr/lib/pulse-2.1/modules/module-simple-protocol-tcp.so
/usr/lib/pulse-2.1/modules/module-sine-source.so
/usr/lib/pulse-2.1/modules/module-switch-on-port-available.so
/usr/lib/pulse-2.1/modules/module-native-protocol-fd.so
/usr/lib/pulse-2.1/modules/module-cli-protocol-unix.so
/usr/lib/libpulse.so
/usr/lib/pulse-2.1/modules/module-alsa-sink.so
/usr/lib/pulse-2.1/modules/module-esound-compat-spawnpid.so
/usr/lib/pulse-2.1/modules/module-native-protocol-unix.so
/usr/lib/pulse-2.1/modules/module-filter-apply.so
/usr/lib/pulseaudio/libpulsecommon-2.1.so
/usr/lib/pulse-2.1/modules/module-http-protocol-unix.so
/usr/lib/pulse-2.1/modules/module-raop-sink.so
/usr/lib/pulse-2.1/modules/module-hal-detect.so
/usr/lib/pulse-2.1/modules/module-ladspa-sink.so
/usr/lib/pulse-2.1/modules/module-null-sink.so
/usr/lib/pulse-2.1/modules/module-card-restore.so
/usr/lib/libprotocol-native.so
/usr/lib/pulse-2.1/modules/module-suspend-on-idle.so
/usr/lib/pulse-2.1/modules/module-virtual-surround-sink.so
/usr/lib/pulse-2.1/modules/module-match.so
/usr/lib/pulse-2.1/modules/module-filter-heuristics.so
/usr/lib/libprotocol-cli.so
/usr/lib/pulse-2.1/modules/module-volume-restore.so
/usr/lib/pulse-2.1/modules/module-native-protocol-tcp.so
/usr/lib/pulse-2.1/modules/module-device-restore.so
/usr/lib/pulse-2.1/modules/module-loopback.so
/usr/lib/pulse-2.1/modules/module-echo-cancel.so
/usr/lib/pulse-2.1/modules/module-cli.so
/usr/lib/pulse-2.1/modules/module-alsa-source.so
/usr/lib/pulse-2.1/modules/module-role-cork.so
/usr/lib/libalsa-util.so
/etc/pulse/system.pa
/usr/lib/pulse-2.1/modules/module-virtual-sink.so
/usr/lib/pulse-2.1/modules/module-sine.so
/usr/lib/pulse-2.1/modules/module-udev-detect.so
/usr/lib/pulse-2.1/modules/module-stream-restore.so
/usr/lib/pulse-2.1/modules/module-pipe-sink.so
/usr/lib/pulse-2.1/modules/module-tunnel-sink.so
/usr/lib/pulse-2.1/modules/module-pipe-source.so
/usr/lib/pulse-2.1/modules/module-http-protocol-tcp.so
/usr/lib/pulse-2.1/modules/module-device-manager.so
/usr/lib/pulse-2.1/modules/module-detect.so
/usr/lib/pulse-2.1/modules/module-combine-sink.so
/usr/lib/liboss-util.so
/usr/lib/pulse-2.1/modules/module-augment-properties.so
/usr/lib/pulse-2.1/modules/module-switch-on-connect.so
/usr/lib/pulse-2.1/modules/module-position-event-sounds.so
/usr/lib/pulse-2.1/modules/module-esound-protocol-tcp.so
/etc/pulse/client.conf
/usr/lib/pulse-2.1/modules/module-alsa-card.so
/usr/lib/pulse-2.1/modules/module-rtp-send.so
/usr/lib/libpulse-simple.so
/usr/lib/pulse-2.1/modules/module-cli-protocol-tcp.so
/usr/lib/pulse-2.1/modules/module-esound-sink.so
/usr/lib/pulse-2.1/modules/module-esound-protocol-unix.so
/usr/lib/libpulse.so.0.14.3
/usr/lib/libprotocol-simple.so
/usr/lib/pulse-2.1/modules/module-mmkbd-evdev.so
/usr/lib/libprotocol-esound.so

Oh right, you are not using the avahi-variant (which depends on dbus). So that's fine.

Make sure udev is running.

(Last edited by loswillios on 22 Jul 2012, 17:55)

Udev is not running by default.

root@OpenWrt:/# ps|grep udev
  733 root       884 S    /sbin/hotplug2 --override --persistent --set-rules-file /etc/hotplug2.rules --set-coldplug-cmd /sbin/udevtrigger --max-children 1

Is this a problem of pulseaudio-daemon package?
Anyway, if I run "udevd --daemon", the hotplug line above is removed from process list and replaced by "udevd --daemon", but nothing changes. Verbose log is the same, client crashes after a while, and there's no sound.
Maybe it's the problem of udev? How to configure without it?
Maybe this info should be placed also to the official howto?

(Last edited by usv on 23 Jul 2012, 00:29)

Finally was able to get it running.
I did as in post #52.

(Last edited by usv on 23 Jul 2012, 19:11)

Where i can download pulseaudio-daemon for backfire 10.03.1? It haven't at build-in repository...

The discussion might have continued from here.