Hi all,
Have a questions here:
Hardware: intel ixp based SBC;
LAN : eth0 and eth1;
wireless: 4 miniPCI radio cards:
---wifi0 : 802.11a
---wifi1: 802.11b/g
--wifi2: 802.11a
--wifi3: 802.11b/g
OS: Kamikaze version 7.0.7.
Target:
configure all LANs and wireless LANs in a bridge mode, no DSN, no DHCP (these services are deleted);
and wifi0 will be bridged client mode, and all other wifis(wifi1,2,3) will be ap mode.
Question 1: Since wet mode is not supported by Kamikaze, and sta is routed client mode, what is bridged client mode?
for testing purpose: I disable wifi0,wifi2,and wifi3, and leave only wifi1 active.
Here is the network:
# Network configuration file
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname "eth0 eth1 ath0"
option type bridge
option proto static
option ipaddr 192.168.168.2
option netmask 255.255.255.0
option gateway 192.168.168.1
option dns 204.101.110.2
#wireless config file:
config wifi-device wifi0
option type atheros
option channel 1
option disabled 1
config wifi-iface
option device wifi0
option network lan
option mode ap
option ssid wifi0-802.11a
option encryption none
#------------------------------
config wifi-device wifi1
option type atheros
option channel 6
option disabled 0
config wifi-iface
option device wifi1
option network lan
option mode ap
option ssid SSID
option hidden 0
option encryption wep
option key '1'
option key1 '26 HEXs'
#-------------------------------
config wifi-device wifi2
option type atheros
option channel 5
option disabled 1
config wifi-iface
option device wifi2
option network lan
option mode ap
option ssid wifi2-802.11.a
option encryption none
#--------------------------------
config wifi-device wifi3
option type atheros
option channel 5
option disabled 1
config wifi-iface
option device wifi3
option network lan
option mode ap
option ssid wifi3-802.11b
option encryption none
It works ok if I set wifi1 as AP mode;
But it does not work if I set it as bridged client mode.
here is the modification of wifi1 side:
config wifi-iface
option device wifi1
option mode sta
option ssid MASTERSSID
option encryption wep
option key '1'
option key1 '26 digit HEX'
I want to have a bridged client. Since wet is not supported in kamikaze and sta is a routed client mode.
so what should I put into mode to reolace sta and make bridged client works?
Thanks.