Hi,
I have 2 Linksys wrt54gl routers with kamikaze 7.09 installed. One is setup as an Access Point and is working great, but I've bought another to create a wireless bridge and having problems creating a wds link between them. This is my current config:
Router 1 (my main AP):
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid home
option hidden 0
option encryption psk
option key "1234567890"
config wifi-iface
option device wl0
option network lan
option mode wds
option ssid wdsap
option encryption none
option bssid "00:1C:x:x:x:x" (mac of other router)
Router 2 (the new one)
config wifi-iface
option device wl0
option network lan
option mode ap
option ssid home
option hidden 0
option encryption psk
option key "1234567890"
config wifi-iface
option device wl0
option network lan
option mode wds
option ssid wdsap
option encryption none
option bssid "00:1C:x:x:x:x" (mac of other router)
I couldn't really find any docs on how to set this up, so I'm not sure if my second router needs to also be setup as an Access point, accept this related line in the docs "WDS links can only be used in pure AP mode and cannot use WEP (except when sharing the settings with the master interface, which is done automatically)." I'm not entirely sure what this means, I'm assuming it means my second router also needs to be an Access Point. I've tried taking out the Access Point settings on the second router config and I get an error trying to restart the networking (Command 'set up' failed: -1) so this is the best I've come up with. However it's not working, I'm getting this error in the logs: "wds0.1: attempt to add interface with same source address." so have I maybe mis configured the network settings? Any help or suggestions would be great.