OpenWrt Forum Archive

Topic: is Sta mode broken in current kamikaze trunk?

The content of this topic has been archived on 29 Mar 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I have configured one router as an ap using Avila GW2345 boards with 1 atheros mini pci card in each.  The access point works great for all of the wireless pc connections that I current have.

I have configured a 2nd router board in sta mode and connected to the first ap.  whenever I do a ping test I get major packet loss and unusually high ping times.

# ping 192.168.1.90
PING 192.168.1.90 (192.168.1.90): 56 data bytes
64 bytes from 192.168.1.90: seq=7 ttl=64 time=301.712 ms
64 bytes from 192.168.1.90: seq=8 ttl=64 time=221.426 ms
64 bytes from 192.168.1.90: seq=12 ttl=64 time=89.562 ms
64 bytes from 192.168.1.90: seq=13 ttl=64 time=164.362 ms
64 bytes from 192.168.1.90: seq=14 ttl=64 time=153.881 ms
64 bytes from 192.168.1.90: seq=15 ttl=64 time=192.297 ms
64 bytes from 192.168.1.90: seq=16 ttl=64 time=157.112 ms
64 bytes from 192.168.1.90: seq=17 ttl=64 time=173.325 ms
64 bytes from 192.168.1.90: seq=18 ttl=64 time=67.824 ms
64 bytes from 192.168.1.90: seq=19 ttl=64 time=73.963 ms

--- 192.168.1.90 ping statistics ---
20 packets transmitted, 10 packets received, 50% packet loss
round-trip min/avg/max = 67.824/159.546/301.712 ms

for testing I have this /etc/config/network:

# Copyright (C) 2006 OpenWrt.org

config interface loopback
      option ifname   lo
      option proto    static
      option ipaddr   127.0.0.1
      option netmask  255.0.0.0

config interface lan
      option type     bridge
      option ifname   "eth0 ath0"
      option proto    static
      option ipaddr   192.168.1.91
      option netmask  255.255.255.0

config interface wan
        option ifname   eth1
        option proto    static
        option ipaddr   192.168.3.2
        option netmask  255.255.255.0

and /etc/config/wireless:

config wifi-device  wifi0
        option type     atheros
        option channel  0
      option country  us
      option agmode   11bg
        option diversity        1
        option txantenna        0
        option rxantenna        0

        # REMOVE THIS LINE TO ENABLE WIFI:
        option disabled     0

     config wifi-iface
        option device   wifi0
        option network  lan  
        option mode     sta 
        option ssid     Test
        option encryption wep
        option ap       auto
        option txpower  21
        option bgscan   1
        option wds      0
        option isolate  0
        option key      1234567890
        option hidden   0

The access point is at 192.168.1.90, and I can ping it all day long and never lose a packet from laptop, but I'm losing 40-50% with using sta mode from the other router.

Anyone got any ideas?

Check & setup distance....
..... i'll got something like this when i no setup distance & my link was 3km...
.... i'll check by GPS how long between ap & sta....
..... & all fine smile
May be help wink
Dmitry.

(Last edited by Gig_tmb on 3 Dec 2007, 23:40)

I doubt it is distance related since I'm only about 50 ft away.  Strange that it's only sta mode that's having this issue.

Same problem here.

http://wiki.openwrt.org/ClientModeKamikazeStyleHowto

2007-12-01 — Tried routed client-mode again with Kamikaze 7.09 and Broadcom WiFi does not work good (very high ping times and dhcp does not always works reliable, I'll test it in a few month again)

Hi!

I have the same problem. Ping is slow and lots of packets are dropped. Sometimes, the router even reboots by itself (after 5 -10 min). I tried to disable the firewall thinking that could be the source of the problem, then,  sometimes it works, sometimes not. (looks random)

Here is my config:

Router: wrt54g V2.2, Kamikaze 7.09
AP: ZyXEL P-660HW-D1 original firmware, V3.40(APC.1) | 02/10/2007

/etc/config/network

#### VLAN configuration 
config switch eth0
        option vlan0    "0 1 2 3 4 5*"

#### Loopback configuration
config interface loopback
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0


#### LAN configuration
config interface lan
        option ifname   "eth0.0"
        option proto    static
        option ipaddr   192.168.0.1
        option netmask  255.255.255.0

#### WAN configuration
config interface wan
        option ifname   "wl0"
        option proto    dhcp

/etc/config/wireless

config wifi-device  wl0
        option type     broadcom
        # option channel  4

        # REMOVE THIS LINE TO ENABLE WIFI:
        # option disabled 1

config wifi-iface
        option device   wl0
        # option encryption none
        option mode     sta 
        option ssid     Stardust
        option encryption psk
        option key      "secret passphrase"

running ifconfig gives this:

eth0      Link encap:Ethernet  HWaddr 00:12:17:E2:40:D4  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:278 errors:0 dropped:0 overruns:0 frame:0
          TX packets:164 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:25675 (25.0 KiB)  TX bytes:23036 (22.4 KiB)
          Interrupt:5 

eth0.0    Link encap:Ethernet  HWaddr 00:12:17:E2:40:D4  
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:280 errors:0 dropped:0 overruns:0 frame:0
          TX packets:165 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:20813 (20.3 KiB)  TX bytes:22438 (21.9 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:8 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:584 (584.0 B)  TX bytes:584 (584.0 B)

wl0       Link encap:Ethernet  HWaddr 00:12:17:E2:40:D6  
          inet addr:192.168.10.36  Bcast:192.168.10.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:111 errors:0 dropped:0 overruns:0 frame:275314
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:14634 (14.2 KiB)  TX bytes:2456 (2.3 KiB)
          Interrupt:4 Base address:0x1000

iwconfig

wl0       IEEE 802.11-DS  ESSID:"Stardust"  
          Mode:Repeater  Frequency:2.437 GHz  Access Point: 00:02:CF:5C:D4:46   
          Tx-Power:19 dBm   
          RTS thr:2347 B   Fragment thr:2346 B   
          Encryption key:off
          Link Signal level:-74 dBm  Noise level:-96 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Ping results:
(I get 3-4mS from my laptop)

PING 192.168.10.1 (192.168.10.1): 56 data bytes
64 bytes from 192.168.10.1: icmp_seq=0 ttl=254 time=162.1 ms
64 bytes from 192.168.10.1: icmp_seq=1 ttl=254 time=186.5 ms
64 bytes from 192.168.10.1: icmp_seq=2 ttl=254 time=209.1 ms
64 bytes from 192.168.10.1: icmp_seq=3 ttl=254 time=232.9 ms
64 bytes from 192.168.10.1: icmp_seq=4 ttl=254 time=156.8 ms
64 bytes from 192.168.10.1: icmp_seq=6 ttl=254 time=511.4 ms
64 bytes from 192.168.10.1: icmp_seq=7 ttl=254 time=126.2 ms
64 bytes from 192.168.10.1: icmp_seq=8 ttl=254 time=150.7 ms
64 bytes from 192.168.10.1: icmp_seq=9 ttl=254 time=275.0 ms
64 bytes from 192.168.10.1: icmp_seq=10 ttl=254 time=300.4 ms

--- 192.168.10.1 ping statistics ---
11 packets transmitted, 10 packets received, 9% packet loss
round-trip min/avg/max = 126.2/231.1/511.4 ms

logread:

Jan  1 01:00:08 Heiheiahulu syslog.info syslogd started: BusyBox v1.4.2
Jan  1 01:00:08 Heiheiahulu user.notice kernel: klogd started: BusyBox v1.4.2 (2007-09-29 09:01:24 CEST)
Jan  1 01:00:08 Heiheiahulu user.warn kernel: CPU revision is: 00029007
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Primary instruction cache 8kB, physically tagged, 2-way, linesize 16 bytes.
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Primary data cache 4kB, 2-way, linesize 16 bytes.
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Linux version 2.4.34 (nbd@ds10) (gcc version 3.4.6 (OpenWrt-2.0)) #3 Sun Sep 30 20:33:21 CEST 2007
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Determined physical RAM map:
Jan  1 01:00:08 Heiheiahulu user.warn kernel:  memory: 01000000 @ 00000000 (usable)
Jan  1 01:00:08 Heiheiahulu user.warn kernel: On node 0 totalpages: 4096
Jan  1 01:00:08 Heiheiahulu user.warn kernel: zone(0): 4096 pages.
Jan  1 01:00:08 Heiheiahulu user.warn kernel: zone(1): 0 pages.
Jan  1 01:00:08 Heiheiahulu user.warn kernel: zone(2): 0 pages.
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Kernel command line: root=/dev/mtdblock2 rootfstype=squashfs,jffs2 init=/etc/preinit noinitrd console=ttyS0,115200
Jan  1 01:00:08 Heiheiahulu user.info : /etc/rc.common: eval: 1: /sbin/hotplug2: not found 
Jan  1 01:00:08 Heiheiahulu user.warn kernel: CPU: BCM4712 rev 1 at 216 MHz
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Using 108.000 MHz high precision timer.
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Calibrating delay loop... 212.17 BogoMIPS
Jan  1 01:00:08 Heiheiahulu user.info kernel: Memory: 14224k/16384k available (1462k kernel code, 2160k reserved, 100k data, 80k init, 0k highmem)
Jan  1 01:00:08 Heiheiahulu user.info kernel: Dentry cache hash table entries: 2048 (order: 2, 16384 bytes)
Jan  1 01:00:08 Heiheiahulu user.info kernel: Inode cache hash table entries: 1024 (order: 1, 8192 bytes)
Jan  1 01:00:08 Heiheiahulu user.info kernel: Mount cache hash table entries: 512 (order: 0, 4096 bytes)
Jan  1 01:00:08 Heiheiahulu user.info kernel: Buffer cache hash table entries: 1024 (order: 0, 4096 bytes)
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Page-cache hash table entries: 4096 (order: 2, 16384 bytes)
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Checking for 'wait' instruction...  unavailable.
Jan  1 01:00:08 Heiheiahulu user.warn kernel: POSIX conformance testing by UNIFIX
Jan  1 01:00:08 Heiheiahulu user.warn kernel: PCI: Disabled
Jan  1 01:00:08 Heiheiahulu user.warn kernel: PCI: Fixing up bus 0
Jan  1 01:00:08 Heiheiahulu user.info kernel: Linux NET4.0 for Linux 2.4
Jan  1 01:00:08 Heiheiahulu user.info kernel: Based upon Swansea University Computer Society NET3.039
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Initializing RT netlink socket
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Starting kswapd
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Registering mini_fo version $Id$
Jan  1 01:00:08 Heiheiahulu user.info kernel: devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)
Jan  1 01:00:08 Heiheiahulu user.info kernel: devfs: boot_options: 0x1
Jan  1 01:00:08 Heiheiahulu user.notice kernel: JFFS2 version 2.1. (C) 2001 Red Hat, Inc., designed by Axis Communications AB.
Jan  1 01:00:08 Heiheiahulu user.info kernel: squashfs: version 3.0 (2006/03/15) Phillip Lougher
Jan  1 01:00:08 Heiheiahulu user.warn kernel: pty: 256 Unix98 ptys configured
Jan  1 01:00:08 Heiheiahulu user.info kernel: Serial driver version 5.05c (2001-07-08) with MANY_PORTS SHARE_IRQ SERIAL_PCI enabled
Jan  1 01:00:08 Heiheiahulu user.info kernel: ttyS00 at 0xb8000300 (irq = 3) is a 16550A
Jan  1 01:00:08 Heiheiahulu user.info kernel: ttyS01 at 0xb8000400 (irq = 3) is a 16550A
Jan  1 01:00:08 Heiheiahulu user.info kernel: b44.c:v0.93 (Mar, 2004)
Jan  1 01:00:08 Heiheiahulu user.debug kernel: PCI: Setting latency timer of device 00:02.0 to 64
Jan  1 01:00:08 Heiheiahulu user.info kernel: eth0: Broadcom 47xx 10/100BaseT Ethernet 00:12:17:e2:40:d4
Jan  1 01:00:08 Heiheiahulu user.debug kernel: Physically mapped flash: Found an alias at 0x400000 for the chip at 0x0
Jan  1 01:00:08 Heiheiahulu user.debug kernel: Physically mapped flash: Found an alias at 0x800000 for the chip at 0x0
Jan  1 01:00:08 Heiheiahulu user.debug kernel: Physically mapped flash: Found an alias at 0xc00000 for the chip at 0x0
Jan  1 01:00:08 Heiheiahulu user.debug kernel: Physically mapped flash: Found an alias at 0x1000000 for the chip at 0x0
Jan  1 01:00:08 Heiheiahulu user.debug kernel: Physically mapped flash: Found an alias at 0x1400000 for the chip at 0x0
Jan  1 01:00:08 Heiheiahulu user.debug kernel: Physically mapped flash: Found an alias at 0x1800000 for the chip at 0x0
Jan  1 01:00:08 Heiheiahulu user.debug kernel: Physically mapped flash: Found an alias at 0x1c00000 for the chip at 0x0
Jan  1 01:00:08 Heiheiahulu user.notice kernel: cfi_cmdset_0001: Erase suspend on write enabled
Jan  1 01:00:08 Heiheiahulu user.debug kernel: 0: offset=0x0,size=0x2000,blocks=8
Jan  1 01:00:08 Heiheiahulu user.debug kernel: 1: offset=0x10000,size=0x10000,blocks=63
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Using word write method
Jan  1 01:00:08 Heiheiahulu user.notice kernel: Flash device: 0x400000 at 0x1c000000
Jan  1 01:00:08 Heiheiahulu user.notice kernel: bootloader size: 262144
Jan  1 01:00:08 Heiheiahulu user.info kernel: Physically mapped flash: Filesystem type: squashfs, size=0x121cc8
Jan  1 01:00:08 Heiheiahulu user.notice kernel: Creating 5 MTD partitions on "Physically mapped flash":
Jan  1 01:00:08 Heiheiahulu user.notice kernel: 0x00000000-0x00040000 : "cfe"
Jan  1 01:00:08 Heiheiahulu user.notice kernel: 0x00040000-0x003f0000 : "linux"
Jan  1 01:00:08 Heiheiahulu user.notice kernel: 0x000be400-0x001f0000 : "rootfs"
Jan  1 01:00:08 Heiheiahulu user.warn kernel: mtd: partition "rootfs" doesn't start on an erase block boundary -- force read-only
Jan  1 01:00:08 Heiheiahulu user.notice kernel: 0x003f0000-0x00400000 : "nvram"
Jan  1 01:00:08 Heiheiahulu user.notice kernel: 0x001f0000-0x003f0000 : "rootfs_data"
Jan  1 01:00:08 Heiheiahulu user.err kernel: sflash: found no supported devices
Jan  1 01:00:08 Heiheiahulu user.info kernel: Initializing Cryptographic API
Jan  1 01:00:08 Heiheiahulu user.info kernel: NET4: Linux TCP/IP 1.0 for NET4.0
Jan  1 01:00:08 Heiheiahulu user.info kernel: IP Protocols: ICMP, UDP, TCP, IGMP
Jan  1 01:00:08 Heiheiahulu user.info kernel: IP: routing cache hash table of 512 buckets, 4Kbytes
Jan  1 01:00:08 Heiheiahulu user.info kernel: TCP: Hash tables configured (established 1024 bind 2048)
Jan  1 01:00:08 Heiheiahulu user.warn kernel: ip_conntrack version 2.1 (5953 buckets, 5953 max) - 360 bytes per conntrack
Jan  1 01:00:08 Heiheiahulu user.warn kernel: ip_tables: (C) 2000-2002 Netfilter core team
Jan  1 01:00:08 Heiheiahulu user.info kernel: NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Jan  1 01:00:08 Heiheiahulu user.info kernel: NET4: Ethernet Bridge 008 for NET4.0
Jan  1 01:00:08 Heiheiahulu user.info kernel: 802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
Jan  1 01:00:08 Heiheiahulu user.info kernel: All bugs added by David S. Miller <davem@redhat.com>
Jan  1 01:00:08 Heiheiahulu user.warn kernel: VFS: Mounted root (squashfs filesystem) readonly.
Jan  1 01:00:08 Heiheiahulu user.info kernel: Mounted devfs on /dev
Jan  1 01:00:08 Heiheiahulu user.info kernel: Freeing unused kernel memory: 80k freed
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Algorithmics/MIPS FPU Emulator v1.5
Jan  1 01:00:08 Heiheiahulu user.warn kernel: diag: Detected 'Linksys WRT54G/GS/GL'
Jan  1 01:00:08 Heiheiahulu user.info kernel: b44: eth0: Link is up at 100 Mbps, full duplex.
Jan  1 01:00:08 Heiheiahulu user.info kernel: b44: eth0: Flow control is off for TX and off for RX.
Jan  1 01:00:08 Heiheiahulu user.warn kernel: Probing device eth0: found!
Jan  1 01:00:08 Heiheiahulu user.info kernel: fo: using base directory: /
Jan  1 01:00:08 Heiheiahulu user.info kernel: mini_fo: using storage directory: /jffs
Jan  1 01:00:08 Heiheiahulu user.warn kernel: jffs2.bbc: SIZE compression mode activated.
Jan  1 01:00:09 Heiheiahulu user.info kernel: b44: eth0: Link is up at 100 Mbps, full duplex.
Jan  1 01:00:09 Heiheiahulu user.info kernel: b44: eth0: Flow control is off for TX and off for RX.
Jan  1 01:00:10 Heiheiahulu user.warn kernel: BFL_ENETADM not set in boardflags. Use force=1 to ignore.
Jan  1 01:00:11 Heiheiahulu user.info : BusyBox v1.4.2 (2007-09-29 09:01:24 CEST) multi-call binary 
Jan  1 01:00:11 Heiheiahulu user.info : Usage: ps  
Jan  1 01:00:11 Heiheiahulu user.info : Report process status 
Jan  1 01:00:11 Heiheiahulu user.info : Options: 
Jan  1 01:00:11 Heiheiahulu user.info : ^Iw^IWide output 
Jan  1 01:00:11 Heiheiahulu user.info : BusyBox v1.4.2 (2007-09-29 09:01:24 CEST) multi-call binary 
Jan  1 01:00:11 Heiheiahulu user.info : Usage: ps  
Jan  1 01:00:11 Heiheiahulu user.info : Report process status 
Jan  1 01:00:11 Heiheiahulu user.info : Options: 
Jan  1 01:00:11 Heiheiahulu user.info : ^Iw^IWide output 
Jan  1 01:00:11 Heiheiahulu user.debug kernel: eth0.0: add 01:00:5e:00:00:01 mcast address to master interface
Jan  1 01:00:13 Heiheiahulu user.debug kernel: PCI: Setting latency timer of device 00:01.0 to 64
Jan  1 01:00:13 Heiheiahulu user.warn kernel: wl0: Broadcom BCM4320 802.11 Wireless Controller 4.80.53.0
Jan  1 01:00:13 Heiheiahulu user.info : Warning: loading wl will taint the kernel: no license 
Jan  1 01:00:13 Heiheiahulu user.info :   See http://www.tux.org/lkml/#export-tainted for information about tainted modules 
Jan  1 01:00:13 Heiheiahulu user.info kernel: CSLIP: code copyright 1989 Regents of the University of California
Jan  1 01:00:13 Heiheiahulu user.info kernel: PPP generic driver version 2.4.2
Jan  1 01:00:19 Heiheiahulu cron.notice crond[343]: crond 2.3.2 dillon, started, log level 8 
Jan  1 01:00:20 Heiheiahulu authpriv.info dropbear[347]: Running in background
Jan  1 01:00:24 Heiheiahulu daemon.info dnsmasq[368]: started, version 2.39 cachesize 150
Jan  1 01:00:24 Heiheiahulu daemon.info dnsmasq[368]: compile time options: IPv6 GNU-getopt ISC-leasefile no-DBus no-I18N TFTP
Jan  1 01:00:24 Heiheiahulu daemon.info dnsmasq[368]: DHCP, IP range 192.168.0.100 -- 192.168.0.150, lease time 1d
Jan  1 01:00:24 Heiheiahulu daemon.info dnsmasq[368]: using local addresses only for domain lan
Jan  1 01:00:24 Heiheiahulu daemon.warn dnsmasq[368]: failed to access /tmp/resolv.conf.auto: No such file or directory
Jan  1 01:00:24 Heiheiahulu daemon.info dnsmasq[368]: read /etc/hosts - 3 addresses
Jan  1 01:00:24 Heiheiahulu daemon.info dnsmasq[368]: read /etc/ethers - 2 addresses
Jan  1 01:00:28 Heiheiahulu daemon.info dnsmasq[368]: reading /tmp/resolv.conf.auto
Jan  1 01:00:28 Heiheiahulu daemon.info dnsmasq[368]: using nameserver 192.168.10.1#53
Jan  1 01:00:28 Heiheiahulu daemon.info dnsmasq[368]: using local addresses only for domain lan
Jan  6 17:32:59 Heiheiahulu authpriv.info dropbear[418]: Child connection from 192.168.0.22:39339
Jan  6 17:33:15 Heiheiahulu cron.warn crond[343]: time disparity of 4215872 minutes detected 
Jan  6 17:33:48 Heiheiahulu authpriv.info dropbear[419]: Child connection from 192.168.0.22:39340
Jan  6 17:33:51 Heiheiahulu authpriv.notice dropbear[419]: password auth succeeded for 'root' from 192.168.0.22:39340

Any help would be very much appreciated!

(Last edited by elvicomte on 6 Jan 2008, 17:39)

I'm not having any problems with sta on 7.09, it's been working well for months ... I haven't tried the latest from svn though.

Looks to be something to do with the encryption...

This is what I get on another AP, with no encryption: (wrt54gl V1.1)

PING 192.168.1.1 (192.168.1.1): 56 data bytes
64 bytes from 192.168.1.1: icmp_seq=0 ttl=64 time=1.9 ms
64 bytes from 192.168.1.1: icmp_seq=1 ttl=64 time=3.0 ms
64 bytes from 192.168.1.1: icmp_seq=2 ttl=64 time=2.2 ms
64 bytes from 192.168.1.1: icmp_seq=3 ttl=64 time=2.0 ms
64 bytes from 192.168.1.1: icmp_seq=4 ttl=64 time=1.8 ms
64 bytes from 192.168.1.1: icmp_seq=5 ttl=64 time=1.8 ms
64 bytes from 192.168.1.1: icmp_seq=6 ttl=64 time=2.8 ms
64 bytes from 192.168.1.1: icmp_seq=7 ttl=64 time=1.9 ms
64 bytes from 192.168.1.1: icmp_seq=8 ttl=64 time=2.1 ms
64 bytes from 192.168.1.1: icmp_seq=9 ttl=64 time=1.9 ms
64 bytes from 192.168.1.1: icmp_seq=10 ttl=64 time=2.1 ms

--- 192.168.1.1 ping statistics ---
11 packets transmitted, 11 packets received, 0% packet loss
round-trip min/avg/max = 1.8/2.1/3.0 ms

I need to check though, if the problem comes from the other AP. (by turning encryption ON on this one...)

The discussion might have continued from here.