How can I set those variables?
echo WIFI == $WIFI
echo LAN == $LAN
echo WAN == $WAN
Try to run them all, get no value return. Look ar /etc/config/network and etc/init.d/firewall
network setting:
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
# option ifname "eth0 ath0 ath1 ath2 ath3"
option ifname "eth0 ath0 ath1"
option type bridge
option proto static
option ipaddr 192.168.10.2
option netmask 255.255.255.0
option gateway 192.168.10.1
# option bcast 192.168.10.2
option dns 204.101.160.2
start() {
include /lib/network
scan_interfaces
config_load /var/state/network
config_get WAN wan ifname
config_get WANDEV wan device
config_get LAN lan ifname
## CLEAR TABLES
for T in filter nat; do
iptables -t $T -F
iptables -t $T -X
.....
Any idea?