hi@all!
i'm going to use one Fonera like an home AP: i want to set up an access point, where i can connect with my wireless portables.
on the Fonera i've load the last Kamikaze kernel (7.09).
i've a range of 5 IPs, gived me by my provider: 77.113.158.154/29
my real gateway is 77.113.158.153, and so, i can use only 5 IPs: 77.113.158.154..155..156..157..158
i understand that to configure the Fonera, i've only to modify these 3 files: dhcp, wireless, network.
here:
#vi /etc/confic/network
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 77.113.158.154
option netmask 255.255.255.248
option gateway 77.113.158.153
option dns 208.67.222.222 208.67.220.220
#vi /etc/config/wireless
config wifi-device wifi0
option type atheros
option channel 11
config wifi-iface
option device wifi0
option network lan
option mode ap
option ssid myssid
option encryption none
with this ^ configuration, all is correct, the portable PCs receive all parameter from dhcp, and they go online immediately.
they received an IP like one of these: 77.113.158.155..156..157..158
it's good, but i prefer that the Fonera assign me an IP like 192.168.1.1/24.. is it possible?
so, i try with this configuration:
# vi /etc/config/wireless
config wifi-device wifi0
option type atheros
option channel 11
config wifi-iface
option device wifi0
option network wlan
option mode ap
option ssid myssid
option encryption none
# vi /etc/config/network
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option proto static
option ipaddr 77.113.158.154
option netmask 255.255.255.248
option gateway 77.113.158.153
option dns 208.67.222.222 208.67.220.220
config interface wlan
option ifname ath0
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
# vi /etc/config/dhcp
config dhcp
option interface lan
option start 100
option limit 150
option leasetime 12h
config dhcp
option interface wlan
option start 100
option limit 150
option leasetime 12h
but, with this ^ configuration, the portable PCs connect correctly to the Fonera, and receive all parameters from dhcp, but non able to go online..!
why this?
i don't know where i mistake!
thanks,
Trew
p.s.: form openwrt console, i'm able to ping some host over internet.
from the PCs, i cannot ping internet.
from the PCs i can only ping the Fonera ath0 (192.168.1.1) and the fonera eth0 (77.113.158.154).
from the PCs, if i traceroute the real gateway (77.113.158.153), i have this results:
1 4ms 2ms 3ms 192.168.1.1
2 * * * Richiesta scaduta.
so, i understand that the packages non able to route from 192.168.1.1 to 77.113.158.154, and so to 77.213.158.153.
how can i correct this?
all RESOLVED here: http://forum.openwrt.org/viewtopic.php?pid=60101#p60101
special thanks to ELEON!!
(Last edited by Trew on 7 Dec 2007, 12:43)