OpenWrt Forum Archive

Topic: can't set txpower on an ath/madwifi device

The content of this topic has been archived on 5 Feb 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

This command fails:

root@OpenWrt:~# iwconfig ath0 txpower 20dBm
Error for wireless request "Set Tx Power" (8B26) :
    SET failed on device ath0 ; Invalid argument.

I get the same result if I do it on wifi0.

I know I shouldn't use this to get a better signal, but my radio is rated for between 24 and 28 dB, so I thought it might actually work.  I'm going to confirm that that's OK to do with the radio manufacturer (ubiquiti).

It seems that the Ubiquiti XR2 adds 10db to the power, and 26db is the "true" max.  Maybe 20 is the max in the driver.

Either way, I'm going to try dropping it to 16db.

Try to add a txpower option to the wifi-iface section in /etc/config/wireless and run 'wifi' command.

(Last edited by forum2008 on 4 Jan 2008, 02:31)

Option txpower doesn't seem to work, and the documentation doesn't mention it.

Setting it LOWER manually did work, so I think the card maxes out at 18dB (that's 28dB to the card)

Yes the SR2/XR2 cards always adds 10dB to power setting. 16dBm (26dBm) and 18dBm (28dBm) is the maximum power setting for SR2 and XR2 cards.

The discussion might have continued from here.