OpenWrt Forum Archive

Topic: WL-500gP + Atheros mini-pci card => very poor signal

The content of this topic has been archived on 10 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

So I received my atheros AR5005GS mini-pci card and replaced the original one. I compiled kamikaze from SVN (latest revision, last night) and flashed the firmware. So now I'm running the 2.6 kernel, and installed hostapd-mini. I configured the wireless connection and it's working so far. However, I have a very very poor signal strength and coverage. What am I doing wrong? Here's my config:

root@OpenWrt:~# uci show wireless
wireless.wifi0=wifi-device
wireless.wifi0.type=atheros
wireless.wifi0.channel=5
wireless.wifi0.diversity=0
wireless.wifi0.rxantenna=1
wireless.wifi0.txantenna=1
wireless.wifi0.disabled=0
wireless.cfg2=wifi-iface
wireless.cfg2.device=wifi0
wireless.cfg2.network=lan
wireless.cfg2.mode=ap
wireless.cfg2.ssid=xxxxxx
wireless.cfg2.encryption=psk
wireless.cfg2.key=xxxxxxxxxxxxxxxxxxx

root@OpenWrt:~# iwconfig ath0
ath0      IEEE 802.11g  ESSID:"xxxxx"  Nickname:""
          Mode:Master  Frequency:2.432 GHz  Access Point: 00:11:F5:83:DB:A0
          Bit Rate:0 kb/s   Tx-Power:16 dBm   Sensitivity=1/1
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:xxxxxxxxxxxxxxxxxxxxxxxxxx [2]   Security mode:open
          Power Management:off
          Link Quality=30/70  Signal level=-66 dBm  Noise level=-96 dBm
          Rx invalid nwid:11  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Oh and now all the sudden the wifi connections drop every couple of seconds sad

Jan 11 21:09:04 OpenWrt daemon.info hostapd: ath0: STA xxxxxxxxxxxx IEEE 802.11: associated
Jan 11 21:09:07 OpenWrt daemon.info hostapd: ath0: STA xxxxxxxxxxxx IEEE 802.11: deauthenticated due to local deauth request
Jan 11 21:09:07 OpenWrt daemon.info hostapd: ath0: STA xxxxxxxxxxxx IEEE 802.11: disassociated

bump

Turn off wireless diversity, and enable only one antenna.

wireless.wifi0.diversity=0
wireless.wifi0.rxantenna=1
wireless.wifi0.txantenna=1

isn't this exactly what that is?

sfa wrote:

wireless.wifi0.diversity=0
wireless.wifi0.rxantenna=1
wireless.wifi0.txantenna=1

isn't this exactly what that is?

If you look at my first post closely I already disabled diversity. It doesn't help.

bump

Hello,
I also have Asus 500gp/Atheros and my signal is also a bit poor.  Anybody else ?

Tex

sfa wrote:

wireless.wifi0.diversity=0
wireless.wifi0.rxantenna=1
wireless.wifi0.txantenna=1

isn't this exactly what that is?

Have you connected the antenna to the MAIN or the AUX connector? If last, try setting rxantenna and txantenna to 2, perhaps you were trying to use the wrong connector (happended to me, changing it to the correct one resulted in fine reception).

KanjiMonster wrote:

Have you connected the antenna to the MAIN or the AUX connector? If last, try setting rxantenna and txantenna to 2, perhaps you were trying to use the wrong connector (happended to me, changing it to the correct one resulted in fine reception).

Hi,
in my case I tried to changed the TX/RX Antenna to "2" but the signal has a big drop in this case so I guess I connected the antenna correctly to the main connector. I don't know if this is a big issue but I have 2 times the diversity param listed and in the 1st one there is missing a "y" :

root@OpenWrt:~# uci show wireless | grep wifi
wireless.wifi0=wifi-device
wireless.wifi0.type=atheros
wireless.wifi0.channel=4
wireless.wifi0.mode=11g
wireless.wifi0.diversit=0 <--- here
wireless.wifi0.disabled=0
wireless.wifi0.distance=3
wireless.wifi0.diversity=0<--- here
wireless.wifi0.txantenna=1
wireless.wifi0.rxantenna=1
wireless.cfg2=wifi-iface
wireless.cfg2.device=wifi0

Edit. I had this duplicated value in /etc/config/wireless .. dont know why.
Tex

(Last edited by Tex-Twil on 26 Mar 2008, 12:18)

The discussion might have continued from here.