Above is a sketch of what i want to achieve
I already have an Access Point (Ap on the sketch). This one is configured like this:
- ssid: shoot
- bssid: A2:34:56:FF:23:23
- auth: wpa-psk tkip
- key: blabla
The OpenWrt is a Fonera running kamikaze 7.09:
/etc/config/network
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.0.253
option netmask 255.255.255.0
/etc/config/wireless
config wifi-device wifi0
option type atheros
option mode 11bg
option diversity 0
option txantenna 1
option rxantenna 1
option disabled 0
config wifi-iface
option device wifi0
option network lan
option mode sta
option ssid shoot
option bssid A2:34:56:FF:23:23
option bgscan 0
option encryption psk
option key "blabla"
(I'm not really sure what bssid does, should it be set to the MAC Ap address I connect to ?, can't ssid be sufficient by itself ?)
First problem: WPA connection from OpenWrt to Ap goes down every second:
WPA: Key negotiation completed with A2:34:56:FF:23:23 [PTK=TKIP GTK=TKIP]
CTRL-EVENT-CONNECTED - Connection to A2:34:56:FF:23:23 completed (reauth) [id=0 id_str=]
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Associated with A2:34:56:FF:23:23
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Associated with A2:34:56:FF:23:23
WPA: Key negotiation completed with A2:34:56:FF:23:23 [PTK=TKIP GTK=TKIP]
CTRL-EVENT-CONNECTED - Connection to A2:34:56:FF:23:23 completed (reauth) [id=0 id_str=]
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Associated with A2:34:56:FF:23:23
CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
Associated with A2:34:56:FF:23:23
Am i doing this right ? i feel kinda lost