Hi there,
It works !, my client can reach the internet, but i'm totally lost on the vlan's and bridging :p ... Could someone try to help me out here ?
Got the following issues :
- on my master ap i want to disable my LAN ports and only use my WAN port to go to cisco 827... This doesn't seem to work atm...
I had to connect it to port 0 of the LAN part, this is obviously a bridge/vlan problem ...
- From whatevery pc in the network I cant ssh to 192.168.1.20 or .21 , except if I go via the clientAP, the I can reach 192.168.1.20 :p
############
my network layout :
WRT54GL (sta, client) --> WRT54GL (master ap) --> cisco 827 (192.168.1.1) --> Internet
### Client/STA ###
#### VLAN configuration
config switch eth0
option vlan0 "1 2 3 4 5*"
option vlan1 "0 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.1.50
option netmask 255.255.255.0
option gateway 192.168.1.1
option dns 193.xxxx
config interface wan
option ifname "eth0.1"
option proto static
option ipaddr 192.168.1.51
option gateway 192.168.1.1
option dns 193.xxxxxx
########################
###Master AP###
config switch eth0
option vlan0 "0 1 2 3 5*"
option vlan1 "4 5"
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.1.20
option netmask 255.255.255.0
option gateway 192.168.1.1
option dns 193.xxxxxxxx
config interface wan
option ifname "eth0.1"
option proto static
option ipaddr 192.168.1.21
option netmask 255.255.255.0
option gateway 192.168.1.1
option dns 193xxxxxxxxxx
####################
Help would be greatly appreciated