I have my network set up like:
WAN -> modem [192.168.0.1] -> router [192.168.1.1] -> bridge [10.0.0.1] (Kamikaze 7.09)-> client
Everything connected through the bridge doesn't seem to be able to make connections to 192.168.x.x or WAN. It can ping them, and the domains resolve but when doing something like wget foobar.com it just hangs at "Connecting to foobar.com|x.x.x.x:80...". This seems to be true for all ports. The bridge itself can connect fine, and the setup was working until recently. traceroute -p 80 foobar.com seems to work.
/etc/config/network:
#### VLAN configuration
config switch eth0
option vlan0 "0 1 2 3 5*"
option vlan1 "4 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 10.0.0.1
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option ifname "wl0"
option proto static
option ipaddr 192.168.1.147
option netmask 255.255.255.0
option dns 192.168.1.1
root@OpenWrt:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.0.0.0 * 255.255.255.0 U 0 0 0 br-lan
192.168.1.0 * 255.255.255.0 U 0 0 0 wl0
default 192.168.1.1 0.0.0.0 UG 0 0 0 wl0
user@client ~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
10.0.0.0 * 255.0.0.0 U 0 0 0 eth0
loopback * 255.0.0.0 U 0 0 0 lo
default 10.0.0.1 0.0.0.0 UG 0 0 0 eth0
This seems to only be relevant for certain ports. 8080 seems to work; 80, 443, 21, and 22 don't.
(Last edited by fophillips on 9 Mar 2008, 00:47)