Hello.
I found some threads related to this topic but none of them helped me.
My goal is to set up a network which looks like this:
The red WLAN connection is what doesn't work.
The Fonera should act as a bridge with a static IP address and has to be connected to the DD-WRT router over wifi. Client 5 should get its IP by DHCP. (But it's strange, i see the Fonera as Client in the DD-WRT control panel.)
My current config looks like this:
root@OpenWrt:~# cat /etc/config/wireless
config wifi-device wifi0
option type atheros
option channel 6
config wifi-iface
option device wifi0
option network lan
option mode sta
option ssid OpenWrt
option encryption wep
option key 1
option key1 xxxxxxxxxxxxxxxxxxxxxxxxxx
root@OpenWrt:~# cat /etc/config/network
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.0.40
option netmask 255.255.255.0
Any suggestions?