OpenWrt Forum Archive

Topic: LinkSys WRT160n

The content of this topic has been archived between 21 Apr 2018 and 29 Apr 2018. Unfortunately there are posts – most likely complete pages – missing.

Hi to all,

I'm totally new to OpenWrt and got a LinkSys WRT160n today. The first thing i did, was to have a look, if i could use OpenWrt with it wink
Unfortunately i did not found any useful info, so i searched the web, to find out what it's about this device. As i found, that it has a Broadcom chipset, i assumed i have to use WhiteRussian to be able to use wireless. Hardwarespecifications found at … router.htm told me, that it is nearly the same hardware as the WRT150n, which is listed to work with Kamikaze here: … fdedcffe0d
So now i'm a bit confused, where to start. I tried with openwrt-brcm-2.4-squashfs.trx and with openwrt-wrt150n-2.4-squashfs.bin, both without success.
Is anybody out there, who owns such a device or someone can give me a hint, where to start?

Thanks in advance,


Kamikadze support Linksys WRT160N ?

We don't have one -- patches/donations are welcomed.

Hi groovy

i have tested the v24 firmware image from dd-wrt on my wrt160n and it works.
But my target was to have a writeable root filesystem on this device.
I have read some articles over the wrt150n and wrt160n and my results was the devices has the same hardware.

the next step was i flashed the openwrt(kamikaze) wrt150n image over the dd-wrt webif, the router reboots after the 100% complete flash process, but the device don´t came up and reboots it self every time.   
After that i pressed and hold the reset button while i plugged the power-cable in, but the device was not available over ping.

Current: Only the Power and one lan led lights.

Can you help me how can i recover the device.

@Admin,mod: Sorry, is it possible to move this topic to Kamikaze.

Thanks Robert

(Last edited by RobertD on 5 Jul 2008, 19:19)

moved the topic.. to recover, try to use tftp, if that fails, you have to get serial console working

Hi Kaloz

thanks for reply.
i have attached the wrt160n via lan-cable to my laptop (
i started nmap on the laptop with the follow parameters: "nmap -sP"
and it tells me no device found.
After that i started wireshark, the only response what i get every ca. 5-10 seconds is:

Source: Cisco-Li_xx:xx:xx
Destination: Broadcast
Protocol: Arp
Info: Gratuitous ARP for (Request)

About the reset Button: I see no difference between hold it and plug in the power cable or
pressing it next boot sequence not.
the result what i get are the same: the Router came only with the 2 lights up and is not pingable over lan.

you say i must use a serial cable:
i found @ebay a siemens usb datacable M55 (german seller: articelnr. 200236518652)
is this the right on to get a working console ?

Before i can start the work with the serial console,
i must search for a special screwdriver to open the case.
It is a screw which includes a 6 star profile and in the middle a small bolt.  i like that ;-)

Thanks Robert.

(Last edited by RobertD on 6 Jul 2008, 00:12)

last week I try the same thing and get the same result

moreover I was unable to get my wrt back to life with uploading a new firmware in tftp, the firmware was accepted but it never reboot itself, after power cycling the wrt still could dead

OpenWRT is best thing since sliced bread!

I have some hacking skills and wrt160n box. I'd like to help with working OpenWRT  wrt160n compatible firmware. For now I'm using DD-WRT on this box.
I looked at both DD-WRT and original Linksys toolchains which work with wrt160n. I hope that merging OpenWRT with one of those should not be very hard.

In order to start building images I need a way to recover from from burning invalid firmware.  After all usually shit have tendency to happen before things start actually working smile. I was hoping to use TFTP for recover procedure.  I've set boot_wait to on and wait_time to 30. I do see during boot that wrt160n bootloader indeed waits for 30 sec, yet  I experience the same issue as bigon while trying to TFTP burn original Linksys image over DD-WRT: the firmware is accepted and ACKed, but reboot never happens. After power cycling DD-WRT is still there.

How can I troubleshoot TFTP burn procedure? Does bootloader leaves any traces/logs?
Please advice how could I recover wrt160n from bad firmware burn?

Your thoughts are welcome. Thanks!

I have broken my wrt160n by flashing a SVEASOFT TALISMAN firmware to it. It would boot and look to be working but i could not ping it (at or anything. Even plugging a cable into a port would light that port number up. But I tried everything I could think of and could find on the openwrt wiki and elseware on the internet and it would not respond.

Eventually I tried using tftp to upload the firmware from the linksys website. It would not accept any firmware. Also boot_wait was not on. I did the unspeakable and pressed a metal object against the pins on the flash chip. and with a lot of fiddling around I managed to get an image tftp'd back into the router. The commands I used I recorded on my wiki page. ->

I wish I could be more descriptive about exactly what I did but I did everything more than once so I am not sure what actually worked. (obviously I don't recommend shorting things out inside the WRT, it was a last resort in my case.) But if you flashed your wrt160n and it stopped working, don't give up because it may be less fragile than previously thought.

If you learn anything new about this device please add it to the wiki page. … ys/WRT160N

Hi people, does anyoneone now how to disassemble this router, I remove the 4 screws but I can't open the case...


after the 4 screws come out you pull the case open. there is 2 plastic clips on the left side and 2 more plastic clips on the right side.

I have managed to compile openwrt trunk to boot on the wrt160n.
Boot Messages from serial Console

I will post exact steps when I can confirm exactly what I did.

I think I just downloaded the trunk source code, compiled it once, changed to the linux kernel source directory (build_dir/linux-mips/linux-, changed the configuration to add the '8-bit buswidth' driver for the MTD, exit saving the configuration, copy the .config to the file target/linux/brcm-2.4/config-default , and rerun make. or something like that.

The first time I tried this it saw the flash but still didn't boot. Perhaps there was an update to the code since then? I didn't see anything relevant in the last few days. Or maybe I made a mistake the first time?

Reference: Compiling Trunk

Edit: I added some details about how to configure the build system to make somewhat working images for this router. (WRT160N)
Don't use it if you don't have a serial console installed and working because networking still needs some work.
Details in the wiki

(Last edited by tpwn3r on 23 Aug 2008, 06:49)

Here is a patch I made to allow detection of wrt160n and enabling some LEDs and the buttons. The WLAN LED still doesn't seem to work tho.

Openwrt shouldn't think it is on a "WRT54G/GS/GL" anymore. It was tested on Rev12384. Networking is working better now (not due to this patch but I think due to overall fixes to the platform).
I can connect to the device at on the LAN as long as I disable the firewall first. You still need a serial connection at the moment.
I would appreciate testing and criticism if any is available.

(Last edited by tpwn3r on 2 Sep 2008, 23:16)

Some more updated info is on the wiki page now.

-Wireless G works. (I haven't tested N because I only have a G adapter.)
-Networking works now. (I think there was firewall problems before, that why it wasn't working as expected.)

It would be nice to get more testers and some feedback. Notes about how to build a working image are on the wiki page. Also I will build some working images for testing if anyone wants.

Great, I'm happy to see that people are working on putting openwrt on wrt160n device smile

I have put some images to try on the page mentioned above.
Please read over the quirks on that page before flashing the device with the experimental images.
Recovery is not easy and sometimes requires a serial port to be installed to tell the CFE to flash a working image if you get a bad flash.

Please reply if you have comments, suggestions, criticisms or requests.
It would be nice to have this as a fully supported device in openwrt.

any progress?

I ordered the router. Just waiting for the postman. I hope openwrt will working on it.

SyneX wrote:

any progress?

I haven't received any negative feedback regarding the images on so I will assume they are fairly stable. I have been using the LUCI image on my own device since the date I compiled it. The build instructions on the wiki page also still build using trunk as of last night. I will try to make a set of up-to-date images if I can soon.

Ah thanks.

I've compiled my first image with luci but I think I use your tested image because I haven't a serial cable.

I would be glad to see an up-to-date image. smile

Now I have got the WRT160n. But it is version 2.

I opened the router: it is is a ralink chip. So I will not test openwrt.  Maybe some day, if somebody ports openwrt to this version of router or I get to know which serial cable I need and how to connect - then I will try to analyze the source code from Linksys to try port openwrt.

in my opinion wrt 160 is a very good router with his firmware.if u want customizations take an wl500gp.

Hi to all,
I'm currently working on a WRT160n v2.0 device and have already bricked and recovered it back several times smile AFAIK it's not possible to run any version of OpenWRT on a v2 WRT160n since it is based on a Ralink processor. What I'm trying to do is to simply get a telnetd running on this device. I have downloaded the GPL'ed firmware code v2.0.02.011 from Linksys GPL code center (available from a link on page … /download) and tried to get the telnetd which is part of the busybox software running, with no success. I'm not even sure whether I have been able to successfully spot the location of the startup scripts. There is a script named rcS in folder /etc_ro and I have placed some initialization code for telnetd together with the actual invocation of the deamon in this script but I suspect that this script itself is executed. (Regarding to my last statement, I have placed the line, echo "HO." > /www/test1.html, into this script and built the firmware, then uploaded the new firmware to wrt160n v2 and finally pointed my browser at and got a 404 - not found.)
Could anybody please point me the right direction for installing & getting telnetd running on a WRT160n? Thank you.

I wanted to mention that I have compiled kamikaze 8.09 rev14417 for the WRT160N V1/1.1 and put them on my site. ->
I have flashed them to my device to make sure they do not brick and I did limited testing. If anyone has any requests for additional packages to be compiled in or as a external package let me know. Oleg asked for pptp so that is also in it.

@ulucinar - Have you got a serial port installed on your router? I have found it to be invaluable in testing on unsupported devices. with one you can usually login to the device at the command prompt and poke around. Regarding your question, I do not know about the init process of that routers stock firmware. What arch is that processor? is it mipsel like the broadcom soc's in the wrt?
Good luck smile

tpwn3r wrote:

I wanted to mention that I have compiled kamikaze 8.09 rev14417 for the WRT160N V1/1.1 and put them on my site. ->
I have flashed them to my device to make sure they do not brick and I did limited testing. If anyone has any requests for additional packages to be compiled in or as a external package let me know. Oleg asked for pptp so that is also in it.

@ulucinar - Have you got a serial port installed on your router? I have found it to be invaluable in testing on unsupported devices. with one you can usually login to the device at the command prompt and poke around. Regarding your question, I do not know about the init process of that routers stock firmware. What arch is that processor? is it mipsel like the broadcom soc's in the wrt?
Good luck smile

Hi again,
I tried but haven't been able to install a serial port on my WRT160n v2 device. Using a multimeter, I figured out a +3.3V, a ground, and two more pins and using a level shifter, I connected them to my PC, but I could not see any messages coming while the router was booting. Worse, I am not even sure if I could figure out how to connect to those pins because they seem to have been soldered out (if it's ok to post pictures here, I can post close-up pictures of those pins).

However,  I have been able to get telnetd working and been able to login in a quite dirty way. What I did to achieve this was to replace one of the daemon binaries being started by the firmware's init process with a small script that starts the telnetd. The chipset used on WRT160N v2 is reported to be Ralink's RT2880F on dd-wrt's hardware site.

However, now I've hit another obstacle. We are trying to establish an 802.11n mesh networking testbed and I (believe, I) need to put the radio into IBSS (adhoc) mode. The driver controlling the radio is rt2860v2_ap and again I believe this version of the driver does not support the IBSS mode. Linksys does not provide the source code of rt2860v2_ap module and instead, the firmware source just contains a binary image of the driver. I think I need to get the rt2860v2_sta driver compiled & running on this device. I have even found the source code for rt2860v2_ap and rt2860v2_sta v1.5 drivers in the GPL source of the firmware of Airlink ar670w and cross-compiled them and put them into the firmware for WRT160n, but when I load these drivers, they complain about the firmware version numbers. By the way, the original rt2860v2_ap driver provided by Linksys in the router firmware is 1.6.

How can I get help on compiling the rt2860v2_sta driver for WRT160n v2 or on obtaining a precompiled image? I've emailed Linksys for this issue, and I got a quick reply stating that they do not provide support  for GPL code. I have also emailed Ralink support but did not get a reply yet. In fact, I don't think that the driver's complaining about firmware version is related to the driver's own version (the original driver provided by Linksys reports to be of version 1.6, the rt2860v2_sta driver I have found in the source code of Airlink ar670w's firmware is 1.5). Maybe, I just could not get the driver built in an appropriate way. What do you think about this issue?

Thank you for sharing your time.

(Last edited by ulucinar on 6 Feb 2009, 20:29)

are you guys using wds with the firmware @

I have massive wifi throughput problems with it. If i connect to the router in ap mode i get a throughput of arround 2500 kb/s but if i connect to the wds the throughput is only arround 190 kb/s.

With other firmwares (dd-wrt as example) i don't have such problems.

any ideas how i can fix that?

Here are my wireless settings :

config 'wifi-device' 'wl0'
        option 'type' 'broadcom'
        option 'disabled' '0'
        option 'channel' '11'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'ssid' 'SSID'
        option 'encryption' 'psk2'
        option 'key' 'KEY'

config 'wifi-iface'
        option 'device' 'wl0'
        option 'ssid' 'SSID
        option 'network' 'lan'
        option 'mode' 'wds'
        option 'bssid' 'MAC OF THE OTHER ROUTER'
        option 'encryption' 'psk2'
        option 'key' 'KEY'

hmm, i just made some additional tests.

If i change the encryption method over the LuCI webinterface and click on save and wait till the wds reconnects, the wifi throughput is fixed. After the "reset" through LuCI the throughput is 2500 kb/s, the same as if i connect directly to the ap.

what is LuCI doing after you hit the save button? Any Ideas how to fix that?

hmm, got it fixed by running the "wifi" command after boot on both devices, but why isn't it working without that?

(Last edited by Walhalla on 17 Feb 2009, 01:39)

Sorry, posts 26 to 25 are missing from our archive.