UPDATE
The more effective way to connect is by using the comgt package as underlined in this thread by aoz.syn, that I thank very much. More information in this thread is given in the following posts by aoz.syn. So please consider comgt package in order to activate your HSDPA connection (but also the others).
Here some aoz.syn useful informations
"Mostly the comgt package provides is a sane and tested set of PPP and OpenWRT scripts designed to make configuring cellular data connections as painless as possible. Hopefully the next release will come soon and include it, but here are the additional configuration options it currently provides:
config interface "foo"
option device "/dev/ttyUSB0"
option proto "3g"
option apn "my.provider.apn"
option service "hsdpa" # or cdma, evdo, umts_only, or gprs_only
option pincode "12345"
option mtu "1492"
So, here are my two condensed lists, truths and needs:
Truths:
- Most cellular modems, whether they plug in via PCMCIA, Cardbus, ExpressCard, or direct USB are USB at heart
- Serial speed doesn't matter
- As long as you have a directly supported device and a kernel less than two years old, you don't need to mess with buffer sizes
- Actual throughput almost never matches marketed throughput
Needs:
- For a PCMCIA or Cardbus device, you will need your hardware's PCMCIA or Cardbus drivers in addition to your USB driver
- For an ExpressCard, the base PCI drivers
- A base USB driver (usually ohci_hcd for Cardbus/PCMCIA/ExpressCard)
- usb-serial (2.6) or usbserial (2.4)
- device-specific driver, if available
At this point, if you plug in your device you should see /dev/ttyUSB0 or higher. If you don't, you are missing a driver or driver option
- pppd
- A chat script (there are dozens of examples out there, comgt does provide one that should work for most people)"
The Following is DEPRECATED (better use of comgt)
UPDATE!!! Dear all, I am terribly sorry, but there was a mistake in my router. In the tag on the bottom part the putted asus wl500GP v2 and
they sell to me as V2, but in reality is a V1!!!! You can see the picture here
http://wl500g.info/showthread.php?p=96239#post96239
You should be able to read in the bottom picture wl500GP v2 but in reality is
a wl500G Premium (v1!!!!) as it is shown on the picture (antenna on the left). In the following everything refers to V1
I would like to share with you my last two week experience in connecting a router with a HSDPA usb modem.I am newby but I hope my results could help someone in connecting and maybe improve my solution. I am newby so I am sorry for my naif methods, but it worked. Of course, I will decline any responsibility. Update: It is noteworthy that "HSDPA usb modems" can be used with any router with usb port and they do not need router with special features, like PCMCIA and datacard!!!
You need:
1) Any kamikaze trunk 7.09 router with usb. I used a brand new ASUS wl500GP v2
2) Any HSDPA modem with its initialization commands. I used a modem Onda MH600HS (HSDPA 7.2 Mega). I will support some information about
Huawei E220, since I have the documentation.
3) Internet connection, used for installation
History
Before using a kamikaze trunk based solution I tried, on my Asus wl500GP v2, a product specific firmware, koppel firmware, that I found in http://koppel.cz/cdmawifi/. Koppel is derivated from oleg firmware, http://oleg.wl500g.info/ and oleg comes from the asus original firmware.
I used Koppel firmware within a good Italian Howto (http://forum.telefonino.net/showthread. … ost4976685)
The problem was that the version used of Koppel did not work, because the new v2 was quite different from old v1.
Anyway Koppel and Oleg forums were important to me to learn a little bit about usb HSDPA connection.
Then I decided to use Kamikaze.
How to
1) Look for a suitable Kamikaze trunk software. I used this I found in this post http://forum.openwrt.org/viewtopic.php?id=14856&p=2 a suitable v2 Kamikaze trunk 7.09 (broadcom 2.4) firmware version here http://web03.tzmo.com.pl/~bartek/asuswl500gpv2/.
2) Install Kamikaze. I putted in the recovery mode and used window recovery program to upload the firmware.
3) I followed the howto in http://wiki.openwrt.org/MobileAPHowTo2# … 1fb39fd5cf.
I did the following packages:
[s]ipkg install kmod-usb-ohci[/s] UPDATE: ipkg install kmod-usb-uhci, kmod-usb-uhci-iv, kmod-usb-ohci is not necessary
ipkg install kmod-usb-serial
ipkg install microcom
ipkg install kmod-ppp
ipkg install ppp
ipkg install chat
reboot
in the dsmeg, if you connect your modem your should recognize your modem:
USB Mass Storage support registered.
hub.c: new USB device 01:03.0-2, assigned address 2
usb.c: USB device 2 (vend/prod 0x19d2/0x1) is not claimed by any active driver.
device wl0 entered promiscuous mode
wl0: attempt to add interface with same source address.
br-lan: port 2(wl0) entering learning state
br-lan: port 2(wl0) entering forwarding state
br-lan: topology change detected, propagating
Here you see Vendor and Product ID of my modem (for E220 0x12d1 0x1003)
4) you should set vid and pid and maxSize in usbserial
usbserial vendor=0x19d2 product=0X0001 maxSize=4096
E220 usbserial vendor=0x12d1 product=0x1003 maxSize=4096
IMPORTANT!!! maxSize=4096 buffer size it is necessary for HSDPA. Otherwise default it will go as gprs...
reboot
in dmesg you should have the three devices ttyUSB0 ttyUSB1 ttyUSB2 now:
.............
USB Mass Storage support registered.
hub.c: new USB device 01:03.0-2, assigned address 2
usbserial.c: Generic converter detected
usbserial.c: Generic converter now attached to ttyUSB0 (or usb/tts/0 for devfs)
usbserial.c: Generic converter detected
usbserial.c: Generic converter now attached to ttyUSB1 (or usb/tts/1 for devfs)
usbserial.c: Generic converter detected
usbserial.c: Generic converter now attached to ttyUSB2 (or usb/tts/2 for devfs)
device wl0 entered promiscuous mode
wl0: attempt to add interface with same source address.
...........
5) now you can test if modem works by sending command via microcom.
microcom -D/dev/usb/tts/0
AT
OK
6) Config files. This part depend on specific modem, type of connection. In
http://www.advantedgecomputing.com/open … linux.html you can find useful information, otherwise google it!
IMPORTANT: In order to have HSDPA you have to specify the negotiation speed
my modem negotiation speed: 921600
E220 negotiation speed:460800
mkdir /etc/ppp/peers
vi /etc/ppp/peers/hsdpa
my modem hsdpa file (comments in Italian)
root@OpenWrt:/etc/ppp/peers# cat hsdpa
#informazioni sul dispositivo
/dev/usb/tts/0 #dispositivo assegnato al modem ONDA
921600 #velocit�
#echo 'settata velocit� '
hide-password
noauth
debug
defaultroute
noipdefault
noccp
nobsdcomp
usepeerdns
connect-delay 10000
nodetach
user ""
password ""
#echo 'chiamo lachat'
connect "/usr/sbin/chat -t 60 -f /etc/ppp/peers/hsdpa.chat
E220 HSDPA should look like:
hide-password
noauth
debug
/dev/usb/tts/0
460800
defaultroute
noipdefault
noccp
nobsdcomp
usepeerdns
connect-delay 10000
nodetach
user "$username$"
connect "/usr/sbin/chat -t 60 -f /tmp/ppp/peers/hsdpa.chat
My modem chat file:
vi /etc/ppp/peers/hsdpa.chat
root@OpenWrt:/etc/ppp/peers# cat hsdpa.chat
SAY 'Inizio connessione...'
'' 'ATZ'
'' 'AT+ZOPRT=5'
TIMEOUT 5
'' 'AT'
'' 'ATV1'
'' 'AT&F&D2&C1S0=0'
'' 'ATS7=60S30=0'
'' 'AT+CGDCONT=1,"IP","datacard.tre.it"'
'' 'AT+COPS=1,0,"3 ITA"'
'' 'ATDT*99***1#'
SAY 'connesso infine'
In particular:
'AT+CGDCONT=1,"IP","datacard.tre.it <-connection type, my APN
'AT+COPS=1,0,"3 ITA"'<---- no Roaming, only my operator[/color]
'ATDT*99***1#'<---dial number
E220 chat file should be like:
'' ''
'' 'ATZ'
TIMEOUT 5
'OK' 'AT+CGDCONT=1,"IP","$apn$"'
'OK' 'ATDT$dialno$'
'CONNECT' ''
7) Device setup and Lock file directory creation
You can try:
root@OpenWrt:~# pppd call hsdpa
You may have:
pppd: pppd is unable to open the /dev/ppp device.
In this case, as suggested in http://wiki.openwrt.org/MobileAPHowTo2# … 1fb39fd5cf
you may need (I did not) to do the following:
mknod /dev/ppp c 108 0
root@OpenWrt:~# mkdir /var/lock
root@OpenWrt:~# vi /etc/modules.d/70-ppp
slhc
ppp_generic
ppp_async
also if you have lock option you may add the following
root@OpenWrt:~# vi /etc/init.d/S80ppp
#!/bin/sh
mkdir -p /var/lock
root@OpenWrt:~# chmod +x /etc/init.d/S80ppp
8) Setting the WAN
root@OpenWrt:/# cat /etc/config/network
#### VLAN configuration
config switch eth0
option vlan0 "1 2 3 4 5*"
option vlan1 "0 5"
#### Loopback configuration
config interface loopback
option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0
#### LAN configuration
config interface lan
option type bridge
option ifname "eth0.0"
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
#### WAN configuration
config interface wan
option ifname "ppp0"
option device "ppp0"
root@OpenWrt:/# cat /etc/config/wireless
config wifi-device wl0
option type broadcom
option channel 5
# REMOVE THIS LINE TO ENABLE WIFI:
#option disabled 1
option wifi-iface
option device wl0
option network lan
option mode ap
option ssid KamikazeHSDPA
option encryption psk
option key 'HSDPAconnect!'
root@OpenWrt:/#
9) test drive :
pppd call hsdpa
root@OpenWrt:/# ifconfig ppp0
ppp0 Link encap:Point-to-Point Protocol
inet addr:10.112.4.3 P-t-P:10.64.64.64 Mask:255.255.255.255
UP POINTOPOINT RUNNING NOARP MULTICAST MTU:1500 Metric:1
RX packets:43354 errors:583 dropped:0 overruns:0 frame:0
TX packets:31102 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:3
RX bytes:50288275 (47.9 MiB) TX bytes:3923668 (3.7 MiB)
root@OpenWrt:/etc/ppp/peers# netstat -nr
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
10.64.64.64 0.0.0.0 255.255.255.255 UH 0 0 0 ppp0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 br-lan
0.0.0.0 10.64.64.64 0.0.0.0 UG 0 0 0 ppp0
10) For the moment I reach the end. I discharghe at [s]500 kb from Itunes[/s] 1300 kb/s (same result I had with computer direct connection)
(Last edited by againmoon on 12 May 2008, 06:15)