OpenWrt Forum Archive

Topic: AR430W Atheros AR2318 / AR2317 chipset support

The content of this topic has been archived between 8 Feb 2018 and 27 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I need some help here... partial success - wifi hangs.

I tried openwrt kamikaze 7.09 on AR430W. Loading / flashing was successful and I was able to log into the router using root account.
Then, I installed web interface just to get things up quickly. No issues.
Wireless was disabled by default. On terminal, dmesg shows that wifi0 is available and atheros chipset is seen.
But when I enabled the radio and enabled a wifi interface through web page, the router HUNG !!!
My session was lost and as I didnt have any serial port access, I could not log back in.
The only way to get it back was - REFLASH !!! I tried kamikaze twice but no luck.
Finally reverted back to DD-WRT.

Can anyone please let me know what can be wrong here ?

I have the ImageBuilder installed and I am ready to make any change on the image if needed. Some guidance around what could be wrong and what to change in source.

If I get successful, I will post my summary and compiled binaries if needed.
AR430W seems to be a good router.. smile

Need help here... and this is a fun project.

My NetGear WGR614v7 got a atheros 2317 cpu too

how did you flash it ?

Ok, let me recall.. as it was a random attempt towards openwrt.

I was running DD-WRT before. v24 rc7.
Then, I picked up the .lzma and squashfs files from kamikaze 7.09.
RedBoot> wont help because it does not support some fis commands like "fis init"
I realized that DD-WRT's boot loader is good enough and better than original RedBoot.
So, from DD-WRT> session, you can flash openwrt.
Follow same usual steps. You can basically refer to this link and do it from DD-WRT> level.
http://forum.openwrt.org/viewtopic.php?id=15175

Just make sure to calculate LENGTH as it is mentioned in this thread.

To get DD-WRT, you can use www.dd-wrt.com page. Go to downloads, pick atheros section, release candidates, rc7. Take ap61.ram. You dont need rest.

Hope this will help you and let me know the experience with openwrt on atheros.

OK... GOOD NEWS.

I have solved my own problem after a couple of days.
I picked up latest snapshot of kamikaze 7.09 as of 4/28/08, made changes to madwifi source and then re-compiled.
The new generated binaries worked on Airlink101 AR430W 802.11g router. I am able to use Wifi and Lan/Wan now.
I will post my steps later.. need to catch up on some sleep now.. but it was a good exercise and I am off DD-WRT now smile

Thanks !!!

hi, how did you flash for DD-WRT on that router ? . I have a WGR614v7, with AR531x/231x chipset and want to install DD_WRT/OpenWRT.

Any help is appreciated...

(Last edited by dexter20v on 4 May 2008, 23:01)

t depends on the router's boot loader etc...  am not sure how WGR614v7 works. But if u can get to the boot loader, then u can install opensource firmwares. On ar430w, its done by entering telnet to port 9000 within few seconds of startup.  The default ip is 192.168.1.1

ngupta wrote:

I picked up latest snapshot of kamikaze 7.09 as of 4/28/08, made changes to madwifi source and then re-compiled.

Sounds great. Now we're just waiting for info what was changed. :)

I just managed to get Redboot running on ZyXEL NBG-318S (AR2318, 4MB Flash, 16MB RAM, 4 ethernet ports and HomePlug AV integrated). Still plenty of problems left such as only AR2315 (AP51) Redboot working that doesn't support Admtek 6996 switch chip present on this board. I can already run OpenWrt, but ethernet and wireless are both down. Wireless fails with same error as AR430W does without your patches. Haven't had time to try using fresh OpenWrt build with 6996 support yet as it takes ages to upload images over 9600 bps serial.  Attempt to use anything faster fails and since Ethernet doesn't work while on Redboot can't load them over net either.

I am not sure how to attach my compiled binaries here... pls email me if anyone needs working openwrt kamikaze binaries for ar430w. THESE ARE FOR TEST ONLY... I am not responsible in anyway smile

Please submit your patches in a ticket via our dev tracker or email them to me.  I would be happy to post/host builds for testing.

Hi Gupta,
       Have the changes been integrated to the builds? I was wondering if I can checkout the latest snapshot and get my AR430w supported. Else can you email me the binaries?
        A basic question: I already have DD-WRT running on mine. Can you just upgrade to OpenWRT from the 'Administer' web page? or do you have to get to the bootloader and reflash there?

I'd be very interested in getting the binaries to run kamikaze on the Airlink101 AR430W, currently running DD-WRT and it still has stability issues.  So if you could post the binaries and instructions on how to install it, it would be greatly appreciated.

ngupta wrote:

OK... GOOD NEWS.

I have solved my own problem after a couple of days.
I picked up latest snapshot of kamikaze 7.09 as of 4/28/08, made changes to madwifi source and then re-compiled.
The new generated binaries worked on Airlink101 AR430W 802.11g router. I am able to use Wifi and Lan/Wan now.
I will post my steps later.. need to catch up on some sleep now.. but it was a good exercise and I am off DD-WRT now smile

Thanks !!!

Hi,

I try to install openwrt in a Airlink101 AR430W 802.11g router, may is possible to you post the steps that you use to flash it

Thanks

With the newest update of the atheros hal we should be able to support this board, but we don't have an actual device.  If I see one for under $30 I'll pick it up, otherwise we'll have to wait on the submission of a patch or donation of a device.

How can I get the newest update?  Is it available via ipkg?  The problem currently is that when you UP the wireless interface, the processor hangs.

By the way the local Fry's has the AR430W for $15.  It's AR2317 based.

-John

(Last edited by johnc60 on 18 Jun 2008, 09:00)

ok i got the latest trunk and built for the atheros

i have ar2317 (wbr1310 30$ moded with 4meg flash) and it built fine and programmed and ran.
i still have the pci hanging issue..  (resolved it by disabling pci on make kernel_menuconfig)

my co # is 11534.

thanks,

i got it to work mostly

here is the reference.

http://forum.openwrt.org/viewtopic.php?id=15492

(Last edited by yoonix on 25 Jun 2008, 00:20)

can you please let me know how to get rid of all the patches that's in the way when using current madwifi?  thanks

i've updated the readme page.
that should give you a good instruction on how to build kamikaze 7.09 with latest madwifi or latest kernel.

hi
  I just sucessfully load openwrt on this ar430w..
but I am still not seeing WIFI

I follow the instruction for building the latest kamakazi, from Yoonix' README..
after I log into openwrt, dmesg, I saw this at the end of dmesg

madwifi: unable to attatch hardware. No hardware present.....

so I went back to the kamakazi compiling system.

under kernel module --> wireless driver  --> kmod-madwifi

there is a selection for

Use the testing version of MadWiFi

should I be using this one or not?  thanks

to answer my own question, though havn't solve it yet..
I use the latest kamikaze with latest madwifi, but still no hardware detected,

I get
hal status 1

somewhere in the dmesg

weird never seen that message.

you MAY need to reflash your configuration (nvram) part of your flash but that might brick your device as well.

post your kernel boot message. thanks.

here is the dmesg

=======================
Linux version 2.6.23.17 (torus@kiosque) (gcc version 4.1.2) #2 Fri Jul 18 01:45
:38 CDT 2008
CPU revision is: 00019064
Determined physical RAM map:
memory: 01000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
On node 0 totalpages: 4096
  Normal zone: 32 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 4064 pages, LIFO batch:0
  Movable zone: 0 pages used for memmap
Built 1 zonelists in Zone order.  Total pages: 4064
Kernel command line: console=ttyS0,9600 rootfstype=squashfs,jffs2 init=/etc/pre
init
Primary instruction cache 16kB, physically tagged, 4-way, linesize 16 bytes.
Primary data cache 16kB, 4-way, linesize 16 bytes.
Synthesized TLB refill handler (20 instructions).
Synthesized TLB load handler fastpath (32 instructions).
Synthesized TLB store handler fastpath (32 instructions).
Synthesized TLB modify handler fastpath (31 instructions).
PID hash table entries: 64 (order: 6, 256 bytes)
Using 92.000 MHz high precision timer.
console [ttyS0] enabled
Dentry cache hash table entries: 2048 (order: 1, 8192 bytes)
Inode-cache hash table entries: 1024 (order: 0, 4096 bytes)
Memory: 13652k/16384k available (1818k kernel code, 2732k reserved, 281k data,
116k init, 0k highmem)
Calibrating delay loop... 183.50 BogoMIPS (lpj=917504)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
Radio config found at offset 0x1000(0x100)
Generic PHY: Registered new driver
Time: MIPS clocksource has been installed.
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 512 (order: 0, 4096 bytes)
TCP bind hash table entries: 512 (order: -1, 2048 bytes)
TCP: Hash tables configured (established 512 bind 512)
TCP reno registered
ar531x: Registering GPIODEV device
squashfs: version 3.0 (2006/03/15) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver $Revision: 1.90 $ 1 ports, IRQ sharing disabled
serial8250: ttyS0 at MMIO 0xb1100003 (irq = 37) is a 16550A
ICPlus IP175C: Registered new driver
Infineon ADM6996: Registered new driver
Marvell 88E6060: Registered new driver
eth0: Atheros AR231x: 00:1d:6a:cd:a2:d0, irq 4
ar2313_eth_mii: probed
eth0: attached PHY driver [ICPlus IP175C] (mii_bus:phy_addr=0:00)
cmdlinepart partition parsing not available
Searching for RedBoot partition table in spiflash at offset 0x3d0000
Searching for RedBoot partition table in spiflash at offset 0x3e0000
5 RedBoot partitions found on MTD device spiflash
Creating 5 MTD partitions on "spiflash":
0x00000000-0x00030000 : "RedBoot"
0x00030000-0x000e0000 : "vmlinux.bin.l7"
0x000e0000-0x003e0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=200000, len=1E0000
0x00200000-0x003e0000 : "rootfs_data"
0x003e0000-0x003ef000 : "FIS directory"
0x003ef000-0x003f0000 : "RedBoot config"
Registered led device: wlan
gpiodev: gpio device registered with major 254
gpiodev: gpio platform device registered with access mask FFFFFFFF
nf_conntrack version 0.5.0 (1024 buckets, 4096 max)
ip_tables: (C) 2000-2006 Netfilter Core Team
TCP vegas registered
NET: Registered protocol family 1
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly.
Freeing unused kernel memory: 116k freed
Please be patient, while OpenWrt loads ...
Algorithmics/MIPS FPU Emulator v1.5
mini_fo: using base directory: /
mini_fo: using storage directory: /tmp/root
device eth0 entered promiscuous mode
br-lan: port 1(eth0) entering learning state
br-lan: topology change detected, propagating
br-lan: port 1(eth0) entering forwarding state
PPP generic driver version 2.4.2
ath_hal: module license 'Proprietary' taints kernel.
AR5212, AR5312, RF5111, RF5112, RF2316, RF2317, TX_DESC_SWAP)
wlan: mac acl policy registered
ath_ahb: trunk
MadWifi: unable to attach hardware: 'No hardware present or device not yet supported' (HAL status 1)
jffs2_scan_eraseblock(): End of filesystem marker found at 0x0
jffs2_build_filesystem(): unlocking the mtd device... done.
jffs2_build_filesystem(): erasing all blocks after the end marker... done.
mini_fo: using base directory: /
mini_fo: using storage directory: /jffs
======================================

I flashed 3 identical units, intended for my WDS. and all are not seeing the wifi.

oh...forgot to mention..
I used both the madwifi r3314 and r3776
and both are not showing the wifi device.

Hmm..

I don't know... What's your wifichip? I don't know why it would not load up the hardware.. hmm.. The driver you are using looks like fairly new..

Hmm.. What's your chip set? 2313?

the chip I saw on this machine is a AR2318..

redboot is only a boot loader, right?
because I use the ap61 from dd-wrt

(Last edited by cycrap on 19 Jul 2008, 01:53)

I've made a new wiki page well updated my original wiki to reflect on redboot.
You were right some of the command I gave you were invalid.

Here is an example of me resizing one of the kernel block and reprogramming it

http://wiki.openwrt.org/yoonix

Try this thread this might resolve your problem

http://forum.openwrt.org/viewtopic.php?id=16427

With the broken configuration unit you should total make a JTAG it will be so much easier. You can probably buy one for 50-100$.

(Last edited by yoonix on 25 Jul 2008, 19:55)