OpenWrt Forum Archive

Topic: [Howto] Compile LuCI GUI and OpenWrt

The content of this topic has been archived between 20 Apr 2018 and 2 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

[Howto] Compile LuCI GUI and OpenWrt

$ cd ~/
$ svn checkout ~/trunk/
$ cd ~/trunk/
$ ./scripts/feeds update packages luci
$ ./scripts/feeds install -a -p luci
$ make menuconfig

In menuconfig change:

- Target System
- Subtarget
- Target Profile

- Base system
   - firewall
     - Choose firewall: new uci firewall

- Administration
   - LuCI Components
     - luci-admin-full: Y
     - luci-app-ddns: Y
     - luci-app-firewall: Y
     - luci-app-ntpc: Y
     - luci-app-qos: Y

$ make world
openwrt@ubuntu:~/trunk-atheros$ make world                  
++ mkdir -p /home/openwrt/trunk-atheros/staging_dir/toolchain-mips_gcc4.1.2
++ cd /home/openwrt/trunk-atheros/staging_dir/toolchain-mips_gcc4.1.2
++ mkdir -p bin lib include stamp
Checking 'bison'... ok.
 make[1] world
 make[2] target/compile
 make[3] -C target/linux compile
 make[2] package/cleanup
 make[2] package/compile
 make[3] -C package/base-files compile
 make[3] -C package/bridge-utils compile
 make[3] -C package/busybox compile
 make[3] -C package/dnsmasq compile
 make[3] -C package/dropbear compile
 make[3] -C package/e2fsprogs compile
 make[3] -C package/lua compile
 make[3] -C feeds/luci/bitlib compile
 make[3] -C feeds/luci/luaposix compile
 make[3] -C feeds/packages/libs/libnotimpl compile
 make[3] -C package/uci compile
 make[3] -C feeds/luci/luci-addons compile
 make[3] -C feeds/luci/luasocket compile
 make[3] -C feeds/packages/net/olsrd compile
 make[3] -C package/iproute2 compile
 make[3] -C package/iptables compile
 make[3] -C package/firewall compile
 make[3] -C package/qos-scripts compile
 make[3] -C package/libtool compile
 make[3] -C package/libpcap compile
 make[3] -C package/zlib compile
 make[3] -C feeds/packages/libs/rrdtool-1.0.x compile
 make[3] -C feeds/packages/utils/collectd compile
 make[3] -C feeds/packages/net/miniupnpd compile
 make[3] -C feeds/packages/net/ntpclient compile
 make[3] -C feeds/packages/net/ddns-scripts compile
 make[3] -C feeds/luci/luci compile
 make[3] -C package/ncurses compile
 make[3] -C feeds/packages/utils/nano compile
 make[3] -C package/openssl compile
 make[3] -C package/wireless-tools compile
 make[3] -C package/madwifi compile
 make[3] -C package/mac80211 compile
 make[3] -C package/libnl compile
 make[3] -C package/hostapd compile
 make[3] -C package/hotplug2 compile
 make[3] -C package/kernel compile
 make[3] -C package/mmc_over_gpio compile
 make[3] -C package/mtd compile
 make[3] -C package/linux-atm compile
 make[3] -C package/ppp compile
 make[3] -C package/udev compile
 make[3] -C package/util-linux-ng compile
 make[2] package/install
 make[3] -C package/base-files install
 make[3] -C package/bridge-utils install
 make[3] -C package/busybox install
 make[3] -C package/dnsmasq install
 make[3] -C package/dropbear install
 make[3] -C package/e2fsprogs install
 make[3] -C feeds/luci/bitlib install
 make[3] -C feeds/luci/luaposix install
 make[3] -C feeds/luci/luci install
 make[3] -C feeds/luci/luci-addons install
 make[3] -C feeds/packages/net/ddns-scripts install
 make[3] -C feeds/packages/utils/nano install
 make[3] -C feeds/packages/net/ntpclient install
 make[3] -C package/firewall install
 make[3] -C package/hostapd install
 make[3] -C package/hotplug2 install
 make[3] -C package/iproute2 install
 make[3] -C package/iptables install
 make[3] -C package/kernel install
 make[3] -C package/lua install
 make[3] -C package/madwifi install
 make[3] -C package/mmc_over_gpio install
 make[3] -C package/mtd install
 make[3] -C package/ncurses install
 make[3] -C package/openssl install
 make[3] -C package/ppp install
 make[3] -C package/qos-scripts install
 make[3] -C package/uci install
 make[3] -C package/udev install
 make[3] -C package/util-linux-ng install
 make[3] -C package/wireless-tools install
 make[3] -C package/zlib install
 make[2] package/rootfs-prepare
 make[3] package/preconfig
 make[2] target/install
 make[3] -C target/linux install
 make[2] package/index
Installed packages (80):
openwrt@ubuntu:~/trunk-atheros$ ll -h bin/
total 14M
-rw-r--r-- 1 openwrt openwrt 2.5M 2008-08-11 12:07 openwrt-atheros-root.squashfs
-rw-r--r-- 1 openwrt openwrt 3.3M 2008-08-11 12:07 openwrt-atheros-ubnt2-squashfs.bin
-rw-r--r-- 1 openwrt openwrt 3.3M 2008-08-11 12:07 openwrt-atheros-ubnt5-squashfs.bin
-rwxr-xr-x 1 openwrt openwrt 2.3M 2008-08-11 12:07 openwrt-atheros-vmlinux.elf
-rw-r--r-- 1 openwrt openwrt 1.0M 2008-08-11 12:07 openwrt-atheros-vmlinux.gz
-rw-r--r-- 1 openwrt openwrt 768K 2008-08-11 12:07 openwrt-atheros-vmlinux.lzma
drwxr-xr-x 3 openwrt openwrt 4.0K 2008-08-09 20:07 packages
openwrt@ubuntu:~/trunk-atheros$ ll -h bin/packages/mips/
total 3.3M
-rw-r--r-- 1 openwrt openwrt  26K 2008-08-09 20:14 base-files-atheros_13-r12259_mips.ipk
-rw-r--r-- 1 openwrt openwrt 2.5K 2008-08-11 11:33 bitlib_25-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 9.1K 2008-08-09 20:07 bridge_1.0.6-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 307K 2008-08-11 12:04 busybox_1.8.2-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  28K 2008-08-11 12:04 cfdisk_2.13.0.1-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 7.7K 2008-08-11 11:40 ddns-scripts_1.0.0-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  72K 2008-08-09 20:09 dnsmasq_2.45-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 100K 2008-08-09 20:11 dropbear_0.51-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 167K 2008-08-11 12:04 e2fsprogs_1.40.11-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 3.2K 2008-08-09 20:11 firewall_1-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 146K 2008-08-11 12:05 hostapd_0.6.3-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  12K 2008-08-09 20:11 hotplug2_0.9+r102-2_mips.ipk
-rw-r--r-- 1 openwrt openwrt  43K 2008-08-11 11:42 iptables_1.4.0-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  12K 2008-08-11 11:42 iptables-mod-conntrack_1.4.0-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 8.6K 2008-08-11 11:42 iptables-mod-extra_1.4.0-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  18K 2008-08-11 11:42 iptables-mod-filter_1.4.0-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  725 2008-08-11 11:42 iptables-mod-imq_1.4.0-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  20K 2008-08-11 11:42 iptables-mod-ipopt_1.4.0-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 3.1K 2008-08-11 11:42 iptables-mod-ulog_1.4.0-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  633 2008-08-11 12:05 kernel_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 1.9K 2008-08-11 12:06 kmod-crc7_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 2.3K 2008-08-11 12:06 kmod-crc-itu-t_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  91K 2008-08-11 12:05 kmod-fs-ext3_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  12K 2008-08-11 12:05 kmod-ipt-conntrack_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  15K 2008-08-11 12:05 kmod-ipt-extra_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  15K 2008-08-11 12:05 kmod-ipt-filter_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  13K 2008-08-11 12:05 kmod-ipt-ipopt_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  12K 2008-08-11 12:05 kmod-ipt-nathelper_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 4.6K 2008-08-11 12:05 kmod-ipt-ulog_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 298K 2008-08-09 20:15 kmod-madwifi_2.6.26.2+r3314-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  29K 2008-08-11 12:06 kmod-mmc_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 7.1K 2008-08-11 12:06 kmod-mmc-spi_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 3.7K 2008-08-11 12:05 kmod-nls-base_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 2.7K 2008-08-11 12:05 kmod-nls-iso8859-15_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 1.9K 2008-08-11 12:05 kmod-nls-utf8_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  26K 2008-08-11 12:05 kmod-ppp_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 8.3K 2008-08-11 12:06 kmod-pppoe_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  95K 2008-08-11 12:06 kmod-sched_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 3.5K 2008-08-11 12:06 kmod-spi-bitbang_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 3.7K 2008-08-11 12:06 kmod-spi-gpio_2.6.26.2-atheros-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  17K 2008-08-11 12:04 libblkid_1.40.11-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  25K 2008-08-09 20:14 libgcc_4.1.2-13_mips.ipk
-rw-r--r-- 1 openwrt openwrt  66K 2008-08-11 11:43 liblua_5.1.3-2_mips.ipk
-rw-r--r-- 1 openwrt openwrt 136K 2008-08-11 11:58 libncurses_5.6-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 478K 2008-08-11 12:01 libopenssl_0.9.8h-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  13K 2008-08-11 11:43 libuci_0.4.8-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 4.8K 2008-08-11 11:43 libuci-lua_0.4.8-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 7.3K 2008-08-11 12:04 libuuid_1.40.11-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 5.3K 2008-08-11 11:43 lua_5.1.3-2_mips.ipk
-rw-r--r-- 1 openwrt openwrt  12K 2008-08-11 11:34 luaposix_5.1.3-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 2.5K 2008-08-11 11:35 luci-addons_0.2-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 2.5K 2008-08-11 12:04 luci-admin-core_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  13K 2008-08-11 12:04 luci-admin-full_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 7.7K 2008-08-11 12:04 luci-admin-mini_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 2.4K 2008-08-11 12:04 luci-app-ddns_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 4.2K 2008-08-11 12:04 luci-app-firewall_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 1.8K 2008-08-11 12:04 luci-app-ntpc_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 2.5K 2008-08-11 12:04 luci-app-qos_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 9.6K 2008-08-11 12:04 luci-cbi_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  16K 2008-08-11 12:04 luci-core_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  10K 2008-08-11 12:04 luci-http_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 7.3K 2008-08-11 12:05 luci-i18n-english_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 2.1K 2008-08-11 12:04 luci-ipkg_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 2.1K 2008-08-11 12:04 luci-sgi-cgi_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 6.6K 2008-08-11 12:04 luci-sys_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  70K 2008-08-11 12:04 luci-theme-openwrt_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 2.5K 2008-08-11 12:04 luci-uci_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 9.6K 2008-08-11 12:04 luci-web_0.7+svn2777-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 8.1K 2008-08-09 20:13 mtd_7_mips.ipk
-rw-r--r-- 1 openwrt openwrt  32K 2008-08-11 11:59 nano_2.0.7-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  12K 2008-08-11 11:40 ntpclient_2007_365-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  32K 2008-08-11 12:07 Packages
-rw-r--r-- 1 openwrt openwrt 6.6K 2008-08-11 12:07 Packages.gz
-rw-r--r-- 1 openwrt openwrt 109K 2008-08-09 20:15 ppp_2.4.3-10_mips.ipk
-rw-r--r-- 1 openwrt openwrt  11K 2008-08-09 20:15 ppp-mod-pppoe_2.4.3-10_mips.ipk
-rw-r--r-- 1 openwrt openwrt 6.3K 2008-08-11 11:36 qos-scripts_1.2.1-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  87K 2008-08-11 11:35 tc_2.6.25-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 6.1K 2008-08-11 11:43 uci_0.4.8-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt 201K 2008-08-09 20:14 uclibc_0.9.29-13_mips.ipk
-rw-r--r-- 1 openwrt openwrt 9.7K 2008-08-09 20:14 udevtrigger_106-1_mips.ipk
-rw-r--r-- 1 openwrt openwrt  32K 2008-08-09 20:12 wireless-tools_29-2_mips.ipk
-rw-r--r-- 1 openwrt openwrt  36K 2008-08-11 12:06 zlib_1.2.3-5_mips.ipk

LuCI website:

@LuIC developers: it would be nice to have a OpenWrt theme without the OpenWrt logo and background image smile

(Last edited by Yanira on 23 Sep 2008, 15:45)

Should webif be disabled?

LuCI has nothing to do with X-Wrt webif. That's why you only checkout the packages and luci feeds with the feeds script (./scripts/feeds update packages luci).

(Last edited by Yanira on 11 Aug 2008, 12:44)

hello... I just tried building this into the latest trunk, and I get the following error:

mipsel-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -DPREFIX=\"/usr\" -DCONFIGFILE=\"/etc/collectd.conf\" -DLOCALSTATEDIR=\"/var\" -DPKGLOCALSTATEDIR=\"/var/lib/collectd\" -DPIDFILE=\"/var/run/\" -DPLUGINDIR=\"/usr/lib/collectd\" -I/home/sloth/Dev/src/OpenWrt/trunk/staging_dir/mipsel/usr/include/libxml2 -I/home/sloth/Dev/src/OpenWrt/trunk/staging_dir/mipsel/usr/include -I/home/sloth/Dev/src/OpenWrt/trunk/staging_dir/mipsel/include -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -fhonour-copts -MT apache_la-apache.lo -MD -MP -MF .deps/apache_la-apache.Tpo -c apache.c  -fPIC -DPIC -o .libs/apache_la-apache.o
apache.c:30:23: curl/curl.h: No such file or directory
apache.c:39: error: syntax error before '*' token
apache.c:39: warning: data definition has no type or storage class
apache.c:44: error: `CURL_ERROR_SIZE' undeclared here (not in a function)
apache.c: In function `init':
apache.c:135: warning: assignment makes pointer from integer without a cast
apache.c:141: error: `CURLOPT_WRITEFUNCTION' undeclared (first use in this function)
apache.c:141: error: (Each undeclared identifier is reported only once
apache.c:141: error: for each function it appears in.)
apache.c:142: error: `CURLOPT_USERAGENT' undeclared (first use in this function)
apache.c:143: error: `CURLOPT_ERRORBUFFER' undeclared (first use in this function)
apache.c:160: error: `CURLOPT_USERPWD' undeclared (first use in this function)
apache.c:163: error: `CURLOPT_URL' undeclared (first use in this function)
apache.c:167: error: `CURLOPT_SSL_VERIFYPEER' undeclared (first use in this function)
apache.c:176: error: `CURLOPT_SSL_VERIFYHOST' undeclared (first use in this function)
apache.c:185: error: `CURLOPT_CAINFO' undeclared (first use in this function)
apache.c: At top level:
apache.c:44: error: storage size of `apache_curl_error' isn't known
make[7]: *** [apache_la-apache.lo] Error 1
make[7]: Leaving directory `/home/sloth/Dev/src/OpenWrt/trunk/build_dir/mipsel/collectd-4.4.3/src'
make[6]: *** [all-recursive] Error 1
make[6]: Leaving directory `/home/sloth/Dev/src/OpenWrt/trunk/build_dir/mipsel/collectd-4.4.3/src'
make[5]: *** [all] Error 2
make[5]: Leaving directory `/home/sloth/Dev/src/OpenWrt/trunk/build_dir/mipsel/collectd-4.4.3/src'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/home/sloth/Dev/src/OpenWrt/trunk/build_dir/mipsel/collectd-4.4.3'
make[3]: *** [/home/sloth/Dev/src/OpenWrt/trunk/build_dir/mipsel/collectd-4.4.3/.built] Error 2
make[3]: Leaving directory `/home/sloth/Dev/src/OpenWrt/trunk/feeds/packages/utils/collectd'
make[2]: *** [package/feeds/packages/collectd/compile] Error 2
make[2]: Leaving directory `/home/sloth/Dev/src/OpenWrt/trunk'
make[1]: *** [/home/sloth/Dev/src/OpenWrt/trunk/staging_dir/mipsel/stamp/.package_compile] Error 2
make[1]: Leaving directory `/home/sloth/Dev/src/OpenWrt/trunk'
make: *** [world] Error 2

any idea what's going on?

looks like the problem was with the luci-app-statistics module - disabled that and things now build...

I just built trunk for an alix board I'm picking up. Yanira you state to build the luci stuff in "y", but the instructions I followed from

the wiki say to build them as modules?


M makes no sense here as they won't get included in the image then

So then everything listed as a Module should be changed?

Changes in menuconfig:
 # Network
hostapd: M
wpa-supplicant: M 
 # Kernel modules
 * Filesystems
kmod-fs-ext3: M
 * Network Devices
kmod-natsemi: N
kmod-ne2k-pci: N 
 # USB Support
kmod-usb-core: M
kmod-usb-ohci: M
kmod-usb-storage: M
kmod-usb-uhci: M
kmod-usb2: M 
 * Wireless Drivers
kmod-madwifi: M 
 # Administration
 * LuCI Components
luci-admin-full: M
luci-app-ddns: M
luci-app-firewall: M
luci-app-ntpc: M
luci-app-qos: M
luci-app-samba: M 
 * LuCI Themes
luci-theme-openwrtlight: M 
 # Utilities
 * disc
cfdisk: M
swap-utils: M 
e2fsprogs: M

Only what you need.
If you don't want samba, don't install it.
You don't need swap? Don't install swap-utils.
You have a Realtek network card on your router? You don't need ne2k or natsemi.
And so on...

(Last edited by CyrusFF on 9 Oct 2008, 12:10)

Thanks for your guide Yanira

I have compiled successfully the 8.09_RC1 + luci 0.8.1
But now i want to compile the LuCI trunk
How can i do this?


cp feeds.conf.default feeds.conf

edit feeds.conf, change luci url to:

src-svn luci

then do:

rm -rf feeds/luci*
./scripts/feeds update luci

~ JoW

Done... and compiling big_smile

Thank you jow

I'd use my own ~/trunk/feeds.conf. If feeds.conf exists it overwrites feeds.conf.default

Thanks for the guide, it is working quite well for me.

This is my interpretation of the instructions from Yanari and Jow.  It compiles ok but is it in the correct order?

cd ~/
svn checkout ~/trunk/
cd ~/trunk/
cp feeds.conf.default feeds.conf

edit feeds.conf, change luci url to:

src-svn luci
rm -rf feeds/luci*
./scripts/feeds update luci
./scripts/feeds update packages luci
./scripts/feeds install -a -p luci
make menuconfig

@Yanira: I cannot choose a firewall.  I get only Openwrt Firewall

- Base system
   - firewall
     - Choose firewall: new uci firewall

 OpenWrt Kamikaze (r13204) Configuration
  ┌────────────────────────────────────── Base system ──────────────────────────────────────� 
  │  Arrow keys navigate the menu.  <Enter> selects submenus --->.  Highlighted letters are │
  │  hotkeys.  Pressing <Y> includes, <N> excludes, <M> builds as package.  Press           │
  │  <Esc><Esc> to exit, <?> for Help, </> for Search.  Legend: [*] built-in  [ ] excluded  │
  │  <M> package  < > package capable                                                       │
  │ ┌─────────────────────────────────────────────────────────────────────────────────────�  │
  │ │ <*> base-files................................... Base filesystem for OpenWrt (NEW) │ │
  │ │ < > br2684ctl.................... ATM Ethernet bridging configuration utility (NEW) │ │
  │ │ < > bridge........................... Ethernet bridging configuration utility (NEW) │ │
  │ │ <*> busybox................................ Core utilities for embedded Linux (NEW) │ │
  │ │ <*> dnsmasq................................ A lightweight DNS and DHCP server (NEW) │ │
  │ │ <*> dropbear........................................ Small SSH2 client/server (NEW) │ │
  │ │ <*> firewall................................................ OpenWrt firewall (NEW) │ │
  │ │ <*> hotplug2........ Dynamic device management subsystem for embedded systems (NEW) │ │
  │ │ <*> iptables............................... IPv4 firewall administration tool (NEW) │ │
  │ │ < > ldconfig............................... Shared library path configuration (NEW) │ │
  │ │ < > ldd.................................................... LDD trace utility (NEW) │ │
  │ │ <*> libgcc............................................... GCC support library (NEW) │ │
  │ │ < > libpthread.......................................... POSIX thread library (NEW) │ │
  │ │ < > libstdcpp.................................... GNU Standard C++ Library v3 (NEW) │ │
  │ │ <*> mtd............................... Update utility for trx firmware images (NEW) │ │
  │ │ <*> opkg...................................... opkg package management system (NEW) │ │
  │ │ < > qos-scripts.................................................. QoS scripts (NEW) │ │
  │ │ <*> uci................ Utility for the Unified Configuration Interface (UCI) (NEW) │ │
  │ │ <*> uclibc........................................ C library embedded systems (NEW) │ │
  │ │ <*> udevtrigger.. Small utility to request kernel devices events for coldplug (NEW) │ │
  │ │ --- wireless-tools.......... Tools for manipulating Linux Wireless Extensions       │ │

Hi yanira and all,
                      Thanks for the information u have given. I have a problem thought like u will solve.
I am using kamikaze7.09 version.Does it supports the web interface Luci, if so then which is the version necessary for it. Also is there any Makefile for the luci on openwrt.
                      Also i downloaded the current 8.01 release of kamikaze. As posted by you above i tried to update the luci package by
./scripts/feeds update packages luci
but it is not getting connected ....the error is

svn: PROPFIND request failed on '/openwrt/branches/packages_8.09'
svn: PROPFIND of '/openwrt/branches/packages_8.09': could not connect to server (

Hello Yanira,

Thanks for your guide. I was able to build my first OpenWrt image flawlessly at very first try.
Could you please advise now how to remove both Luci and Uci smile and compile an image with good old /etc/* text config files instead of Windows registry-like Uci setup?
I feel it must be quite easy but I only start to understand building process.

Removing LuCI is easy, just don't select it in the first place. Getting rid of uci is harder, either learn to live with it or rewrite the init scripts to suit your needs. You can override any file by creating a files/ folder within the buildroot and put custom files there (for example files/etc/init.d/dnsmasq).

The developers put pretty much thought into the init scripts and uci integration, it's hard to just replace that. You have to redo the firewall, hotplug handling, wireless configuration, network config and switch setup. Many packages won't be compatible anymore etc. Good luck with that.

~ JoW

(Last edited by jow on 19 Jan 2009, 18:18)

Jow, thank you for your reply. I think I have to live with uci till I gain more experience with building images.

Seems there isnt carl9170- file hosted anymore at as shown here: , seems its now old packages.. replaced by 0.9.7 or 0.9.8..
But it still exist in "old" direcotry in this url … /carl9170/ so the download script should be changed to look at correct url for carl9170.

Edit: Thnx to Bartman007 the file is now hosted on mirrors.

(Last edited by crow on 21 Jan 2010, 09:42)

I have just successfully built OpenWRT backfire 10.03 with Luci following the post at the top if this topic.

So far so good. Luci is version 0.9.0

Here is my question:

- Which files do I edit to modify the GUI?

I want to edit network.lua but it seems in V0.9.0 - the files are 'compiled' binaries. I assume they are built from some source files but don't know which ones.

Any help appreciated.


it seems that nobody has working kexec-tools for mips. I have browsed the web and found no positive results. I won't try to port the kexec-tools to mips on my own, but if somebody can point me to a patchset, that is claimed to actually work, then i'll happily apply it.

For Attitude Adjustment, it appears that the menuconfig option that needs to be set is

LuCI > 1. Collections > <M> luci

(or <*> to compile into ROM image)

It doesn't make sense to me to have an option M in Menuconfig. If =M doesn't store the module in the flash, what's the point?  The compiled package isn't going to go anywhere useful to the router, and you're likely then to download, install and configure the module(s) from the internet via the OPKG utility anyway.  OK, I suppose you could be sourcing the packages locally, in which you would need them compiled, but I am sure not many of us are doing that.

Based on my exploration into the Westell 7500 sourcecode, =y meant module was bound within the kernel Built-in, =M meant it was not bound within the kernel built-in but rather an external module stored in the filesystem on the flash, making it available to be loaded manually or by script.
By the way I suspect this is why the resulting compile of the Westell sourcecode caused the system to watchdog reset every 60 seconds: the config option flag was misspelled in the Make for Watchdog, causing it to default to =y when it was supposed to be compiled as an external module).

Hi All,

I am trying to compile Luci in my OpenWRT distibution [Attitude Adjustment ]. However, I am stuck at the very first step of it.

I have used following command,
$ ./scripts/feeds update packages luci

and I am getting following error message,
$ ./scripts/feeds update packages luci
Updating feed 'packages' from 'svn://' ...
Updating '.':
At revision 42306.
Create index file './feeds/packages.index'
Updating feed 'luci' from ' … ib/package' ...
Updating '.':
svn: E175002: Server sent unexpected return value (400 Bad Request) in response to REPORT request for '/!svn/vcc/default'

Am I doing any mistake? Could anyone help me in this respect.

Thanks in advance.