OpenWrt Forum Archive

Topic: Linksys WRT610N

The content of this topic has been archived between 6 Feb 2018 and 1 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Hi all,

Sorry for kicking this topic, but does the posts above mean that you can use VLAN functionality on the WRT610n v2 or am I missing some information?

They got it working on DD-WRT so I assume it could work on openWRT as well. Only thing to keep in mind is that LUCI may be configuring the wrong CPU port (5 instead of 8) which could make your device inaccessible. Therefore, use only the command line.

Am I right?


I'm new to OpenWRT.  I've installed the OpenWRT Firmware on my WRT610n - connected it to my modem and got it on the internet - and then installed luci.  How do I add support for USB?  Is that possible?


Sure you can.
You can install extra packages like kmod-usb-core, kmod-usb2 as well as libusb-1.0 and usbutils just to start...
If you have LuCI working, go to System-->Software, do an "update lists" and then search/istall the packages I mentioned.
Maybe you'll need more, but that depends upon your goals.

(Last edited by uqbar on 19 Jan 2015, 18:24)

Thanks for the reply!

I go to LuCI, software, and search for the packages you mentioned.  However, when I click install it gives me the following error:

Collected errors:
* opkg_install_pkg: Package kmod-usb-core md5sum mismatch. Either the opkg or the package index are corrupt. Try 'opkg update'.
* opkg_install_cmd: Cannot install package kmod-usb-core

I also tried logging in to puddy and installing the packages from the command prompt I receive this error:

root@OpenWrt:~# opkg install kmod-usb-core
Installing kmod-usb-core (3.14.28-1) to root...
Downloading … m47xx.ipk.
Collected errors:
* satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-core:
*      kernel (= 3.14.28-1-d41b744ae1bf5870f6a135340a585fda) *         kernel (= 3.14.28-1-d41b744ae1bf5870f6a135340a585fda) *
* opkg_install_cmd: Cannot install package kmod-usb-core.

FYI:  I used the firmware from this link when I installed - ' … uashfs.bin'


(Last edited by natebloss on 19 Jan 2015, 19:35)

Have you clicked on "update lists"?
From command line (putty) you need to run "opkg update".
Either command before installing any package.

(Last edited by uqbar on 19 Jan 2015, 21:07)

I did do the 'opkg update' before trying to install the package (I forgot to include that in my last post).  Also, I don't see 'update list' in the LuCI interface.  When I click on software I have an 'Actions' and 'Configuration' tab.  And I have 2 text boxes where I can enter text and search for packages.  The first text box is titled 'Download and Install Pacage' the other is titled ' Filter'.  Previously I tried using these text boxes to search and install the package, and it led to the errors mentioned in my previous post.  Is it possible I have a different version of LuCI?  Regardless, I'm also getting the error in the command prompt. 

Under 'System' there is an entry that list my 'Firmware Version'; it says 'OpenWrt Chaos Calmer r43977 / LuCI (git-15.017.51462-30d45d0)' 

Thanks for the help, I really appreciate it!


That is not a WRT610N specific problem, you just fell into the trap of installing a trunk snapshot one day - and then trying to install further kernel modules several days later (which were built against a different/ newer trunk snapshot).

Trunk snapshots are rebuilt roughly daily, but kernel modules (and their corresponding module packages) need to match exactly to the kernel they've been built against. In practice this means you can only install (module-)packages built in the same build run as the firmware you installed, so basically from the same day as the trunk snapshot you downloaded and flashed. This means you either need to install all potentially needed packages right away after flashing your trunk snapshot or mirror all packages corresponding to the firmware you're going to flash (and then feed those to opkg instead of the fresh ones on

Unless you have special reasons to use a trunk snapshot, it's probably easier for you to just flash an official release firmware - whose /etc/opkg.conf points to a (mostly-) frozen package tree corresponding to the release firmware you installed, so you can 'always' install matching packages later on.

(Last edited by slh on 19 Jan 2015, 23:21)

Ok - I think that clears things up, and I understand the problem.  I'm a little foggy on the solution though.  I think the best thing for me to do is reflash my router with an official release.  However, I was under the impression that the WRT610n was not officially supported, so it was risky to install an official release on it (as in the official release had not been tested and the snapshot was a custom OpenWRT version built for the WRT610n)?  Is that not the case? 

So if I need an official release, what is the best release for me to download / what bin file do I download?  And then after I have downloaded and installed this, in theory I should be able to install packages whenever I want and not just the same day I flash it?

Thanks for putting up with my beginner questions!  You're helping me understand this a lot.


I installed OpenWRT today. But I only get 4 pings at boot. Telnet and SSH are not working. Tried every resetting method I could find on the internet. So pretty much stuck right now.

Same as me.

Came from dd-wrt...flashed with "trunk snapshot openwrt-wrt610n_v1-squashfs.bin" (flash seemed to work fine) and now I hace a nice brick.

It seems to boot...I can Ping with TTL=64 (some webs says that it means that the fw is working) but I dont hace access to any webGUI so cant do anything with it.

Tried 100s times several recovery methods posted everywhere (mostly dd-wrt forum) with no result at all, the only thing not tried yet is to flash via Serial....

Any other issue?

If you installed a trunk snapshot (rather than a release build), the webinterface isn't preinstalled and you can only connected via ssh (root, no password).

Is it possible to reference the 4 Wrt610n's 4 LAN ports independently?  I would like to assign each to a different VLAN.  UCI requires the physical interface name when creating logical interfaces for VLANs.  However, ifconfig returns only two physical interface names: eth0.1 for the 4 LAN ports and eth0.2 for the WAN port.

I'm new to OpenWrt and Linux in general.  I wonder if the ability to reference each LAN port depends more on the driver that for the switch chipset? Or maybe even on the hardware itself? 

Can someone please confirm for me that it is not possible to create an eth0.2 physical interface name refering to LAN port 2?

(Last edited by sdf23489 on 28 Jan 2017, 05:28)

You need to configure the switch to have more VLANS and connect each to a separate port. Then you add the corresponding eth0.x interfaces.

mk24 wrote:

You need to configure the switch to have more VLANS and connect each to a separate port. Then you add the corresponding eth0.x interfaces.

Thanks.  I understand now.  First you create vlan 3 using a config switch_vlan block.  Specify the physical port numbers in that same block.  Then go up earlier in the file and add an interface for that vlan 3 in a config interface block.  The ifname will be eth0.x, where x is the vid of the vlan just created.  This adds a new eth0.3 interface in the ifconfig output.

I was confused because I was thinking the eth0.3 would be created elsewhere.  Didn't realize the .x was the vlan vid.

(Last edited by sdf23489 on 30 Jan 2017, 00:09)

I must say I'm pretty impressed with OpenWrt.  My WRT610N has been configured with 4 VLANs: management, main LAN, renter LAN, and an IoT LAN. The devices on each VLAN cannot talk to other VLANs unless forwarding rules have been added to do so.  I'm definitely a fan of the UCI configuration concept.  I love the fact that I'll be able to transfer my config files to new hardware with minimal modification.

Question: This website's WRT610N device page lists Backfire 10.03.1 as the latest stable build for hardware revision 1.  However, each stable release since then has had a WRT610N binary.  Is there a reason why there's no link to the current stable Chaos Calmer build?  There's a link to the 2011 Backfire build and the current trunk build.  Is there something on this router that doesn't work quite right with the Chaos Calmer build?  Or is it just that this router is too old for anyone to care about updating the page?

Support for WRT610N v1 was broken for a while, due to changes in the switch driver, but that has been solved (trunk definitely, but I think it may have already been fixed in time for CC).

I only installed trunk because it seemed like the better option of the two builds linked on the device page. I figured trunk would be safer than a build from 2011.  Being new to the site I just assume that the device page's stable recommendation was current.

A mid-January build of trunk ran pretty solid for at least a week. I'm not using the wireless, so I can't vouch for the radios.  However, the switch seems to be working fine with my non-standard VLAN and routing setup. Last night I installed Chaos Calmer 15.05.1 and it seems to be running just as well.  Unless the the issues were sporadic or limited to certain features, it seems the fixes were indeed implemented in time for 15.05.1.

(Last edited by sdf23489 on 15 Feb 2017, 00:42)

I was using DD-WRT on my WRT610Nv2 for years. I updated to LEDE to have the newest version, but I have now a limitation that seems to come from OpenWRT: no 5G & 802.11n support :-(
Sound weird for something who was working nearly 10 years ago... Any affordable way to fix it?

HI JR3977.

You can _try_ to uninstall the opensource wireless (b43) driver, and install the Broadcom Driver to get 5Ghz Wifi working. I succeeded in doing this with one of my 610Ns, but the other would not work (and was therefore only working as 2.4 Ghz).

You may want to look at this (although it isn't a step by step)

The discussion might have continued from here.