OpenWrt Forum Archive

Topic: ipkg update gives wget: bad address

The content of this topic has been archived on 14 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi,

I am new to this game so sorry if it is a common mistake, but I could not yet find the right answer.

I tried to update and got this message :
   

root@OpenWrt:~# ipkg update
Downloading http://downloads.openwrt.org/kamikaze/7.09/ixp4xx-2.6/packages/Packages
wget: bad address 'downloads.openwrt.org'
Downloading http://downloads.openwrt.org/kamikaze/packages/armeb/Packages
wget: bad address 'downloads.openwrt.org'
Downloading http://downloads.x-wrt.org/xwrt/kamikaze/7.09/ixp4xx-2.6/packages/Packages
wget: bad address 'downloads.x-wrt.org'
An error ocurred, return value: 3.
Collected errors:
ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp    -q -P /tmp/ipkg-bX9XRD http://downloads.openwrt.org/kamikaze/7.09/ixp4xx-2.6/packages/Packages'
ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp    -q -P /tmp/ipkg-bX9XRD http://downloads.openwrt.org/kamikaze/packages/armeb/Packages'
ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp    -q -P /tmp/ipkg-bX9XRD http://downloads.x-wrt.org/xwrt/kamikaze/7.09/ixp4xx-2.6/packages/Packages'

I am using kamikaze 7.09 on a NSLU2

thanks in advance

Philippe

(Last edited by amazilia on 13 Sep 2008, 00:27)

It seems your internet connection is not working.

You can try to run udhcpc or otherwise manually configure your internet settings and retry.

bifferos wrote:

It seems your internet connection is not working.

You can try to run udhcpc or otherwise manually configure your internet settings and retry.

Hi,

my connection is working fine. I can dowload the files from the repository to my PC and make a local installation. what I cannot do is to get to the repository from the NAS neither for install nor for update.

Thanks

Philippe

bad address ? DNS is working (on NAS) ?

ciao gerd

I also have this same message, "wget: bad address 'downloads.openwrt.org'" when I "ipkg update" or "ipkg install something"--also running 7.09 on a NSLU2.  This happens either from the command line or from webif.  I can successfully ping the outside world, e.g., google at 209.85.135.103.  Any pointers as to what to look for?

this is typical if the dns server entry is not an IP address (or not a valid IP address) >on the router<.

Connected machines use their own DNS server entry, but the router still needs an IP address for dns searches. "downloads.openwrt.org" is a name that the router cannot resolve to an IP address without an IP entry for the DNS server to ask as well as a route to the internet _from the router_, not from the connected machines.

Remember, when doing [io]pkg updates _on the router_, the router is now acting as another machine on the internet and requires the same information as the other machines in order to get to the internet for itself.

Well, after a reboot, it works--ipkg update and ipkg install htpdate.  So a mystery why it failed before.  The NSLU2 is not a router--tho your note still applies; if it was a DNS problem, I think it was of the glitchy variety.

Back with the same problem a month later--different NSLU2, different version of Kamikazi--8.09.  I built the latest version (for the first time)--r13988.  When I try "opkg update", I get the following:
# opkg update
Downloading http://downloads.openwrt.org/snapshots/ … ackages.gz
wget: bad address 'downloads.openwrt.org'
Collected errors:
* opkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp    -P /tmp/opkg-jMUAqP http://downloads.openwrt.org/snapshots/ixp4xx/packages/Packages.gz'

I modified /etc/config/network to include the DNS ip which works on my other NSLU2 under Kamikazi 7.09, and to add additional DNS ips suggested on the web, e.g., 4.2.2.1, 4.2.2.2, etc.

I can successfully ping 209.85.135.103, which is google, but fail when trying to ping www.google.com ("ping: bad address 'www.google.com'").

So it definitely looks like a DNS problem, but how do I address it?

/etc/config/network looks like this:

config interface loopback
        option ifname   lo
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0

config interface lan
        option ifname   eth0
        option type     bridge
        option proto    static
        option ipaddr   192.168.1.77
        option netmask  255.255.255.0
        option gateway  192.168.1.88
        option dns      4.2.2.1
        option dns      4.2.2.2
        option dns      4.2.2.3
        option dns      4.2.2.4
        option dns      192.168.1.88
        option hostname nslu2b

config interface homenet
        option proto    static
        option dns      192.168.1.88
        option gateway  192.168.1.88

OK, I removed dnsmasq from /etc/init.d, since my NSLU2 is behind a router which is a DNS server, and now "ping www.google.com" works and "opkg update" works.  I can't say that I understand why dnsmasq was preventing this access, but if others have the same problem and can remove it, that may be the cure.

Well same problem here,but;

I've seen that on the Webpage of NSLU2 on the right TAB : Network -> Interfaces -> LAN

Click on the <entry> Additonal Field on the bottum left of the page,
Select for DNS-Server and choose your ROUTER-IP adress.
This resolves the DNS!


P.S.
I work with OpenWrt just fore a few moments because the IP adres it usess after flashing the FW (of OpenWrt) was the same of the Router!
This cost me some time to resolve this and the Status LED was turned off!
I blew one NSLU2 because of the AllErease FW util from the maker himself!
So I'll used this Utility NEVER again.

I've got a dimilar problem:
I'm running an Nslu2 with Kamikaze 7.09 and Kernel 2.6.21.6

I can update ipkg-opt:

root@OpenWrt:~# ipkg-opt update
Downloading http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/Packages
Updated list of available packages in /opt/lib/ipkg/lists/nslu2
Downloading http://ipkg.nslu2-linux.org/feeds/optware/openwrt-ixp4xx/cross/unstable/Packages
Updated list of available packages in /opt/lib/ipkg/lists/optware
Successfully terminated.

But updating ipkg fails:

root@OpenWrt:~# ipkg update
Downloading http://downloads.openwrt.org/kamikaze/7.09/ixp4xx-2.6/packages/Packages
Updated list of available packages in /usr/lib/ipkg/lists/release
Downloading http://downloads.openwrt.org/kamikaze/packages/armeb/Packages
wget: server returned error: HTTP/1.1 404 Not Found
Downloading http://downloads.x-wrt.org/xwrt/kamikaze/7.09/ixp4xx-2.6/packages/Packages
Updated list of available packages in /usr/lib/ipkg/lists/X-Wrt
An error ocurred, return value: 1.
Collected errors:
ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp    -q -P /tmp/ipkg-dwJfQG http://downloads.openwrt.org/kamikaze/packages/armeb/Packages'

I can ping the server

root@OpenWrt:~# ping http://downloads.openwrt.org
PING http://downloads.openwrt.org (195.56.146.238): 56 data bytes
64 bytes from 195.56.146.238: icmp_seq=0 ttl=56 time=38.1 ms
64 bytes from 195.56.146.238: icmp_seq=1 ttl=56 time=37.2 ms
64 bytes from 195.56.146.238: icmp_seq=2 ttl=56 time=37.1 ms
64 bytes from 195.56.146.238: icmp_seq=3 ttl=56 time=37.4 ms

--- http://downloads.openwrt.org ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 37.1/37.4/38.1 ms

Any idea what I need to do?

i have the SAME problem.
thnx

lesid wrote:

I've got a dimilar problem:
I'm running an Nslu2 with Kamikaze 7.09 and Kernel 2.6.21.6

I can update ipkg-opt:

root@OpenWrt:~# ipkg-opt update
Downloading http://ipkg.nslu2-linux.org/feeds/optware/nslu2/cross/stable/Packages
Updated list of available packages in /opt/lib/ipkg/lists/nslu2
Downloading http://ipkg.nslu2-linux.org/feeds/optware/openwrt-ixp4xx/cross/unstable/Packages
Updated list of available packages in /opt/lib/ipkg/lists/optware
Successfully terminated.

But updating ipkg fails:

root@OpenWrt:~# ipkg update
Downloading http://downloads.openwrt.org/kamikaze/7.09/ixp4xx-2.6/packages/Packages
Updated list of available packages in /usr/lib/ipkg/lists/release
Downloading http://downloads.openwrt.org/kamikaze/packages/armeb/Packages
wget: server returned error: HTTP/1.1 404 Not Found
Downloading http://downloads.x-wrt.org/xwrt/kamikaze/7.09/ixp4xx-2.6/packages/Packages
Updated list of available packages in /usr/lib/ipkg/lists/X-Wrt
An error ocurred, return value: 1.
Collected errors:
ipkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp    -q -P /tmp/ipkg-dwJfQG http://downloads.openwrt.org/kamikaze/packages/armeb/Packages'

I can ping the server

root@OpenWrt:~# ping http://downloads.openwrt.org
PING http://downloads.openwrt.org (195.56.146.238): 56 data bytes
64 bytes from 195.56.146.238: icmp_seq=0 ttl=56 time=38.1 ms
64 bytes from 195.56.146.238: icmp_seq=1 ttl=56 time=37.2 ms
64 bytes from 195.56.146.238: icmp_seq=2 ttl=56 time=37.1 ms
64 bytes from 195.56.146.238: icmp_seq=3 ttl=56 time=37.4 ms

--- http://downloads.openwrt.org ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 37.1/37.4/38.1 ms

Any idea what I need to do?

i have the SAME problem.
thnx

Hi,

I wrote a separate thread about this.  The respositories for 7.09 have been moved to a different directory structure.

Try modifying your ipkg.conf file to:

src release http://downloads.openwrt.org/kamikaze/7 … 4/packages
#src packages http://downloads.openwrt.org/kamikaze/packages/mipsel
src packages http://downloads.openwrt.org/kamikaze/7 … ges/mipsel
dest root /
dest ram /tmp

And try again.  The error you see is that ipkg tries to fetch the mipsel package list and can not.

Hope this helps, :-)
P

Hi,

I got the same problem with my nslu2 (slug) with xwrt kamikaze 8.09.
name resolution is ok, ping is ok, but not opkg update.

"opkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp   ... "


The problem seems coming from the the particularity of the nslu2:
It has only one lan ethernet connection, no wan, no wifi.  This device is used generally inside the lan behind another router .

"opkg update" is using wget with passive mode to access repositories. Passive mode expect the remote server to establish another connection from the outside to your slug.

This is working perfectly when the slug itself is connected to the wan but not when another router is natting your slug internal address.

To resolve this, I modified my lan/wan router to have all incomming ports forwarded to the slug.
However, I'm not totally satisfied with this configuration and I would prefer to adapt the slug config to tell it that it is connected behind another router...

any hints?

Pascal

Hi, I'm new to OpenWrt and new to the forum.

I have had problems updating the package list on my NSLU2 and came across the following advice:

# sysctl -w net.ipv4.tcp_ecn=0

or to make the setting persist across boots:

# vi /etc/sysctl.conf

and change
   net.ipv4.tcp_ecn=1
to
   net.ipv4.tcp_ecn=0

Hope it helps,

Greg

Hi,

Great! your suggestion solved the issue.

thank you very much !

Pascal

* opkg_download: ERROR: Command failed with return value 1: `wget --passive-ftp    -P /tmp/opkg-0STueY http://downloads.x-wrt.org/xwrt/kamikaze/8.09/x86/packages/Packages'


EVIDENTEMENTE EL PROBLE ES QUE NO ESTA DISPONIBLE EL WEB X-WRT.ORG, EL QUE EST DISPONIBLE ES OPENWRT.ORG, ASI QUE EDITE EL ARCHIVO /ETC/OPKG.CONF Y CAMBIE LA URL EN LA LINEA SRC QUE FALLABA POR LA OTRA Y ME FIJE QUE O SE REPITA DOS VECES LA PALBRA PACKAGE EN LA MISMA URL Y DE ESTA MANERA SALIO ANDANDO, ENJOY

/ETC/OPKG.CONF
#src X-Wrt http://downloads.x-wrt.org/xwrt/kamikaz … 6/packages
#src X-wrt http://downloads.x-wrt.org/xwrt/kamikaz … 6/packages
src X-Wrt http://downloads.openwrt.org/kamikaze/8.09/x86/packages
src OpenWrt http://downloads.openwrt.org/kamikaze/8.09/x86/packages
#src SnapShot http://downloads.openwrt.org/snapshots/ … 6/packages

dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /jffs

this is pretty easy to fix, at least it was for me.

I just edited the conf to point to the right repository url

vi /etc/opkg.conf (vi sucks balls)

cntrl +a to edit, then shift + zz to save and exit

The discussion might have continued from here.