OpenWrt Forum Archive

Topic: New Broadcom BCM63xx codebase with GPL'd Ethernet and USB support

The content of this topic has been archived between 8 Feb 2018 and 7 May 2018. Unfortunately there are posts – most likely complete pages – missing.

@misteroX,
no open BCM drivers for ADSL, i think this is the only at this moment that we can't make run over bcm963xx boards. All other thinks seems +/- run.

salut

(Last edited by t3l3m4k0 on 3 Dec 2008, 10:25)

Hi everybody,
i've got either an USR9108 rotuer or a DG834GT and i'd like to install openwrt on both.
The problem is that this is the first time i try to do things like these and i'd like to know which are the steps i must follow to install openwrt on those routers.

Any advice is appreciate and i'm sorry if this looks like a n00b post.

Regards

@djdok,
To install openwrt at this moment you must have serial console acces to router.
When router boots, CFE loader can be breack. You can use "help" command to see a list of availables commands.
You can use something similar to this "flashimage 192.168.1.100:firmware.bin" to upload firmware.
If firmware update goes wrong you must have a JTAG interface to debrick device.

Consider, at this moment of developement, if you don't have or can have a  JTAG interface i recommend don't change firmware.

Also DSL is not working.

salut

@ t3l3m4k0

Ok thx for the infos, but i have some questions:
1) to build the "firmware.bin" have to build the 13370?
2) once i can flash the firmware, according to you, will be it possible to install amule on the routers and make them p2p stations?
3) i have another router hamlet hrdsl512w but i haven't found any information on internet about it, how can i get those sys infos?

Thx for your patience
Regards

Hi djdok,
for my DG834GT I used trunk 13370 and router up and runnig without error but adsl did not work.
Last trunk did  not work.
See above post from t3l3m4k0.

To compile trunk 13370 I added this rows into file target/linux/brcm63xx/image/Makefile

# DG834GT
        $(call Image/Build/CFE,$(1),96348GW-10,6348)

and this rows into file build_dir/linux-brcm63xx/linux-2.6.27.7/arch/mips/bcm63xx/boards/board_bcm963xx.c

static struct board_info __initdata board_96348gw_10 = {
        .name                           = "96348GW-10",
        .expected_cpu_id                = 0x6348,

        .has_enet0                      = 1,
        .has_enet1                      = 1,
        .has_pci                        = 1,

        .enet0 = {
                .has_phy                = 1,
                .use_internal_phy       = 1,
        },

        .enet1 = {
                .force_speed_100        = 1,
                .force_duplex_full      = 1,
        },


        .has_ohci0 = 1,
        .has_pccard = 1,
        .has_ehci0 = 1,
};


/*
* all boards
*/
static const struct board_info __initdata *bcm963xx_boards[] = {
#ifdef CONFIG_BCM63XX_CPU_6348
     
        &board_96348gw_10,
        ,
#endif

*****
For developers,
Can you add the rows for DG834GT in the last trunk ?

Bye
MisteroX

(Last edited by misteroX on 5 Dec 2008, 17:24)

@misteroX,
you can submit patch/changeset to https://dev.openwrt.org/newticket
and Florian (thx), sure will submit to trunk.
@ djdok,
1.-MisteroX maked a good mini howto for you.
2.-I believe torrent is best than amule. 16MB maybe not enought ram, try mounting a swap partition. You can try p2p and say if it works.
3.-You can open router an see what kind of CPU holds.

(Last edited by t3l3m4k0 on 5 Dec 2008, 22:20)

Hi all,

@tel3m4k0
Ok, I will write a ticket.

@jow
For my dg834gt I used the trunk 13537 with your patch and router up and runnig without error.

Bye
MisteroX

@jow
your patch, for me,  works with rootfs_data partition but not all clean it does, nvram partition has bad boundaries (see yours dmesg).
for me works better the change of by-one:

   r->end

by

   r->end + 1

in     /bcm963xx-flash.c

i tried several days to identify why it works on early revisions and now no works, and why? we must have to do the described changes. I not detected why.

Salut

Fixed with [13540], thanks guys !

florian_ wrote:

Fixed with [13540], thanks guys !

Hi florian,

I used trunk ver 13544 without jow's patch and router is unable to write anything on the flash.
I've to apply it to make it work correctly.

Can you modify file bcm963xx-flash.c to make my router work correctly ?

if necessary I will open a ticket

Thanks
MisteroX

misteroX wrote:
florian_ wrote:

Fixed with [13540], thanks guys !

Hi florian,

I used trunk ver 13544 without jow's patch and router is unable to write anything on the flash.
I've to apply it to make it work correctly.

Can you modify file bcm963xx-flash.c to make my router work correctly ?

if necessary I will open a ticket

Thanks
MisteroX

Last time I flashed my router it worked well, but I couldn't flash it with the trunk from yesterday 9/12 with a CRC error at CFE console.

I guess it's the same problem that some of you are having, isn't it?

I have to submit also a ticket for my board to get support (board name "F@ST2404").

Greetings!

MisteroX please show me a bootlog of your device, the changeset definitively fixes the computation of partition on all boards that I have tested (4MB and 8MB flash).

@ misteroX, after 13551, all works fine for me (mtd partitions mounted ok).

@ sblanco, i think you must recompile and send again firmware. Origin of CRC error may be from corrupted file (firmware)

greetings

t3l3m4k0 wrote:

@ sblanco, i think you must recompile and send again firmware. Origin of CRC error may be from corrupted file (firmware)

greetings

I did compile several times with always the same result. I have started to troobleshoot downgrading to earlier revisions from the trunk.

Any other firmware installs out of the box, with no CRC complaint, as some weeks ago did.

t3l3m4k0 wrote:

@ misteroX, after 13551, all works fine for me (mtd partitions mounted ok).

@ sblanco, i think you must recompile and send again firmware. Origin of CRC error may be from corrupted file (firmware)

greetings

Hi t3l3m4k0,
for my router trunk 13544 doesn't work.
It works only with jow's patch
I will test the last trunk to see if it works without patch.

At the same time I have sent dmesg to Florian

Bye
MisteroX

@misteroX, still thereis a bug (by-one) in 13544, you must use at least 13551, as i sayed before.
@sblanco, your problem is strange, CRC is calculated by image tools and there is no version change at last revisions

(Last edited by t3l3m4k0 on 11 Dec 2008, 15:20)

t3l3m4k0 wrote:

@misteroX, still thereis a bug (by-one) in 13544, you must use at least 13551, as i sayed before.

OK,  I will try trunk 13551 this evening.

Thanks
MisteroX

t3l3m4k0 wrote:

@misteroX, still thereis a bug (by-one) in 13544, you must use at least 13551, as i sayed before.
@sblanco, your problem is strange, CRC is calculated by image tools and there is no version change at last revisions

Sorry, I was so stupid, I don't know why I changed and tried to flash with f command instead of flashimage.

I could compile (not last trunk as it was unbuildable), now I'm fighting with wireless to get it working. I get this output, firmware gets loaded, but doesn't work properly (see message last line).

root@OpenWrt:/# ifconfig wlan0 192.168.2.1
firmware: requesting b43/ucode5.fw
firmware: requesting b43/pcm5.fw
firmware: requesting b43/b0g0initvals5.fw
firmware: requesting b43/b0g0bsinitvals5.fw
b43-phy0: Loading firmware version 410.2160 (2007-05-26 15:32:10)
ifconfig: SIOCSIFFLAGS: Cannot assign requested address

Bye!

Hi all,
I used  trunk 13595 and router (DG834GT) up and runnig without error.

Bye
MisteroX

misteroX

kamikaze work on DG834GT ?

send to me a flash to write

snipers wrote:

misteroX

kamikaze work on DG834GT ?

send to me a flash to write

Yes, kamikaze works (trunk13595).
Only ADSL Doesn't work but for this view post #126 of t3l3m4k0.

I'll send you a pm with a link where you can download the openwrt-96348gw-10-squashfs-cfe_13595. bin for DG834GT

Bye
MisteroX

For people who have a bcm4318 soldered directly on the PCB, B43 will fail loading the SPROM contents, so we have to fake them. I am cooking up patch that defines sane variables in the board setup code. Later on, when ssb loads, it fallbacks to the faked eeprom.

As a temporary fix, you can use this patch :

--- a/drivers/ssb/pci.c 2008-11-21 00:02:37.000000000 +0100
+++ b/drivers/ssb/pci.c 2008-12-03 22:49:17.000000000 +0100
@@ -26,6 +26,18 @@
 /* Define the following to 1 to enable a printk on each coreswitch. */
 #define SSB_VERBOSE_PCICORESWITCH_DEBUG                0

+const u16 wl_srom_map_4318[64] = {
+/* 000 */ 0x2001, 0x0000, 0x0449, 0x14e4, 0x4318, 0x8000, 0x0002, 0x0000,
+/* 008 */ 0x1000, 0x1800, 0x0000, 0x0000, 0xffff, 0xffff, 0xffff, 0xffff,
+/* 016 */ 0xffff, 0xffff, 0xffff, 0xffff, 0xffff, 0xffff, 0xffff, 0xffff,
+/* 024 */ 0xffff, 0xffff, 0xffff, 0xffff, 0x0000, 0xffff, 0xffff, 0xffff,
+/* 032 */ 0xffff, 0xffff, 0xffff, 0xffff, 0x0003, 0xc992, 0x2b5d, 0xffff,
+/* 040 */ 0xffff, 0xffff, 0xffff, 0xffff, 0xffff, 0xffff, 0x3017, 0x15ae,
+/* 048 */ 0xfa85, 0xfe8d, 0xffff, 0xffff, 0x004c, 0xffff, 0xffff, 0xffff,
+/* 056 */ 0x003e, 0x2848, 0xff02, 0x4652, 0x0010, 0xffff, 0xffff, 0x2602
+};
+
+

 /* Lowlevel coreswitching */
 int ssb_pci_switch_coreidx(struct ssb_bus *bus, u8 coreidx)
@@ -327,6 +339,8 @@ static void sprom_extract_r123(struct ss
        s8 gain;
        u16 loc[3];

+printk("revision %d \n",out->revision);
+
        if (out->revision == 3) {                       /* rev 3 moved MAC */
                loc[0] = SSB_SPROM3_IL0MAC;
                loc[1] = SSB_SPROM3_ET0MAC;
@@ -492,8 +506,12 @@ static int sprom_extract(struct ssb_bus
        return 0;
 unsupported:
        ssb_printk(KERN_WARNING PFX "Unsupported SPROM revision %d "
+               "detected. Will extract v1 using static SPROM\n", out->revision);
+       sprom_extract_r123(out, wl_srom_map_4318);
+/*
                   "detected. Will extract v1\n", out->revision);
        sprom_extract_r123(out, in);
+*/
        return 0;
 }

Hi,

i'm trying to build an image for an Alice Gate Voip 2 Plus (BCM6358KFBG).
I can get a working kernel patching the board_bcm63xx.c file, but i have to compress it with cmplzma (from broadcom)
or to leave it in elf format otherwise CFE will complain about the format.

Naturally the kernel complain about no root partition as i just load the kernel from tftp and there is no root on the flash.

Now i'm trying to build a complete image but when i use flashimage CFE complain about wrong tag, any idea of what could try?

I've hadded in the taget/linux/brcm63xx/image/Makefile  $(call Image/Build/CFE,$(1),AGPF-S0,6358).

Loading 192.168.1.100:openwrt-AGPF-S0-squashfs-cfe.bin ...
Finished loading 2228228 bytes
SGP  tagVersion : 6
image tag unknown 80800000
*** command status = -1

Hi fw_crocodile,

Did you modify the file board_bcm963xx.c with the data of your board ?
For example see my post #130  but this is only for DG834GT.


Bye
MisteroX

(Last edited by misteroX on 15 Dec 2008, 12:57)