OpenWrt Forum Archive

Topic: Netgear WNR2000 OpenWRT (Atheros AP81, AR9103 chip, u-boot)

The content of this topic has been archived between 3 Apr 2018 and 3 May 2018. Unfortunately there are posts – most likely complete pages – missing.

ckm wrote:

give this a try it worked on my v4 it mite work on a v1.

https://www.youtube.com/watch?v=0K8sVuCrPt4&t=0s

they do have a recovery mode.

I had researched that and tried it but I just never get a power light.  Tried the 30-30-30 drill, tried another AC/DC adapter (mine was still OK buy a DMM check) but just never get any indications of any power on the router and nothing ever happens. 

So more than bricked I think it is dead...

Jack

outrage_uk wrote:

I would like to thank fuhry and radengr for their excellent work with the WNR2000v1. I was totally new to OpenWRT this evening - moved from DD-WRT because of the lack of support for this model, and with your instructions, I have successfully flashed my router. big_smile

I intend to create a newbies guide to flashing this router for people like me who don't understand the full technical terms of everything. cool

cool

Hi outrage_uk. Did you create the newbie guide for flashing WRT to the WNR2000v1?
cheers pollock73

WNR2000v1 owners, check this out:

http://www.tnhh.net/posts/lede-on-wnr2000v1-unsupported-hardware.html

(Last edited by ptcruisergt on 23 Dec 2016, 21:07)

Hi WNR2000V1 lovers.

I successfully compiled LEDE Reboot 17.01-SNAPSHOT r3285-111cf1b firmware for our old router. It is fully functional and there are different versions of it.

First, you need to flash Fuhry's bootloader from this forum and  establish a serial connection to the router. You will also have to setup a tftp server  for transferring files.

The installation instructions and the "bin" files are inside this download link >   https://drive.google.com/open?id=0B7XbZ … WVmdzJRMUU

After the installation you will have around 160 Kb free space in the flash. It is not too much. But technically, with that 4Mb flash, there is nothing much to do.

Enjoy.

(Last edited by faruktezcan on 5 Apr 2017, 06:16)

Hello,
I have a v1 and its stuck in a boot loop. I initially installed the openwrt as described, and that was fine.

I tried to revert back to stock, and now it will startup, light the orange power light, light the wifi blue light, and then reboot. Over and over.

i tried turning off the power, and depressed the reset button for 30 seconds while turning on.  That gets the power button blinking green continuously.  I did the tftp command with the stock firmware, and that seemed to be successful. However, the boot loop doesn't go away.

I don't understand the instructions below regarding uboot recovery console. How do you get to that to enter the below commands. Any other suggestions?

prentek wrote:
radengr wrote:

The second (from the uboot recovery console):

mtdparts default
erase nor0,4
erase nor0,1

Then reboot the router, tftp flash a copy of an official firmware from Netgear, and follow the instructions above. Enjoy, and thanks again to fuhry for patching uboot!

Thanks I have manage to unbrick my wnr2000 v1 by this instruction,

Actions

Setup your ethernet network adapter with a static ip. My configuration is:

IP: 192.168.1.10
netmask: 255.255.255.0
gateway: 192.168.1.1

Connect your network adapter and router with the ethernet cable (I have used router's port no.1).

Then power off the router and power on while pushing the reset button. Power led started to blink and i was able to ping again.

I have put orginal software:

tftp -i 192.168.1.1 PUT WNR2000-V1.2.3.7.img

download from ftp://downloads.netgear.com/files/WNR2000-V1.2.3.7.img

!!ATTENTION!!. At this time, your job is finished. Please at this time be patient, because your router is still working for you, as it is writing the firmware you have send to the flash. WAIT patiently, don't ping, don't try to access web interface or something similar. Router will REVIVE on its own! You can begin tweaking the router when power led stops blinking and stays permanently lit up.

That it, it is operational again!

To restore to stock using TFTP put you need to set the binary option.   With the light blinking green due to holding the reset button down while powering up,

tftp -m binary 192.168.1.1 -c PUT <filename>

If it still does not boot, a serial connection would be the next step in troubleshooting.  Serial allows you to observe boot-up messages and enter uboot commands.

(Last edited by mk24 on 10 Nov 2017, 16:17)

The discussion might have continued from here.