OpenWrt Forum Archive

Topic: Trendnet TEW-632BRP, TEW-652BRP, DLink DIR-615 C1, CC WLN2206 working!

The content of this topic has been archived between 29 Mar 2018 and 29 Apr 2018. Unfortunately there are posts – most likely complete pages – missing.

Hello
Happy new year everybody,
i'm searching for a stable version of Openwrt for my Tew-632brp v1.0
Any link please ?
Thanks
Ced

fced wrote:

i'm searching for a stable version of Openwrt for my Tew-632brp v1.0

Most recent "stable" version is Backfire 10.03.1-rc4.
Binaries for ar71xx based devices like TEW-632 are here: http://downloads.openwrt.org/backfire/1 … c4/ar71xx/

Updating from Trendnet TEW-632 factory firmware to OpenWrt: http://downloads.openwrt.org/backfire/1 … actory.bin

Edit:
bleeding edge development trunk builds are here: http://downloads.openwrt.org/snapshots/trunk/ar71xx/

(Last edited by hnyman on 1 Jan 2011, 20:21)

Thankyou,
i will try it (i'm actually on DD-Wrt) but wifi isn't stable, and http interface is very slow..
Ced

fced wrote:

Thankyou,
i will try it (i'm actually on DD-Wrt) but wifi isn't stable, and http interface is very slow..
Ced

I am not sure, if you need the "factory" version or the "sysupgrade" version, if you are updating from DD-Wrt.

Hello
In fact, updating directly from ddwrt web interface to openwrt haven't worked,
i have downgraded to official trendnet firmware from u-boot update interface, and after, i updated from trendnet web interface to openwrt -factory, and then to openwrt sys-upgrade...
thankyou...

Can somebody please share the network config  for TEW-632BRP or point the errors in my config?  I am using Backfire 10.03.1-rc4 image. My usage will be standard home router doing PPPoE on external DSL modem through WAN port with wired and wireless clients. In my current setup I have setup the WAN credentials correctly.  I get ISP ip address and their DNS servers. I can also ping any site from the router console (SSH) but the client machines cannot access any sites. I am suspecting that the routing is not correctly setup. BTW Is the internal connection of eth0/1 same as this architecture ?
Where does WLAN (wireless) get connected?

Here is my config file.

config 'interface' 'loopback'
    option 'ifname' 'lo'
    option 'proto' 'static'
    option 'ipaddr' '127.0.0.1'
    option 'netmask' '255.0.0.0'

config 'interface' 'lan'
    option 'ifname' 'eth0'
    option 'proto' 'static'
    option 'ipaddr' '192.168.1.1'
    option 'netmask' '255.255.255.0'
    option 'defaultroute' '0'
    option 'peerdns' '0'

config 'interface' 'wan'
    option 'proto' 'pppoe'
    option 'username' 'me@provider.net'
    option 'password' 'supersecret'
    option 'defaultroute' '1'
    option 'keepalive' '10'
    option 'ifname' 'eth1'
    option 'peerdns' '1'

config 'switch'
    option 'name' 'eth0'
    option 'reset' '1'
    option 'enable_vlan' '1'

config 'switch_vlan'
    option 'device' 'eth0'
    option 'vlan' '1'
    option 'ports' '0 1 2 3 4'

Hello All,

I'm new to this and just flash this firmware to my Trendnet TEW-625BRP  and now having this problem

- Can't access to the router anymore. I have tried 192.168.10.1, 192.168.1.1, 192.168.0.1 and none of them working
- The status LED is off and there is no wireless available from this router

I was using this frimware http://wrpd.dlink.com.tw/router/firmwar … Cx_Default found from http://www.dd-wrt.com/wiki/index.php/DIR-615C

Please help

Thank you

This (OpenWRT build discussed in this thread) firmware should be applicable to TEW 632 and TEW 652 Generation 1  (v.1.x)
This (OpenWRT build discussed in this thread) firmware should NOT be applicable to TEW 632 and TEW 652 Generation 2  (v.2.x)

What is TEW 625 i dunno, probably some misspelling.

> found from http://www.dd-wrt.com/wiki/index.php/DIR-615C
DD-WRT and D-Link 615C firmwares linked there probably follows the same rules above. But better ask in DD-WRT forum.

> this frimware http://wrpd.dlink.com.tw/router/firmwar
This is not firmware at all, but a chinese HTML text about "404 error"
Probably You misspelled the link.

(Last edited by annoynimous on 15 May 2011, 02:32)

Here is the link of the firmware http://wrpd.dlink.com.tw/ router/firmware/query.asp?model=DIR-615_Cx_Default

(deleted the space after .com.tw/)

It is TEW-652BRP (I'm sorry for the typo)

I think mess this router. It is v2 and not V1

Is there anyway I can recover it to Trendnet firmware?

Thanks

TrenNet got ya! they started selling different things to same name just like D-Link :-(

if there is radiotechnics maniacs around you....
de-soldering EPROM chip from motherboard and reflashing it on a special chip-programmer stand and then re-soldering it back.
or maybe using JTAG, if you manage to

Given the device's current price, i guess u'd either to get some curious fan of soldering, or became one, or drop the case.

1st of all it is quite strange that u managed reflashing - since firmware blob has a signature on the end (in the wiki u mentioned described aboout HEX editor)
Didn't the router refuse to flash with Gen-1 signature?

I download the current Trendnet firmware and look at the code and then changed the code on the file that I downloaded :-(

and the fact that code in article was different from your code did not alerted u ?
and the very fact that TrendNet had TWO different, incompatible firmwares - which implies two different incompatibe devices?

" Good details over on the x-wrt.org site  Stock firmware hacking: http://www.bitsum.com/forum/index.php?& … =45.0;wap2"
Those links were good (more techy), but now they are dead.

The thin chance remains if
1) Gen-2 device has two partitions, bootloader and the firmware itself
2) www re-flashing only overwritten firmware, not the bootloader

Such is sometimes on personal computer parts, like motherboards or DVD-RW
But for routers... i doubt.

This person at least was stopped with file sizes difference http://www.dd-wrt.com/phpBB2/viewtopic. … p;start=15
Bad luck

(Last edited by annoynimous on 15 May 2011, 03:23)

I'm a level 3 solder and no problem with desolder the chip.

Do you know where is the firmware file and what program to do the JTAG.

Thank you

what u downloaded must be the firmware in some wrapper for WWW update.
try to grok the dd-wrt / open-wrt scripts, they show how to wrap, so u may figure out how to unwrap

Hi,

Do you know Trendnet TEW-651BR has the same hardware as others in this post so it can be flashed with some openwrt linux firmware? Thanks.

S.

thanks for clearing things out. i opened the router and saw three ICs: one RTL something, one 2x3 dots with two lines above and below something, and one MX something. this is wrong i guess.

i will consider probably in the future acquiring a router running linux: exactly i want to retrieve wireless parameters of the connections and be able to send them back. i was thinking some kind of ssh (?) but i don't have experience with firmware linux, what interface (serial or ethernet or even wireless) and in what way can i connect to an embedded device; is it different from the way you would use a linux driver in C? thanks.

ps: i meant these posts or this topic, sorry.

(Last edited by sjbiaga on 1 Nov 2011, 18:47)

RTL most probably stands for Realtek - vendor of network chips, sound chips and embedded processors. Realtek.com.tw website

632 and 652 were on Atheros revisions 1.0 and 1.0, bur revision 2.0 comes on R-somthing. Probably Realtek as well. Or maybe RALink, dont remember.
PS: here confirmation: http://wiki.openwrt.org/toh/trendnet/tew652brp10r

And now there is even 652 version 3.x! http://trendnet.ru/products/catalog/det … -652BRPv3x

PS: those routers are running Linux.
It is just not community-driven Linux.

I only had 632/652 revision 1.x
There you could just save config on the router Tools Webadmin page.
This config could be unpacked by 7-zip (or maybe it even was not compressed, do not remember) and then displayed as text with for example Notepad++

I think it is still the same because, u know, just why they would change it ?

Why u talk of drivers ? Network settings are not mantained by drivers.
FreeBSD (and routers fw based on it) uses their script set.
On desktop Linux usually RedHat /etc/netconfig scripts are used. They are ugly but widespread used and supported. Including support from GUI wizards like NetManager
On AltLinux /etc/net scripts are used, which are great for wired net, but not very good for Wi-Fi
*WRT are targeted on machines small by CPU and by Memory - so they have their only little-size network scripts.

What are used in Trendnet ? Dunno, unpack thei firmware and look inside :-)

(Last edited by annoynimous on 1 Nov 2011, 22:33)

The webadmin and save config can be done through the asp pages on my router too for network settings.

It keeps logs too which can be sent with SMTP.

But no way backwards, like a tiny background process to retrieve wifi monitoring parameters.

S.

you may try to remove from config all settings, but those related to wifi

if such a reduced config can be estored, then it would be that "be able to send them back"

in early days of 632 there was some person, who reversed its firmware, described hardware and such
he also made modified hardware with ssh
but later it was out of interest and  there only left description on berlios.de for it

Just FYI/FWIW, I added a hardware version 3.2R printed-circuit board photo to the TEW-652BRP OpenWRT wiki.

http://wiki.openwrt.org/toh/trendnet/tew632brp

(That pages covers both the 632 and 652.)

(Last edited by Anakin2 on 12 Feb 2012, 19:00)

Greetings from a Newbie here on the board with a question from Columbus, Ohio:

I have TEW-652BRP that works fine EXCEPT it does not permit loop back. Since I'm running a web server, it would be nice to be able to see the server via DNS from the LAN side of the house. Folks on the WAN have no problem seeing my pages.

Can the config.BIN file be modified to allow this?

Any and all suggestions would be helpful

Thanks,

Dave in Columbus, Oh

Has anyone figured out  how to flash a TEW652BRP V1 from linux?  I get to the interface, but no browser I found is successful at sending the image.  I've tried Opera, Firefox, and Chrome.

I don't have windows available.... Any help?

there were attempts at installing MSIE 5/6 under WinE, maybe as part of Cross-Over office.

you can also try emergency recovery mode instead of full-featured UI, dunno if it helps or not.

I have a weird problem with a tew-652brp v3.2R (3.02b02), original: 3.00b13
After i bought it, it worked great for about 3 weeks then the problems started:
The first few days the wireless would just randomly turn off and i had to reboot it.
After a few days if i try to restart after the wireless was gone all the leds (except the wlan) are always on and the unit is basically bricked for 3-4 days ( if i try to power it in that interval the same story with the led's ) after 3-4 days have passed i power the router and it works just fine for 2hours-24 hours then the fun starts all over again.

When it first started doing this i waited for it to work and flashed it with 3.02b02 hoping for a miracle and it worked for about 24-48 hours then it started again...

P.S. while all the leds are on i can't even get it in recovery mode... (if i try to put it in recovery mode i can get a connection but no packets are being sent by the router)

I even tried opening it to see if it's too hot and that's not the case, at some point after it acted up i put it in a bag and threw it in the freezer for 5 minutes and nothing... still all the leds but the wireless constantly on...

Any ideea what i can do ( besides returning it / warranty / tech support - don't ask why... )

(Last edited by mad on 13 Oct 2012, 20:11)

The discussion might have continued from here.