OpenWrt Forum Archive

Topic: Inventel Livebox

The content of this topic has been archived between 17 Apr 2018 and 18 Apr 2018. Unfortunately there are posts – most likely complete pages – missing.

Hi ruff,AndyP and danitool,

I'm trying to compile with a new revision 19500 for livebox but.....I got error applying patch "platform/046-cramfs_endianness.patch". It seems garbage. Can I compile it without this patch on this newer revs?

Applying patch platform/046-cramfs_endianness.patch
patch: **** Only garbage was found in the patch input.
Patch platform/046-cramfs_endianness.patch does not apply (enforce with -f)
make[2]: *** [/home/rollerdk/livebox/kamikaze/trunk/build_dir/linux-brcm63xx/linux-] Error 1
make[2]: Leaving directory `/home/rollerdk/livebox/kamikaze/trunk/target/linux/brcm63xx'
make[1]: *** [menuconfig] Error 2
make[1]: Leaving directory `/home/rollerdk/livebox/kamikaze/trunk/target/linux'
make: *** [kernel_menuconfig] Error 2


Hi again,

I'm trying to compile with a new revision 19500 for livebox without patch "platform/046-cramfs_endianness.patch" but now I got this error:

(make V=99)

  SYMLINK include/asm -> include/asm-mips
  CALL    scripts/
  CHK     include/linux/compile.h
  CC      arch/mips/bcm63xx/boards/board_livebox.o
In file included from arch/mips/bcm63xx/boards/board_livebox.c:29:
arch/mips/include/asm/mach-bcm63xx/board_bcm963xx.h:61: error: array type has incomplete element type
make[7]: *** [arch/mips/bcm63xx/boards/board_livebox.o] Error 1
make[6]: *** [arch/mips/bcm63xx/boards] Error 2
make[5]: *** [arch/mips/bcm63xx] Error 2
Can anyone help me please? I don't understand the error.


Hello people .... i have an inventel box, and i have compiled the firmware ... as it says danytool .... however ... my rs232 ttl doesnt work well (dunno why) and i have flashed the redboot that supports control C and flashed the openwrt.cramfs to dev/mtd1 from liventel software ....... but now doesnt works ...... and i can not connect to redboot through console .....
i have used wireshark to see what it says .... and when it starts ... it puts his ip through grauitous arp .... but i can not login into redboot 9000 port through network .... it isnt supported by default no? i have read in somewhere that ruff can connect to 9000 port ... if so .. i could enter and flash my router better :S

thx for all

well various things ... after flashing the redboot that can be stopped with controlC the inventen can not be restored with normal firmware, because it is encripted
so i had to build the serial cable. now it works
if we turno on fconfig net_debug true, we can connect to redboot through telnet in 9000 if we have the botton one pushed. the botton one configures network for doing the load.

after i have boot the openwrt the wifi wasnt started because something in my config, i have boot with luci interface (that goes very slow dunno why) and i have been able to put wifi on.
Now i am fighting with brctl and wifi in modo sta, i want to bridge wifi and network but when i add eth0 or eth1 to the br0 with wifi0 ... i can not ping anything and without them yes.

Thank you for the good work people smile

can this openwrt firmware build enable this router to act as a  repeater,client bridge

thanks in advance

well in the latest trunks there is a new daemon in openwrt:
In theory it can act as a pseudo - client bridge.
I only tried client, and wds client, both working pretty well. I don't know about wds/ap, so who knows... Some feedback in this forums would be nice......

Can we use VOIP service on ours Livebox with OpenWRT?

sinusq wrote:

Can we use VOIP service on ours Livebox with OpenWRT?

No, there aren' drivers for this, again propietary modules.

(Last edited by danitool on 5 Dec 2011, 13:50)

any one could help now..
I tried to flash openWRT
so I started FTP server - replaced RedBoot to redbootelnet03.rom, (lb and telnet worked after it), I changed my IP to , and with openwrt-livebox.bin in FTP dir. I reset lb (holding 1 button) - but LB didnt take file from (3 LEDs flesh but no FTP connection in logs) - right now, I tried few times, checked ftp connection with tcmd and now I cant connect to LB, or even use RGWRepair (Ive got boot error).

What can I do now with this problem?

use TFTP server not FTP !!!!

my mistake, still - I have access to Redboot , rw permision in tftpboot - run tftp server
but - when I put openwrt-livebox.bin in tftpboot and keep "1" it's doesnt upload to LB, same when I try use 'list' command with squashfs files with redboot (also checked with … x_recovery metode)- all commands works, but I cant downlad files to LB..dont know if it mistake with tftp (tried on Windows, Ubuntu, Fedora), or sth wrong with LB..(my LB always starts very long)

I have access only with ethernet cable..any ideas what I made wrong..;( and what I can do..

its very likely that I will read  this topic after NY, so  - I wish Happy NY to everyone!!

hey guys,

was running kamikaze on my livebox, before i decided to mount a usb storage device. tried to install block-mount which showed errors. so decided to compile a new firmware using the new patch posted with all the mount utilites and everything. well, to cut a long story short, flashed the new kernel (checked the tftp log to confirm openwrt-livebox.bin transfer) but after the flash process i could not telnet the livebox. tried flashing again both with the newly compiled and the old  firmware but still no response upon telnet and now to make things worse after a few attempts the redboot tftp client is not connecting to the server on my system. the log is empty. has anybody got a clue how i can recover the livebox from this failure??any help would be appreciated.thanks

Probably you'll need a serial console to watch what's happening.

thanks dani, tried failsafe mode but that does not seem to work either. time to rig up a serial console and see whats going on.


hey guys,

tried everything i could, finally decided to replace redboot loader with jtag. had a few questions though, do i need to plug in the power to the router when using redim for byte reordering?? also on the EJTAG pins on the router what do i have to connect to Vcc and GND(almost certain that GND is pin 25 of the parallel port)?? any help would be much appretiated.thanks very much.

If you use an unbuffered JTAG cable … unbuffered
You only need to connect TDI,TDO,TMS,TCK and GND

There are several methods/applications to write to the flash, this is one I used succesfully, with the hairydairimaid utility:
You don't need to plug the power for using redim, btw I've provided the redboot already byte swapped, thus redim is not needed if you use the CUSTOM.BIN I've postet at the wiki.

Probably UrJtag or Tjtag would work either without byte reordering (redim).

(Last edited by danitool on 15 Feb 2012, 20:34)

cheers dani, flashed redboot via JTAG, using the latest openwrt you uploaded, too scared to use my own compiled version, thats the one that broke the router in the first place!!cheers mate, long live open source

The discussion might have continued from here.