Hi All !
Kamikaze 8.09 branch : 2.4 for Broadcom
Well, let's say i'm trying to get a fix IP@ for my WAN port :
#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto static
# option proto dhcp
option ipaddr 172.16.94.245
option netmask 255.255.255.0
option gateway 172.16.94.250
No way to ping 172.16.94.250 !!!
root@crys:~# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
172.16.94.0 * 255.255.255.0 U 0 0 0 eth0.1
192.168.94.0 * 255.255.255.0 U 0 0 0 br-lan0
default 172.16.94.250 0.0.0.0 UG 0 0 0 eth0.1
root@crys:~# ping 172.16.94.250
PING 172.16.94.250 (172.16.94.250): 56 data bytes
--- 172.16.94.250 ping statistics ---
8 packets transmitted, 0 packets received, 100% packet loss
root@crys:~#
But with :
#### WAN configuration
config interface wan
option ifname "eth0.1"
option proto dhcp
# option proto static
# option ipaddr 172.16.94.245
# option netmask 255.255.255.0
# option gateway 172.16.94.250
# option dns "172.16.94.250"
It works !!!
root@crys:~# ping 172.16.94.250
PING 172.16.94.250 (172.16.94.250): 56 data bytes
64 bytes from 172.16.94.250: seq=0 ttl=64 time=2.325 ms
64 bytes from 172.16.94.250: seq=1 ttl=64 time=2.201 ms
64 bytes from 172.16.94.250: seq=2 ttl=64 time=4.584 ms
64 bytes from 172.16.94.250: seq=3 ttl=64 time=2.174 ms
--- 172.16.94.250 ping statistics ---
4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max = 2.174/2.821/4.584 ms
root@crys:~#
DO YOU HAVE ANY CLUE TO HELP ??? :0(
Thanks to you