Hello,
I've (sort of) had success flashing an SVN trunk build as of yesterday. I made the IDE cable serial port cable mentioned earlier in this thread up (thanks for that - what a brilliant design - works perfectly) and the device boots and Wifi appears to work on 802.11g - but I get some packet loss on n, as mentioned.
However, DHCP isn't working on the "internet" port, which seems to be eth1.
udhcpc starts on boot, and 'ps' shows it running (udhcpc -i eth1), but no address. If I kill this process and then run it manually I *usually* get an address, but it is intermittent.
While trying to debug the problem I ran iptables -F, -X, -t nat -F etc to clear the firewall rules in case they were in the way.
I set a manual IP address using ipconfig, and could ping the other end. However, on occasions where udhcpc failed manually I could not ping the other end.
I installed tcpdump on the router, and it *looks* as though I do not see the ping/DHCP requests using tcpdump when the device is failing - i.e. they're going AWOL somewhere in the kernel.
I seem to be able to reproduce my problem:
- power on
- killall udhcpc
- ifconfig eth1 192.168.1.20 (eth0 port is configured as 192.168.2.1 - so this address should be valid, and 192.168.1.1 is my old router at the other end of eth1.) I don't think the router is at fault as the same problem occurs with the cable modem directly connected.
ping the wireless router at the other end - ping 192.168.1.1 - this will probably work
If I then type 'ifconfig eth1 down' it stops working - fair enough.
If I then type 'ifconfig eth1 up; ifconfig eth1 192.168.1.20' and then do the ping again it doesn't work.
If I type 'ifup wan' it restarts udhcpc etc, but again no joy - the interface seems to have gone dead.
The same thing can be reproduced by typing '/etc/rc.d/K40network stop; K40network start'.
My /etc/config/network is as follows (I tried commenting out the switch section in case this was the problem):
config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.2.1
option netmask 255.255.255.0
config interface wan
option ifname eth1
option proto dhcp
config switch eth1
option reset 1
option enable_vlan 0
#config switch_vlan
# option device eth1
# option vlan 1
# option ports "0 1 2 3 4 5"
The problem occurs with two different devices at the other end of eth1.
When it is in the failed state I can monitor traffic on eth1 - it just seems like no data gets out.
I suspect (knowing me) I'm doing something *really dumb* but the intermittentness of this puzzles me. Can anyone point out the obvious post I've missed in this forum? I've tried reading them all but I bet I've missed something critical!
Thanks,
Colin