OpenWrt Forum Archive

Topic: WL-500 GP mode client broadcom and mode AP in USB (ralink)

The content of this topic has been archived on 7 May 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi:

I got a wp-500gp install a ralink USB and I have this problem so my par on the network settings because I get an ip out of range.

Please help me to configure the network



vi /etc/config/network


root@OpenWrt:~# vi /etc/config/network

config 'switch' 'eth0'
        option 'vlan0' '1 2 3 4 5*'
        option 'vlan1' '0 5'

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'type' 'bridge'
        option 'ifname' 'eth0.0'
        option 'proto' 'static'
        option 'netmask' '255.255.255.0'
        option 'ipaddr' '192.168.1.1'

config 'interface' 'wan'
        option 'ifname' 'eth0.1'
        option 'proto' 'dhcp'

config 'interface' 'ap'
        option 'ifname' 'wlan1'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.225'
        option 'netmask' '255.255.255.0'




this is another important information for users configure your openwrt  and use ralink USB in mode AP and broadcom for mode client:


root@OpenWrt:~# vi /etc/config/wireless

config 'wifi-device' 'wlan0'
        option 'type' 'mac80211'
        option 'channel' '6'
        option 'txpower' '27'
        option 'disabled' '0'

config 'wifi-iface'
        option 'device' 'wlan0'
        option 'mode' 'sta'
        option 'ssid' 'Vinyols Online'
        option 'encryption' 'psk2'
        option 'key' 'evameumis3'
        option 'network' 'wan'

config 'wifi-device' 'wlan1'
        option 'type' 'mac80211'
        option 'disabled' '0'
        option 'chanel' '1'
        option 'txpower' '11'
        option 'channel' '1'

config 'wifi-iface'
        option 'device' 'wlan1'
        option 'encryption' 'none'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'ssid' 'CompuArc'

Hello,

which Kernel do you use? How did you installed the device so that "wlan1" is available? I planned the same configuration like you, but my router brigged while i tried to get the ralink device to work :-(

FIRST: SORRY FOR MY BAD ENGLISH MY CATALONIAN NATIVE

My usage last kamikaze and install especific drivers and all dependencies rt2xxx usb (web inteface, system, software)

My software:

                        r1142-1
                        installed
                       
               
                    aoetools base-files-brcm47xx 14-r14511
                         bridge
                     busybox
                     cfdisk
                     dialog
                     dnsmasq
                     dropbear
                     e2fsprogs
                     fdisk
                     firewall
                     firmwarehotplug
                     fuse-utils
                     fxload
                     glib1
                     hostapd
                     hotplug2
                     iptables
                     iptables-mod-conntrack
                     iptables-mod-nat
                     iw
                     kernel
                 kmod-b43
                     kmod-crc-itu-t
                     kmod-crypto-aes
                 kmod-crypto-arc4
                 kmod-crypto-core
                     kmod-crypto-michael-mic
                     kmod-diag
                     kmod-fuse
                     kmod-ide-core
                     kmod-ieee80211
                     kmod-ipt-conntrack
                     kmod-ipt-core
                     kmod-ipt-nat
                         kmod-ipt-nathelper
                     kmod-mac80211
                     kmod-ppp
                     kmod-pppoe
                     kmod-rt2500-usb
                     kmod-rt2x00-lib
                     kmod-rt2x00-usb
                     kmod-rt73-usb
                     kmod-scsi-core
                     kmod-switch
                     kmod-usb-acm
                     kmod-usb-core
                     kmod-usb-storage
                     kmod-usb-uhci
                     kmod-usb2
                     libblkid
                     libext2fs
                     libfuse
                     libgcc
                     liblua
                     libncurses
                     libnl
                     libopenssl
                     libpcap
                     libpthread
                     libuci
                        0.7.3-1
                     libuci-lua
                     libusb
                     libuuid
                     lua
                     luci-admin-core
                     luci-admin-full
                     luci-admin-mini
                     luci-app-firewall
                 luci-cbi
                 luci-core
                 luci-http
                 luci-i18n-english
                 luci-ipkg
                 luci-sgi-cgi
                 luci-sys
                 luci-theme-base
                        0.8.6-1
                 luci-theme-openwrt
                        0.8.6-1
                 luci-uci
                 luci-uvl
                     luci-web
                        0.8.6-1
                     mc
                     mtd
                     ntpclient
                     opkg
                         pciutils
                     ppp
                     ppp-mod-pppoe
                     uci
                     uclibc
                         udev

                     udevtrigger
                     usb-modeswitch
                         usbutils
                     wavemon
                     wireless-tools
                     wpa-cli
                     wpa-supplicant
                         zlib
                    


and edit this

root@OpenWrt:~# vi /etc/config/wireless

config 'wifi-device' 'wlan0'
        option 'type' 'mac80211'
        option 'channel' '6'
        option 'txpower' '27'
        option 'disabled' '0'

config 'wifi-iface'
        option 'device' 'wlan0'
        option 'mode' 'sta'
        option 'ssid' 'Vinyols Online'
        option 'encryption' 'psk2'
        option 'key' 'evameumis3'
        option 'network' 'wan'

config 'wifi-device' 'wlan1'
        option 'type' 'mac80211'
        option 'disabled' '0'
        option 'chanel' '1'
        option 'txpower' '11'
        option 'channel' '1'

config 'wifi-iface'
        option 'device' 'wlan1'
        option 'encryption' 'none'
        option 'network' 'lan'
        option 'mode' 'ap'
        option 'ssid' 'CompuArc'


Please check this for resolve ip problems (ex:269.x.x.x) in my new ap ralink rt73-usb

vi /etc/config/network

config 'switch' 'eth0'
        option 'vlan0' '1 2 3 4 5*'
        option 'vlan1' '0 5'

config 'interface' 'loopback'
        option 'ifname' 'lo'
        option 'proto' 'static'
        option 'ipaddr' '127.0.0.1'
        option 'netmask' '255.0.0.0'

config 'interface' 'lan'
        option 'type' 'bridge'
        option 'ifname' 'eth0.0'
        option 'proto' 'static'
        option 'netmask' '255.255.255.0'
        option 'ipaddr' '192.168.1.1'

config 'interface' 'wan'
        option 'ifname' 'eth0.1'
        option 'proto' 'dhcp'

config 'interface' 'ap'
        option 'ifname' 'wlan1'
        option 'defaultroute' '0'
        option 'peerdns' '0'
        option 'type' 'bridge'
        option 'proto' 'static'
        option 'ipaddr' '192.168.1.225'
        option 'netmask' '255.255.255.0'

P.D: Gracias a jordi Fredolic

(Last edited by vinyols on 15 May 2009, 00:37)

Can you please enter "iwconfig" and post the results her, thank you!

root@OpenWrt:~# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

eth1      no wireless extensions.

eth0.0    no wireless extensions.

eth0.1    no wireless extensions.

br-lan    no wireless extensions.

wmaster0  no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"Vinyols Online"
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:22:F7:08:6C:A5
          Bit Rate=11 Mb/s   Tx-Power=27 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:03FD-7616-2CAE-8871-BD00-6DDD-4D59-C01A [3]   Security mode:open
          Power Management:off
          Link Quality=45/100  Signal level:-67 dBm  Noise level=-63 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wmaster1  no wireless extensions.

wlan1     IEEE 802.11bg  ESSID:""
          Mode:Master  Frequency:2.412 GHz  Tx-Power=11 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

br-ap     no wireless extensions.

mon.wlan1  IEEE 802.11bg  Mode:Monitor  Frequency:2.412 GHz  Tx-Power=11 dBm
          Retry min limit:7   RTS thr:off   Fragment thr=2352 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

If you go at the webfrontend to "wireless", is there the Wlan1 interface selectable?

YES all found in interface web

install drivers and edit /etc/config/wireless

My only found this in client mode

Help me please for ap mode

(Last edited by vinyols on 16 May 2009, 14:12)

The discussion might have continued from here.