OpenWrt Forum Archive

Topic: WL-500gP dead with kamikaze 8.09

The content of this topic has been archived on 29 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

* Present: the router is an Asus WL-500gP and is dead: when powered up the 4LAN+WAN leds are on (from the first moment, no blinking) and the rest are off and there is no activity on any eth port - not a single frame (as reported by a direct connected tcpdump/wireshark). can't say what exactly is the problem but probably the BIOS is broken also.
* What happened: I was running whiterussian (kernel 2.4) and everything was fine until I decided to upgrade to kernel 2.6 no matter what the wireless problems are or might be. I downloaded kamikaze 8.09 (kernel 2.6 for brcm47xx: openwrt-brcm47xx-squashfs.trx) and installed it on the router through whiterussian webinterface. It worked nice, I logged in with telnet, changed the passwd, 'uname' confirmed the kernel 2.6 and then I ssh-ed into it successfully.
After 3 min rebooted automatically and after 2 such reboots (at 3-5 minutes) died. So it lived with 2.6 for about 6-8 minutes.
I tried restart with the power on pressed many times without success I also tried the pin 9 ground method also without success.
Just before each restart I successfully logged into the LuCI web interface; therefore there are big chances that the LuCI interface did something very wrong.
Does it worth finding a jtag cable and and try my best to mount it? Will the jtag cable for sure solve the problem?
Are there any other solutions (except the ones that I already tried) that I can try before I throw it in a box for the next 10 years hoping in a miracle?

there is no JTAG, but maybe you could do something with the serial port.

Did you try the firmware restoration mode (press restore(?) for a few seconds while connecting to power)? (There is no power-button on the device, as you described)
Then the power-led should flash slowly, and you can download a new firmware via tftp or the Asus Utility.
If that doesn't work, the boot loader is probably damaged, or even worse occured.
Grounding any pins without proper knowledge of THAT PARTICULAR device is very adventurous, and can be mortal.

yes, I did, with the power button I ment reset button

Did you try the asus restauration tool? It already helped me when I wasn't able to ping my router.

(Last edited by zorxd on 22 May 2009, 18:17)

I tried that too, without success. In order to use the firmware restoration tool you need to have one of the interfaces working (also some LEDs - the power one - should blink) and as I said, I believe the interfaces are dead. I'll give a try with the serial cable although I'm not very hw oriented but it doesn't seem complicate; I'd like to avoid this because if it doesn't work I wold not know if is the cable I just made or the router, but it seems the only solution.
I find very strange the way it happened (after a successfully installation): the LuCI interface should be reviewed because this is a very serious bug; anyway, the cause is a default running software after a fresh install.
If someone else can confirm the same problem and symptoms, it should go to bug report also.

Check your power adapter, a friend of my had the same symptoms as you're describing and it turned out to be a bad power adapter.

true, I replaced the power adaptor and it started again.

Yeah, this phenomenon - i.e. the adaptor failing somehow - is not unknown to me either. Because of its cheap&crappy fabrication, some capacitors 'explode' ('they lift their hat' as a more hardware-oriented colleague of mine pointed it out). The result is an idle voltage of 5V but only 4V under load. I had the capacitors replaced and the adaptor works fine again. Bottom line: always be prepared with extra adaptors (or capacitors) if you use an Asus WL500gP... smile

This is exactly what has been occuring with me.
I have installed the lastest kamikaze 8.09.1 release on my WL-500g P r1.1.
I can telnet and ssh into it but when i change something and issue the reboot command the box, which was working perfectly before, goes incommunicado.
I cannot reset it and restart. No amount of button pressing brings it back to life.
I have managed to bring it back to life by opening it up shorting pin 9 and waiting till it goes back to life flashing.
I am uncertain that the PSU is the fault because the original asus firmware stayed up for hours and rebooted without any problems on the box.

I had power supply problems all I had to do is change the capacitors in the power supply

Hi everyone,

I need JTAG pinout for wl-500gp v1,
The pin 9 trick doesn't work, the CFE is corrupt or deleted, the RS232 console does not show anything when connected, and I do not have acces to a Flash programmer or AVR.

Thanks in advance,


I had similar power supply problems. Router was not booting up. Or even if it started successfully, it was losing the packets like crazy.

It started with boot problems: all LEDs were up and light (maxbe except power LED and WIFI). Sometime it went further and seemed operation but it didn't respond to ping and did not give any sign of life.
Then I started it with another power adaptor, it started successfully. Next day (again with the faulty adaptor) I recognized that Internet is interrupted from time to time (say once in every 2-3 minutes). I was monitoring it with continuos ping.
Then I investigated the router from close and discovered that power led blinks once when ping loss happens. Sometimes even all LEDs were light for a short time.
I replaced the power adaptor and after that not a single packet loss!

My lesson from this: faulty power supply can cause weird things...

(Last edited by markov333 on 19 Oct 2009, 21:42)

I guess this is a common problem with the 500gP.  I came home today to find one of mine in the state described by the first post on this thread.  The router had been plugged in and running for a year.  As I have a couple of these routers, I just tried out another power supply after reading the suggestions in this thread and -voila!-  the router is running again.  Now I just have to buy a new PS...

the solution is that when these equipments runs for long time they get warmed up so we must make the environment cool

The discussion might have continued from here.